Jump to content
3000AD Forums
Sign in to follow this  
Guzzler

EMD slow down

Recommended Posts

With the v2.09 betas I was so busy doing Ground Ops (it takes a long time to eliminate all the insurgents in the Sol system) that I never got into any big space battles.

Well I finally got into one now with the v2.09 final and noticed that when several of the enemy turn on their EMD's and they start flashing, my computer comes to almost a complete stop. My frame rate will be in the mid to high 50's and then will plummet to 1 FPS (which I think is a generous 1).

I am using a PII 350 with 128 mb Ram and Voodoo 3 card. While the frame rate will slow down somewhat in very heated ground battles it stays high enough that the controls are smooth and game play is no problem. With a couple of enemy activating their EMD's the frame rate drop and choppiness become so bad that I can barely track and hit a stormcarrier, let alone anything smaller.

So the question is, since I really like the enemy being able to use advance tactics like activating their EMD, is their any way to disable the blinking/flashing effect that occurs and seems to kill my FPS?

If there is no way to prevent the frame drop, then what system will I need to keep the frame rate up, especially with BCM on the horizon?

Last question, just out of curiosity, what was the correct Forum for this topic? I couldn't decided if it belonged in Tech Support or New Version, so I wimped out and put it here.

Guzzler

"It is easier to ask for forgiveness than to ask for permission."

Share this post


Link to post
Share on other sites

I have that same problem with the final version. I figured I had it configured wrong, at first anyway. Is there a way around the slow down?

Share this post


Link to post
Share on other sites

Considering that:

  1. v2.09 was in testing since v2.08 was released on 09-15-99, giving enough time for people to notice this or complain about it.

  2. v2.09 is the last patch for v2.0x

  3. I have never (nor has anyone else that I know of) experienced this 'slowdown' until this post.

  4. I don't experience the problem

You have the following choices:

  1. go back to 2.08

  2. use the TTD declutter command and turn off the TTD entirely, leaving only the currently targeted entity.

Eitherway, not only am I not touching that code again, I don't regard it as a bug and am I not likely to optimize it either.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×