Jump to content
3000AD Forums
Sign in to follow this  
Supreme Cmdr

UCAWA 1.00.10 Patch Released

Recommended Posts

Use the game Updater to download and apply the patch.

The online VCF has also been updated.

NOTES:

If you use the game's Updater, the process will go like this:

  1. If you have any version lower than 1.00.07, it will download the 1.00.07 update first. After applying this, you need to run Updater again so that it can download the incremental update to 1.00.10
  2. If you already have 1.00.07 or higher installed, it will download only the incremental update to 1.00.10

Also, you can now view the VCF directly from the Updater (once it has self-updated itself to the newer version which supports this).

If you don't want to use the Updater, then you have to check one of the public mirrors for a link to the full v1.00.10 patch; which you should then copy into the game's folder and execute from there.

WARNING: DO NOT DOWNLOAD THE PUBLIC PATCHES AVAILABLE ON DOWNLOAD MIRRORS IF YOU HAVE THE DOWNLOAD (DIRECT2DRIVE, TRYMEDIA ETC) VERSION OF THE GAME!! USE THE UPDATER INSTEAD. ONCE THE PUBLISHERS MAKE THEIR VERSIONS OF THE PATCH AVAILABLE, THE UPDATER WILL DOWNLOAD THEM. THE TIMETABLE FOR THOSE PATCH RELEASES IS UP TO THE PUBLISHER DUE TO HOW THEIR PROTECTION SYSTEM WORKS.

[ 11-22-2005, 07:16 PM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

I have a download version of UCAWA. When I'm running the updater it downloads the 1.00.10 patch. But when it's in install stage I get a message saying "Can't find the file .ucAWA_1.00.10_inc.exe. Check that you have the right name and try again." The file is there though. Am I doing something wrong here?

Share this post


Link to post
Share on other sites

1. go to your UCAWA install folder

2. find the file named 'settings'

3. open it in notepad

4. look up the section entitled application, it should read something like the following:

[APPLICATION]

Name=UNIVERSAL COMBAT A WORLD APART

Location=D:Program Files3000ADUniversal Combat A World Apart

After the Location= should be the folder where your game is installed (Mine's installed on drive D, yours might be in a different location) if it isn't, (I'm guessing it's reading Location=.) change it manually to your actual install location.

5. Save the file and exit, then retry using the updater. (It should work properly now, though it will download the file again in the process)

Hope that fixes your problem (I got the same error myself until I performed the steps above, haven't had a problem using it since)

Share this post


Link to post
Share on other sites

Thanks. That did the trick. Dose that setting get strange because I didn't use the default install folder?

Installed on D:D games etc...

Share this post


Link to post
Share on other sites

I can't be sure, but my installation isn't in the default directory either.

Share this post


Link to post
Share on other sites

Dunno why you folks need to change anything, because the default path for the patch install is the current folder. This is what the default SETTINGS.INI file looks like. When the Updater downloads the patch, all it does it copy it to the game's install folder. Then it executes it. The only reason this will fail, is if the Updater can't find the file it downloaded. There should be no reason to change the SETTINGS.INI file at all, since the . location denotes the current folder. So there must be a reason why this setting works fine for some people, but you folks have to manually add your game install folder. I'm going to investigate this some more. Thanks for providing the work-around Ben.

code:


[uPDATER]

runmode=full

selfupdate=
http://downloads.3000ad.com

[uPDATEINFO]

URL=
http://downloads.3000ad.com
/updateinfo.xml

servertimeout=2000

[APPLICATION]

Name=UNIVERSAL COMBAT A WORLD APART

Location=.

version=1.00.02


Share this post


Link to post
Share on other sites

i had the same problem (using download version). I never post about it because is a minor problem and could fix it. Maybe could be some problem only for "no english" version of windows.

Share this post


Link to post
Share on other sites

I think I gotthe same error when I first try the updater. I didn't noticed it later because I download patches manually.

Yes, I have edited the install folder too to another location.

Possibly the installer don't update all the settings with the info gathered during the install process.

Share this post


Link to post
Share on other sites

I need a guinea pig to try this.

Edit SETTINGS.INI and make the following changes;

  1. version=1.00.10 to version=1.00.08
  2. location=. to location=%updater%

Save the file and run Updater again. It should check the server, download the patch, copy it (from the temp download folder) to the game folder and execute it.

Share this post


Link to post
Share on other sites

OK. Thats just strange why the default location= setting works for some people and not others. Oh well. At least now we know.

Share this post


Link to post
Share on other sites

*moved*

quote:


Originally posted by Azaran:

very well done on the latest patches, i've played all night and no crashes at all, no bugs, absolute heaven.

Now if i can only play like a professional commander and less like a drunken one armed one eyed monkey with all the co-ordinative and planning skills of a three week old mouldy biscuit, i'd be sorted! *Grins*


Share this post


Link to post
Share on other sites
Sign in to follow this  

×