Jump to content
3000AD Forums
Sign in to follow this  
Supreme Cmdr

UCAWA 1.00.16 Patch Released

Recommended Posts

This patch requires the April 2006 (or later) DirectX runtime

Use the game Updater to download and apply the patch.

The online VCF has also been updated.

NOTES:

If you use the game's Updater, the process will go like this:

  1. If you have any version lower than 1.00.07, it will download the 1.00.07 update first. After applying this, you need to run Updater again so that it can download the incremental update to the latest version. You will have to run the Update multiple times to get all the updates to the latest version.
  2. If you already have 1.00.07 or higher installed, it will download only the incremental update to the latest version.

If you don't want to use the Updater, then you have to check one of the public mirrors for a link to the full patch; which you should then copy into the game's folder and execute from there.

Though this latest patch contains a new SETTINGS.INI file, if the Updater downloads the patch but it doesn't run or you discover that it didn't patch, you may need to edit the SETTINGS.INI file in Notepad and make the following changes :

  1. version=1.00.15 to version=1.00.16 (or change this to whatever the previous version was)
  2. location=. to location=%updater%

Then save the file and run the Updater again.

WARNING: DO NOT DOWNLOAD THE PUBLIC PATCHES AVAILABLE ON DOWNLOAD MIRRORS IF YOU HAVE THE DOWNLOAD (e.g. DIRECT2DRIVE) VERSION OF THE GAME!! USE THE UPDATER INSTEAD. ONCE THE PUBLISHERS MAKE THEIR VERSIONS OF THE PATCH AVAILABLE, THE UPDATER WILL DOWNLOAD THEM. THE TIMETABLE FOR THOSE PATCH RELEASES IS UP TO THE PUBLISHER DUE TO HOW THEIR PROTECTION SYSTEM WORKS.

Share this post


Link to post
Share on other sites

I found some issues in the language.lng file today and which affects the priority list menus. The patch will be reissued today to include the fixed file.

Will advise when it is available via the Updater and D2D.

UPDATE: The server now has the fixed version. Just run Updater as normal and it will indicate that 1.00.16.01 is available. Note that the version number for the game will not change. It will still show 1.00.16 in the main menu.

The update is currently only on the update server. The download mirrors and the D2D versions will be up later today.

[ 08-01-2006, 06:45 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

I'm getting a weird error with the updater, it connects to the server and reports that there is a new patch available (1.00.16.01), I click next and am taken to the progres bar, but then instad of downloading the new patch, an error window comes up, saying

Error

Can't copy file Updater.

on clicking the more button, it displays

There can be several reasons for this error. The file is not available or the file is in use by another application.

Share this post


Link to post
Share on other sites

I am getting the same error, but I am actually only trying to update to 1.00.15. I hadn't patched to that level yet.

Share this post


Link to post
Share on other sites

Works just fine here. I just tried it on four machines.

If it downloads the file but can't copy it from the temp folder to the game folder, then its a problem on your end.

Also, your SETTINGS.INI file should look like this

code:


[uPDATER]

runmode=full

selfupdate=
http://downloads.3000ad.com/selfupdate.xml

[uPDATEINFO]

URL=
http://downloads.3000ad.com/updateinfo.xml

servertimeout=2000

[APPLICATION]

Name=UNIVERSAL COMBAT A WORLD APART

Location=%updater%

version=1.00.16


Share this post


Link to post
Share on other sites

That's exactly what mine looks like, only the version line reads

version=1.00.15

and it won't download the new patch.

Share this post


Link to post
Share on other sites

Well, I just changed it to 1.00.15 and it still works.

What exactly is the problem? None of these reports make any sense to me.

Also, what is the date/time stamp of the updater.exe file?

Share this post


Link to post
Share on other sites

Man, you guys are killing me. If you have an older version of the updater.exe file, it will try to update itself AFTER it applies the patch. Thats the error message you are getting because apparently it can't find the updated version of updater.exe on the server. I'm going to look into that now.

The patch was already applied but it rolls back the entire op.

UPDATE: Try it now.

[ 08-01-2006, 05:15 PM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

Same error.

To clarify:

1. Run updater.exe

2. Click 'Next'

3. New Version (1.00.15) available! - click Next

4. Download files - the progress bars don't move, error pops-up right away "Can't copy file updater"

5. Click OK, Rolling back changes, 100%, Click Finish, app exits.

My updater.exe is 579KB, Modified April 11, 2006 10:13AM

Share this post


Link to post
Share on other sites

The D2D version is now up on the updater server. I suspect that IGN will link the new version on their UCAWA downloads page later this afternoon.

Share this post


Link to post
Share on other sites

Any way to know if it is the new version or not?

Share this post


Link to post
Share on other sites

If you downloaded it after my post above, then its the new version. IGN sent me email shortly after my post to let me know that they have refreshed their download version as well.

Share this post


Link to post
Share on other sites

Updater is still giving the same error, only now after downloading the patch. Is there another way to get the latest version of the updater?

Share this post


Link to post
Share on other sites

Ben, it works fine. So the problem has to be on your end. NOTHING in the Updater has changed. If you can't get it work, well, download the patch from one of the mirrors which have been updated.

I even copied an older version of Updater to my runtime folder and ran it.

It connected to the server and downloaded the patch.

Then it downloaded an updated version of itself.

Then the patch was applied.

Share this post


Link to post
Share on other sites

I am getting the same error, but it happened differently. It downloaded to 83% this time, and then failed with the 'can't copy file updater'.

Now if I run the updater again, it is failing right away (at 0%).

Anyway, just an FYI, I will download from a mirror.

Share this post


Link to post
Share on other sites

OK, enough with the Updater posts. It works just fine. If you can't use it, find a download mirror already.

[ 08-02-2006, 02:38 PM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

UPDATE: To prevent Updater from attempting to download and update itself, I have uploaded the latest version. Just unzip and overwrite your older version.

Now let me know if the Updater works or not. If you've already updated by downloading from a mirror, edit settings.ini and change the version to 1.00.15 first before running Updater again.

Share this post


Link to post
Share on other sites

The new updater worked perfectly for me.

Thank you for your effort SC.

Share this post


Link to post
Share on other sites

OK, that only works now for you folks because Updater does not need to update itself, since the version you manually downloaded is the same as the version on the server.

I discovered that this problem is with it self updating from the 03-20-06 version of Updater to the latest 07-14-06 version. When I ran my tests, I used an older 08-18-05 version which worked just fine. But when I located and used the 03-20-06 version, I had the same problem as you folks. Sorry for doubting you, guys (Ben, Case et al). Its been a long week; especially with the UCSE release and all.

I have contacted the author. He's pretty good about fixing bugs, so this should be easy.

In the meantime, anyone having problems with Updater self updating, should just download the latest version and overwrite their existing version before continuing.

If you're NOT having this problem (because you are using an older version of Updater), you don't need to do anything because in that case the self update process works just fine.

[ 08-18-2006, 09:21 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

all's well that ends well

Share this post


Link to post
Share on other sites

I recently formatted and reinstalled UCAWA from my CD. When I ran the updater it downloaded patch 1.00.16.01 and patched it.

It didn't do anything incremental like download patch 1.00.07 and then the latest patch, like you alluded to in your first post.

anyhow when I try to run the game now, the intro runs then it quits saying

Error Loading connect.dat

Share this post


Link to post
Share on other sites

It won't download 1.00.07 unless the version on the CD is older. You should've checked what version you have first.

The error loading means that the game is not installed correctly and has nothing to do with the patch.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×