Jump to content
3000AD Forums
Sign in to follow this  
Cruiser

CTD and intruders

Recommended Posts

Not calling you stupid SC, people talk past each other sometimes thats all, especially when it concerns software.

Ok then, I give up.

If there isn't anyone who will comment on this, who actually have the UCAWA 1.00.11 installed, and have experienced the same PERSCAN problem (or have tried my saved game), then I guess there's not much more I can do about it.

Aren't there really anybody who has tried my save game and - like SC - isn't able to reproduce? I'm not posting here because I expect SC to help me, it's just as much you other guys - Who has BTW been very kind to help me before... thx.

(and no, I'm not talking about the old and already fixed problem concerning intruders being transported).

Share this post


Link to post
Share on other sites

I think we're having a language problem here. I never said that you were calling me stupid.

As I've said before, I CANNOT fix what I CANNOT reproduce. And since - thus far - nobody has reproduced it on their own or with your saved game, what does that tell you? Even the debug build I sent you, does not exhibit the problem.

Share this post


Link to post
Share on other sites

Cruiser, can you please zip up these files and send to me via email please. Don't forget that if you don't have the name of the game in the email subject, my spam filter will reject it.

All the INI files in the DATA sub-folder

All the INI files in the root of the game folder

The files above are for your D2D installation btw, not the Starforce version.

Share this post


Link to post
Share on other sites

Will do.

I'll send an email called "UCAWA - Intruders CTD INI files - D2D - Cruiser".

You can expect me to send them about 1700 hours GMT.

Thanks.

Share this post


Link to post
Share on other sites

Ok, sent the files to your profile email. Files are from my fresh D2D install with applied 1.00.11 by the updater util.

BTW, I noticed some debug log files in my folder also. Just tell me if you want them.

Again, thanks for helping me out.

Share this post


Link to post
Share on other sites

I got the files and will check them out later.

Did you read my last PM from yesterday and re-download the file again to check it out?

Share this post


Link to post
Share on other sites

I just re-downloaded the file, and re-applied it to my Starforce folder. Still CTDs.

I will now try to re-install D2D, apply the Starforce ini, protection and exe files again to see what happens.

Share this post


Link to post
Share on other sites

quote:


Originally posted by Cruiser:

I just re-downloaded the file, and re-applied it to my Starforce folder. Still CTDs.


Which CTD are you getting now? Because you told me on PM that you couldn't even run the game with the latest update I sent you.

Share this post


Link to post
Share on other sites

Ok I will try to be more specific. I wrote "It seemed to result in the same CTD's as above". I meant the intruders CTDs. Still the same.

If I experience any other crash than the one I've been posting about I will let you know.

I've never had one CTD anywhere else in the game while we tested this. If I've indicated this then I'm sorry for the confusion.

Share this post


Link to post
Share on other sites

I just tried a clean D2D install, applied the Starforce INI archive + update 1.00.12.01.

Still CTDs in PERSCAN when I've watched intruders for a while.

Just so you know, every other aspect of UCAWA is very stable on my machine. I have let it run for several days, entered FP mode, attacked bases and never one CTD. Only intruders CTD seems to persist.

Share this post


Link to post
Share on other sites

So what you're saying is that the D2D 1.00.11 and the Starforce 1.00.12.01 builds both give you a CTD when viewing PERSCAN if intruders are on board?

Well, I'm stumped. I can't reproduce it, so I can't fix it.

You might want to start a new game, go somewhere where you don't start a chance of intruders showing up (e.g. one of the sub-regions in Jupiter) and run some tests again.

I don't believe that this has anything to do with intruders and the only way to be sure, is to remove them from the equation. So, do this and give you personnel orders so they move around the ship and view them from PERSCAN.

ps: Did you get my email? If so, please send me the requested file.

Share this post


Link to post
Share on other sites

quote:

So what you're saying is that the D2D 1.00.11 and the Starforce 1.00.12.01 builds both give you a CTD when viewing PERSCAN if intruders are on board?


Yes, with the exception of the debug build, which never crashed once.

quote:

You might want to start a new game, go somewhere where you don't start a chance of intruders showing up (e.g. one of the sub-regions in Jupiter) and run some tests again.

I don't believe that this has anything to do with intruders and the only way to be sure, is to remove them from the equation. So, do this and give you personnel orders so they move around the ship and view them from PERSCAN.


Ok, I'll run some tests the next few days. I'll also let it be in PERSCAN all night. Does it remove intruders to disable NPC auto generation?

quote:

ps: Did you get my email? If so, please send me the requested file.


Just sent it.

Share this post


Link to post
Share on other sites

I sent you a reply. It looks like you are mixing D2D and SF files. You are also using the same saved game to run these tests, when you should have used a new one.

So, please follow the instructions in the email I just sent and report back.

Yes, if you run a Roam scenario with AG off, no intruders will be generated.

My thought process is that if this is not an intruder problem, then it could be something else. One way to clarify that, is to remove the intruders from the equation.

Not using the same saved game (which has the intruders) also removes the issue of it being a corrupted saved game.

Using the SF version - and it too crashing - eliminates this issue as being a problem in the D2D version (which only differs from the SF version in terms of copy protection).

Share this post


Link to post
Share on other sites

Yes, I will do exactly as you write in your mail.

In case I didn't make it clear before, then I've tried to:

1. uninstall UCAWA and delete folder

2. re-instal and run updater -> D2D v1.00.11

3. Start new game

4. Wait for intruders

5. Save the game.

6. Restore it and watch PERSCAN

7. CTD.

Tried with both the Megaron and MK3 because I realize that I always per reflex start with the Megaron.

Thanks.

Share this post


Link to post
Share on other sites

The saved game you sent me and the log, showed that there was planetary activity. There wouldn't be any planetary activity if you were using a NEW and CLEAN profile while you were in space.

And if the intent is to prove that it is intruders that are causing the problem, why do you need to save and restore the game? If its the intruders causing it, then it should eventually crash as long as they are on board; without you having to save and restore.

You are continuing to confuse this issue.

Share this post


Link to post
Share on other sites

quote:

The saved game you sent me and the log, showed that there was planetary activity. There wouldn't be any planetary activity if you were using a NEW and CLEAN profile while you were in space.

Yes, that log was from my old Starforce folder which I played with for a while before the testing. I looked in the fresh install, and it hadn't any log information. (yes one log file with one file stating that some fx module was being initialized if I remember correctly).

quote:

And if the intent is to prove that it is intruders that are causing the problem, why do you need to save and restore the game? If its the intruders causing it, then it should eventually crash as long as they are on board; without you having to save and restore.

When testing the intruders issue, I only get CTDs 80% of the time. Therefore the save before testing.

quote:

You are continuing to confuse this issue.

Share this post


Link to post
Share on other sites

quote:


Originally posted by Cruiser:

Yes, that log was from my old Starforce folder which I played with for a while before the testing. I looked in the fresh install, and it hadn't any log information. (yes one log file with one file stating that some fx module was being initialized if I remember correctly).


You will only get a log file if you add /d? (where ? = 1 to 5) to the shortcut.

quote:


When testing the intruders issue, I only get CTDs 80% of the time. Therefore the save before testing.

Thats not good enough. I have had that same game running continuously in both the D2D and SF version with no such crashes.

If you want to reprodue it reliably, do NOT introduce - yet another - variable to the equation i.e. the use of a saved game.

Also, we need to know in what version this started happening. So before you start your next batch of tests, I suggest that you run the original D2D version of the game (which I think is 1.00.10) WITHOUT doing ANY patch upgrades.

If you still get the crashes in that version, THEN you can upgrade to 1.00.11 and then on to the 1.00.12.01 which I sent you earlier today.

You need to also be running in window using /w1 and with debug logging using /d2 also. This way, if/when it crashes, at least something will be displayed on screen or logged to the .log files.

Share this post


Link to post
Share on other sites

Understood. I'll get right on it this weekend. I'll write exactly what I did in the test, so you can correct my in any mistakes.

Share this post


Link to post
Share on other sites

Ok, I've been doing some testing on the intruders / PERSCAN CTD issue. I've uploaded all log files for download.

***********************************

TEST 1, Original D2D v.1.00.08. ran with /d2 /w1

- Started new game, ROAM + NPC auto gen, got intruders and CTD'ed. Logs are included in the file mentioned above.

- Started new game, ROAM + no NPC auto gen, ran for approx. 12 hours in PERSCAN while all marines on search duty (like when intruders board my ship) , no CTD. Logs are also included even though no CTD.

***********************************

TEST 2, D2D v1.00.11 (by updater util), ran with /d2 /w1

- Started new game, ROAM + NPC auto gen, got intruders, CTD

************************************

TEST 3, D2D -> SF v1.00.12.02 (custom build that you sent me), ran with /d2 /w1

- Started new game, ROAM + NPC auto gen, got intruders, no CTD

- Just to try, I loaded my old save game but even after many tries, no CTD

********************************

Bottom line: I was able to get both D2D v1.00.08 and D2D v1.00.11 to CTD just by starting new game and run until intruders boarded my ship. I ran in PERSCAN all the time, but did only CTD when I was boarded.

I was not able to get the SF v1.00.12.02 to CTD, even when, as a last resort, I tried loading my intruders save game. No CTDs.

Note that sometimes had to try several times to get the CTD with TEST 1 & 2. Sometimes being boarded by intruders did not cause my machine to crash. But even with intensive testing, I could not get SF v1.00.12.02 to crash. I can't conclude anything though because I could just have been "lucky" knowing that the D2D version did not crash in ALL tests.

I will of course also be testing in full screen, and still try to see if I can get the SF version to crash. Will let you know if I'm successful.

Well thats all for today, please tell me, if I screwed up the test scenarios somehow.

Thanks, Cruiser.

Share this post


Link to post
Share on other sites

Hope I'm not jumping in where I don't belong, but I just wanted to say that I've had the Perscan crash with intruders since I downloaded the D2D version in late December. I had hoped the 1.00.11 patch would correct the problem, but no luck. It looks like you gentlemen are hot on the trail, though... The problem isn't a "game-breaker" by any means, but it is annoying and detracts from an otherwise great game so I'll continue to follow this topic with high hopes and fingers crossed.

Share this post


Link to post
Share on other sites

I got a CTD with intruders in SF v1.00.12.02 in full screen (1024x768) just now. And I have an idea (partly) why it didn't crash in the other tests with SF version.

I noticed during a test that the PERSCAN looked like this. As you can see the intruders section where collapsed.

When I tried to drag it open, it CTD'ed instantly. I tried this twice to be sure. I've updated the logs mentioned in my previous test report with the CTD logs.

I will now test the /w1 mode and see if it behaves like this also.

Share this post


Link to post
Share on other sites

Yes, just tried this with the /w1 option also.

First perscan starts with the collapsed intruders section, and an arrow pointing up (see image in last post).

Then when I try to drag it, it changes to a double arrow (up and down). I also took a screen shot of this.

If I then again try to drag this section (with the double arrows) it CTDs instantly.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×