Jump to content
3000AD Forums
Sign in to follow this  
Supreme Cmdr

Galactic Command - Echo Squad SE Demo/Preview Tech Support

Recommended Posts

The IGN sneak preview is based on 2.00 RC16 build.

The general preview version (available to select members here) is based on 2.00 RC15 build.

Both of these versions will expire seven days after being installed. The official demo due out around the end of February and before the game's March 3rd release, will be non-expiring. It will also be based on a different build level.

You can check the VCF for more info on these builds.

Please post all your tech issues/questions in this thread only please.

Share this post


Link to post
Share on other sites
Right, as soon as I launch, I crash. I am assuming there is no widescreen support?

You're the first person to report any sort of crash; apart from that one guy who sent me an email saying he was trying to run it on a 64-Bit version of Vista, even though the FAQ

clearly indicates that its not supported.

And since I have no idea about your system info or what conditions you're running under, we can't help you. The game includes an extensive FAQ. Please look at it.

The game does support widescreen (here are some 1080p shots). Please refer to the product info. You however should not force a screen mode because that can and will cause a crash in the video driver. Any mode that your card/monitor supports is listed in Config. So e.g. if you don't have widescreen support, you won't see widescreen resolutions (e.g. 1280x720) there and should instead use 1280x960 or whatever is listed as being supported by your hardware.

Also just to ensure that you're using the same version as everyone else, be sure that you have downloaded the latest update (first post in this thread).

Share this post


Link to post
Share on other sites
I found some controller issues with the mouse and keyboard flight controls, namely some conflicting key maps:

A (without any other simultaneous key presses) is both roll left/slide left and the autopilot toggle, which means the roll/slide function is lost

D (without any other simultaneous key presses) is both roll right/slide right and the designate target button, so if you have a target selected, you can't use this button to roll right

I've actually changed this in the .23 update. Funny thing is that nobody noticed. Until now ;) I guess thats probably because most people don't use the keyboard to fly etc

These two are displayed in the game commands help file in the keyboard controls, cockpit views/tactical and miscellaneous images. (I just noticed the miscellaneous image has the key combo for game frame rate and version info wrong, should be ctrl V, not V, this works fine and doesn't conflict, just the help file has it wrong. I haven't checked out everything, I will look some more tonight)

Now that I didn't notice. I'll take a look a the commands file and have Joerg correct it. The V key should be colored Blue, as in CTRL+V

right click when using mouse flight controls brings up the tactical targets in the current region, instead of launching a missile (this one I need to test out a little more to make sure)

That mouse button no longer launches missiles. it is used exclusively for the HUD pop-up target menu. The game commands chart is incorrect and will be updated.

the issues with A, D and right mouse click are not game-killers, since there are other keys available that will do the same, but they are more awkwardly placed.

yep

Share this post


Link to post
Share on other sites

I got a chance to fire it up again tonight and I seem to be plagued with alpha map issues. Hud elements, exhaust, lens flares, space debris all are showing black around the textures. I tried reducing all the setting to minimum to see if that helped and patching up my video card to the latest drivers but to no avail. It's been ages since I got into my system profile so I'll post what I can here:

Problem: Black boxes around alpha mapped textures

Game version: 2.00.21

Video card: ATI Radeon X850 XT

Video Card Drivers: Catalyst 8.2

Processor: AMD Athelon 64 X2 dual core 4400+

RAM: 2gb corsair

OS: Windows XP pro 32bit SP2

The only thing I haven't done yet is a clean install to see if that fixes it. I've had issues from time to time with the Radeon line (one day I'll shell out the extra money for an NVIDA) so it might just be a card problem and nothing to do with the game.

Share this post


Link to post
Share on other sites

I have that same card line (X800) here actually. No such issues. Any such issues are either card or driver issues. Send two screen shots to [email protected] and let me take a look. We're going Gold on Friday and nothing is preventing that from happening; especially not - yet another - crappy driver issue from ATI. But I'll see what I can dig up.

ATI is notorious for crap like that in their card/drivers and there is nothing that we can do about it.

In fact, we had a similar problem with these cards back in July and on the original Echo Squad game. They broke the decoding of BMP images. Yes, really. They didn't fix it and we had to kludge around it. Apparently some ATI cards don't seem to interpret this Pixel Shader correctly. We have to workaround it. They subsequently escalated it to the driver team. We never heard from them again about it. Hence the workaround above. Thats ATI for you.

Here are some examples of their incompetence in this regard. These were all compiled in my issues dB back when I was investigating this.

http://www.rage3d.com/board/showthread.php?t=33887006

http://www.overclock.net/ati/184805-x1950-...rtifacting.html

http://forums.guru3d.com/showthread.php?t=215584

http://forums.guru3d.com/showthread.php?t=220220

http://www.futurehardware.in/571827.htm

http://www.futurehardware.in/562568.htm

http://www.geexbox.org/forum/viewtopic.php...5c1a665c2b446a8

http://forumz.tomshardware.com/hardware/x1...pict219813.html

http://forums.fallenearth.com/fallenearth/...ead.php?p=36210

http://www.hothardware.com/printarticle.aspx?articleid=958

Share this post


Link to post
Share on other sites

Yep, shitty card. Toss it in the garbage when you get the chance.

The X850 supports floating point render targets but does not support alpha blending while using them. This is exactly the same reason that blooming in Bioshock doesn't work on that card.

http://discussions.hardwarecentral.com/sho...ad.php?t=170528

Same issues with FarCry

http://boards.slackercentral.com/archive/i...hp/t-74987.html

We'll probably add a separate code path for this, but of course it will lose ALL the blooming, HDR, cool effects etc. Thats the price you pay for having a crappy card I guess.

Share this post


Link to post
Share on other sites

Figures as much. I guess it's time to snag a new one, any suggestions? I've had it do junk like this from time to time before. Do you still want me to send you the screenshots?

Share this post


Link to post
Share on other sites

No need for the shots, since I already know what the issue is.

However, I am currently building a .24 update with the floating point checks I mentioned earlier. When its uploaded, just download and apply it. Then run the game and tell me how it looks. It won't look as good as the shots, but at least the textures would be rendered correctly.

As far as getting a new card, no matter what anyone tells you STAY AWAY from ATI cards. Any nVidia 8800 class card is good enough. You can pick up a PNY 8800GTS 320MB video card cheap these days. If you can afford it, then go for the PNY 8800GTS 640MB or anything in that range.

Share this post


Link to post
Share on other sites

OK, nice to have my easy access rolling back ;)

One minor thing I had to double check, when viewing the tutorial doc in-game, I can only view up to page 12 and no further. All the other docs can be viewed with no problems, and the tutorial doc linked to from the docs folder works fine when viewing it in acrobat reader, it's only when viewing it in-game that this issue occurs. Anyone else getting this?

Share this post


Link to post
Share on other sites
One minor thing I had to double check, when viewing the tutorial doc in-game, I can only view up to page 12 and no further. All the other docs can be viewed with no problems, and the tutorial doc linked to from the docs folder works fine when viewing it in acrobat reader, it's only when viewing it in-game that this issue occurs. Anyone else getting this?

Yes, I just noticed it too.

Share this post


Link to post
Share on other sites

The tutorial used to be 12 pages until I decided to change the orientation to landscape and then reformat it. That increased it to 22 pages and I forgot to update the code. Fixed now in RC25 build

Keep it coming guys, two more days to Gold. Anything that comes in after 02/29, is going in a day zero patch update.

Fired it up tonight with the new patch (yay for no black boxes!) and had some fun familiarizing myself with the controls and looking things over.

I can't comment much on the graphics, but what I can get are nice if a tad dark inside the cockpit.

Thats because there is no HDR and thus the tone mapping which makes the lighting look better also requires HDR. I'll see if we can figure something out to make things brighter when HDR is not in use.

Share this post


Link to post
Share on other sites

2 issues, shame this is my last night of testing, I'm out all next evening and then my 7 days are up :) ):

Issue 1:

I tried docking with the GCV-Merlin and I was told it was an invalid docking target, although the manual says that I can dock with it (end of page 5- start of page 6):

In command of GCV-Excalibur and the Wildstar Fleet, is Tacops Commander Mark Stryker.

Other ships in the fleet include the GCV-Merlin, a Nightstar heavy carrier commanded by Strategic Commander Ruby Law, GCV-Stalingrad, a Starcarrier heavy cruiser commanded by Fleet Commander Nat Mason and GCV-Boston, a Starcarrier heavy cruiser commanded by Fleet Commander Jack Dearth.

Each of the carriers has several wings of fighters assigned to them and you can dock with either of these carriers (as well as with friendly stations) for repairs, refueling and rearming.

Issue 2:

I've also worked out what issue stingray was talking about in the adrenaline vault forum thread you linked to. It's a hotspot clash in the restore saved game menu. It's an old issue with the frontend that I maybe never got round to reporting, or someone did a long time ago and it wasn't considered important.

at 1024 x 768 resolution (maybe at others, I don't know if it changes with resolution, my monitor doesn't go any higher), the hotpsot for the sixth save slot in a profile clashes with the accept button and the hotspot for the sixth profile slot clashes with the cancel button.

To reproduce (example 1):

start new game,

choose any profile slot EXCEPT the 6th one from the top (i.e. make sure that one remains unused)

enter name, start a scenario (it doesn't matter which one)

as soon as it starts up, choose exit (full save)

save in the sixth save slot from the top in that profile

restore

choose the profile you just saved (so that the sixth save slot appears)

click on restore

the accept button is almost totally blocked (just the top edge of it sticks out above the hotspot for the sixth save slot, and that is where you can click on it to activate it), the cancel button is not above a used hotspot, so is not blocked at all and all of it can be clicked on.

example 2:

same as before except choose the 6th profile slot from the top and save in any slot you like.

When restoring ANY profile, the 6th profile hotspot is immediately under and blocks the cancel button in the same way as the sixth save slot blocks the accept button (so if you select the profile from example 1 above, both buttons will be blocked, otherwise just the cancel button will be blocked)

I hope that clears things up (and restore stingray's faith in his laptop ;) )

Share this post


Link to post
Share on other sites

You can only dock with Excalibur in the preview/demo version.

I'll look into the Frontend hotspot issue now that I have a lot more info to go on.

When you license expires, the .25 patch will extend it by another 14 days. It should display a new hardware fingerprint when the first (.16) license expires. When it does, send it to me via PM. If it expires and you don't get that new hardware fingerprint prompt, let me know via PM.

Share this post


Link to post
Share on other sites

LATEST VERSION

There are two versions, please ensure that you download and execute the correct one!!

WARNING: PAY VERY CLOSE ATTENTION TO THE INSTALL PATH DISPLAYED WHEN YOU EXECUTE THIS PATCH OR IT WILL INSTALL TO THE WRONG FOLDER!! By default it auto-selects the folder in which you installed the sneak preview, as this is stored in the registry.

v2.00.26 - Tester/Media version

For changes since the FULL v2.00.16 build, see the Version Control File.

Share this post


Link to post
Share on other sites

Ben, let me know if you are still getting the hotspot detection issue.

Eclipse, I need feedback on the lighting tweaks for that non-HDR card you're using.

Share this post


Link to post
Share on other sites

Checked it out tonight, looks great with the changes!

Share this post


Link to post
Share on other sites

Ah nice. Thanks for your help.

So, there you have it. Folks with a non-HDR card won't have to b*tch and moan at me come next week or wait for something that would never get addressed (like in those other games) ;)

Share this post


Link to post
Share on other sites

Thanks for putting that fix in! Now to head over to the other thread and post my combat experience ;)

Share this post


Link to post
Share on other sites

hotspots issue is cleared, works great now. ;)

I found the following issues in the manual, things that seem to have been left over from the previous edition (will hopefully save some people complaining about things they can't do):

Page 12, Section 4.1 (NID description):

To select and cycle targets, use the . and , keys or move the mouse into the display and then click on the desired target. If the mouse is over more than one target, the target info is stacked and the current target is displayed with a flashing > marker. Each click of the mouse will then cycle to the next target and the marker will move to that target (if any) in the cluster.

again, page 13, (WTS description):

To select and cycle waypoints in the list, use the . and , keys or move the mouse into the display and then click on the desired waypoint.

and again, page 15, section 4.2 (TRS description):

To select and cycle targets, use the . and , keys or move the mouse into the display and then click on the desired target. If the mouse is over more than one target, the target info is stacked and the current target is displayed with a flashing > marker. Each click of the mouse will then cycle to the next target and the marker will move to that target (if any) in the cluster.

Page 18 (VID description):

Also in this view, if you launched a missile (e.g. STS-Vagrant) which has an infra-Red camera and you wish to revert to viewing the target instead of the missile's camera view of the target, press the V key.

when I tried this in-game, it just cycled the VDD normally, returning back to the missile view

Page 31 (TACOPS, planetary scan description):

To revert to the previous map level and all the way back to the global map, just right-click repeatedly or press the NUMLOCK key on the numeric keypad.

right clicking in tacops brings up the tactical targets menu, and doesn't zoom back in tacops.

Page 37 (USING GUNS):

The laser intensity of the gun can be modified in increments of 10% up to a maximum of 100% by clicking inside the GUNS box or by using keyboard commands. The higher the laser intensity, the slower the gun recharge rate, but the more damage inflicted on the target. Each percentage of intensity increases the damage factor by the intensity setting. Therefore, if the setting was 50%, the target would get hit at the rate of 50% plus the default value of the damage factor.

This is no longer in the game, as far as I can tell?

Page 43 (lighting quality):

HIGH = On pixel shader 2.0 and higher cards, this setting is the same as the MEDIUM setting on these cards.

MEDIUM = On pixel shader 2.0 and higher cards, this setting is the same as the HIGH setting on these cards.

I assume this should be the other way round :) ?

You stated earlier that the fighter's stats in the game manual are identical to the one in the UC games appendix (e.g. in UCCE). I found a couple of differences, are they deliberate or further typos in the manual?

Page 46 (Starlance):

GUN SHOT SPEED 750m/s

in UCCE appendix this is 1.5 km/s, same as all the others

Page 47 (IC mk1):

GUN SHOT RATING 16.0 units/shot

in the UCCE appendix this is 45 units/shot. Perhaps the shots per second value was accidentally copied?

Also, the game_keys.png file in the docs folder (linked to from the start menu shortcut) hasn't been updated to match the changes in the in-game images.

There are a few other non-critical minor typos (that don't change the meaning of what is being said), but I'd have to go through the whole thing carefully to catch them all.

Share this post


Link to post
Share on other sites
hotspots issue is cleared, works great now. ;)

heh, that would never have been reproduced without your detailed description.

I found the following issues in the manual, things that seem to have been left over from the previous edition (will hopefully save some people complaining about things they can't do):

I'll have them corrected. I may have missed them when I did my previous checks.

Page 43 (lighting quality):

I assume this should be the other way round :) ?

No, its correct.

You stated earlier that the fighter's stats in the game manual are identical to the one in the UC games appendix (e.g. in UCCE). I found a couple of differences, are they deliberate or further typos in the manual?

Page 46 (Starlance):

in UCCE appendix this is 1.5 km/s, same as all the others

The UCCE appendix (take a look at the OBJDEFS.SCR in the GBS files) is wrong. The Starlance uses the shotm1r type rated @ E25 damage and H750 speed. The ICMK1 uses shotm3r @ E45 / H750

Page 47 (IC mk1):

in the UCCE appendix this is 45 units/shot. Perhaps the shots per second value was accidentally copied?

This was a typo. It should be 45

Also, the game_keys.png file in the docs folder (linked to from the start menu shortcut) hasn't been updated to match the changes in the in-game images.

The patch installer didn't include the new version, thats all.

Share this post


Link to post
Share on other sites

hehe, I have to justify your generosity to me somewhow, don't I? ;)

Share this post


Link to post
Share on other sites
hehe, I have to justify your generosity to me somewhow, don't I? ;)

LOL!! Absolutely!!

So how is the card coming along?

Share this post


Link to post
Share on other sites

working very nicely, I can put all the graphics settings up to virtually maximum without it affecting my framerate, my poor little CPU doesn't know what hit it :) It gets pretty hot though, so I should maybe look at installing some case fans. Now I gotta go update my system profile

Share this post


Link to post
Share on other sites

Since we're going Gold next week, I won't be releasing another public update. All official testers, please fallback to Area 51. If you don't have access, send me a PM.

I have updated the VCF to reflect changes since the recent .26 release.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×