Jump to content
3000AD Forums
Sign in to follow this  
Stalintc

UCCE: 1680x1050 ctd

Recommended Posts

Hi all,

I was unsure whether to post this up or not as it could be a problem with the configuration of my OS, but after alot of testing different configurations I thought it might be worth posting here, perhaps someone can reproduce following my steps?

Description

When the game is set to run at 1680x1050 when I leave my ship\vehicle\etc and enter first person mode a ctd happens, this also happens when loading up an Instant Action scenario which begins in first person mode.

When the game is first installed I go into config to setup my settings and I go for 1680x1050 for resolution, then if I were to load up a marine IA scenario or leave a ship in any campaign mode, first person mode will work fine. If I then exit the game then run the game again (even after reboot) and try to load a marine IA scenario or leave my ship vehicle in any campaign mode the game will ctd every time even after restarting the game.

System Spec

CPU - Intel Core 2 Duo QX6700 2.66GHz (Quad Core)

RAM - 2GB OCZ Platinum Extreme

GPU - ASUS 8800GTX 768mb

SND - Creative X-FI Platinum

HD - 750GB Segate Barracuda SATA 2.0 16mb cache (C:\ 40GB for booting and running OS) (D:\ 710GB for storing data and running programs)

OS - Windows Vista Ultimate X64 edition

Graphics driver version - 7.15.0011.6925

Sound Driver Version - 6.00.0001.1283

Monitor - 22" Samsung Flat Screen

Replication:

(These instructions ASSUME you are capable of running 1680x1050 resolutions)

Game version: Gamers Gate 1.00.05

- Run UCCE

- Click config and change screen resolution to 1680x1050

- Click SAVE then EXIT

- Return to main menu

- Click Instant Action

- Open MI Marine scenario "Last Man Standing"

= The scenario should open ok and first person mode does not cause a crash.... proceed to next steps

- Close UCCE

- Wait for full closure of the game client

- Run UCCE

- Click Instant Action

- Open MI Marine scenario "Last Man Standing"

= The scenario will ctd when finished loading (Usually displaying the infamous "Windows send error report" dialogue box)

The steps above can be repeated in campaign mode but exiting any craft when planetside with the same results.

Workaround

I have been able to find a workaround to the issue however by doing the following each time you close the game:

(These instructions ASSUME you are at the main menu with intent on closing the game down)

- With UCCE open at main menu (after exiting a scenario\campaign)

- Click Config

- Change screen resolution to something like 1280x1024

- Click SAVE and then EXIT

- Now close UCCE

Then when you next play UCCE...

- Click Config

- Change screen resolution to 1680x1050

- Click SAVE and the EXIT

= I now experience no ctd when leaving craft or running marine IA scenarios.

The above process must be followed each time the game is closed or I will experience ctd with loading first person mode next time I play.

END\

I hope these instructions for replication and workaround are clear, im not hugely talented on writing structured reports or instructions :)

I have no idea if can even be replicated on another machine.

Would appreciate any input that anyone has, I am more than happy to provide anything which may be of use to diagnose it. Of course it could just be my computer ;)

Cheers muchly

Terry

Share this post


Link to post
Share on other sites

Nothing to do with the game. I just tried it on my rig and it works just fine.

Apart from that, NONE of our games are supported on x64 operating systems.

Share this post


Link to post
Share on other sites

Ok SC thanks for the input and looking into it.

Its worth a try, dont ask never find out ;) I'll go back to digging around graphics and sound settings.

The workaround I detailed there works fine for me, so im more than happy to do that, just a couple of extra clicks is all :)

Share this post


Link to post
Share on other sites

Sounds good. Actually, the fact that the workaround just inits the video driver sub-system and nothing else, my guess is that the problem in the x64 graphics driver w/ widescreen support.

In fact, only the ucconfig.ini file is modified by the game using the workaround. If after you exit the first time, you save that file to .bak, then the second time, play and quit, compare the .bak to the current .ini file and you'll see that as far as game config is concerned, only the resolution line is changed from 1280x1024 to 1680x1050.

Share this post


Link to post
Share on other sites
Sounds good. Actually, the fact that the workaround just inits the video driver sub-system and nothing else, my guess is that the problem in the x64 graphics driver w/ widescreen support.

That makes alot of sense actually and it really would not surprise me in the least. Might be worth me checking on the issue on future revisions of the driver when they get released, although im not holding my breath hehe ;)

In fact, only the ucconfig.ini file is modified by the game using the workaround. If after you exit the first time, you save that file to .bak, then the second time, play and quit, compare the .bak to the current .ini file and you'll see that as far as game config is concerned, only the resolution line is changed from 1280x1024 to 1680x1050.

After reading that, I did it for myself to see and I can understand what happens now.

If I get lazy I might just write a little batch file that I can run before opening the game to copy a version of the .ini with 1280x1024 into the game directory so it is reset to that value when I start 'er up! of course totally at my own risk :)

Mind you, im going to have to be a little on the bored side to do that hehe

Thanks again mate.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×