Jump to content
3000AD Forums
Sign in to follow this  
aramike

Video Problems - Tech Support

Recommended Posts

Post here if you are having difficulty with your computer's video while running BCM.

This thread is not for opinions on BCM's graphics.

[This message has been edited by aramike (edited 03-19-2001).]

Share this post


Link to post
Share on other sites

If you are experiencing lock-ups in the game, and you have already de-selected the zbuffer option for you nVidia card, make sure that you don't have Video Shadowing enabled in your computer's BIOS. I know it is in the FAQ but in case you don't want to read that FAQ that might solve your problem (it did for me).

~Pio

Share this post


Link to post
Share on other sites

During the logo, the screen around the logo flashes a chechered pattern. I usually just press ESC and it takes me to the game.

Pentium 500

128 meg ram

Direct x 8

Voodoo 3 agp 1.07 driver

Share this post


Link to post
Share on other sites

ok think this classes as a vid, or might be general

Im getting a really BAD FPS rate in BCM

Running an AMD ATHLON 1.1 ghz

320 mb ram

voodoo3 2000 PCI (gonna upgrade soon)

i run win2k and win98se but i get really baaaad FPS on BCM demo. like 6 to 8 fps. major jerkovision

Only program i get problems with, deus-ex and Ground control and everything else i have runs smooth as anything on 1024x768. only this one has probs. Im running the latest drivers. Tried latest official and beta drivers for both w2k and 98 and same results.

I do get the corrupt menu screen as well but i think a lot of people have been saying they get this. Just scroll over where the menu button was and it gets past it

Share this post


Link to post
Share on other sites

quote:

Originally posted by Dunk:

ok think this classes as a vid, or might be general

Im getting a really BAD FPS rate in BCM

Running an AMD ATHLON 1.1 ghz

320 mb ram

voodoo3 2000 PCI (gonna upgrade soon)

i run win2k and win98se but i get really baaaad FPS on BCM demo. like 6 to 8 fps. major jerkovision

Only program i get problems with, deus-ex and Ground control and everything else i have runs smooth as anything on 1024x768. only this one has probs. Im running the latest drivers. Tried latest official and beta drivers for both w2k and 98 and same results.


Dunk,

Check your desktop color depth and see if you're running in 16 bit color before you enter the game. If not, change it to 16 bit and ensure that your color options in the config for BCM is also set to 16 bit.

That should give you your speed back.

------------------

Guardian

External Beta Tester

Battlecruiser Millennium

Share this post


Link to post
Share on other sites

Also which version of the demo are you running? SC warned that the 160MB high quality version needed at least a 32MB video card or the frame rate may take a big hit.

- Advil

Share this post


Link to post
Share on other sites

Ok cheers that fixed it smile.gif

running smooth as anything now smile.gif

Oh i also found out if u set your desktop resolution to your ingame resolution you can see the start menu in BCM, instead of waving the mouse where the buttons are smile.gif

Nice startup piccy smile.gif

Share this post


Link to post
Share on other sites
Guest manta

System Specs :

- PIII 933

- 256 MB

- Leadtek GF 2 MX 32 MB Video Card

- Nvidia Reference Drivers 6.50 for Win 2K

- Win 2K Proffessional with service pack 1 and critical updates applied.

- BC:M demo HC version and selected HIGH quality mode.

- BC:M running in HIGH priority mode on Win2K.

I have a question about video card. At the 1024x768 or 1280x1024 resolution frame rate seems a bit low. At 800x600 it's good, but I have an 17" monitor and i want to play it at a resolution higher than 800x600. Is there anybody playing the demo higher resolutions with GF 2 MX based cards with all options set to max? Or do i need reinstall the demo with low Content option ?

Thanks,

Manta, only known player in Turkey.

(As far as i know smile.gif )

P.S. This is not a big problem at all. I just want to make the demo run at higher resolutions with a good frame rate.

Share this post


Link to post
Share on other sites

quote:

Originally posted by manta:

I have a question about video card. At the 1024x768 or 1280x1024 resolution frame rate seems a bit low. At 800x600 it's good, but I have an 17" monitor and i want to play it at a resolution higher than 800x600. Is there anybody playing the demo higher resolutions with GF 2 MX based cards with all options set to max? Or do i need reinstall the demo with low Content option ?


Whew Manta...there's no reason why that setup should be having any troubles. I'm running at 1024x768 with a plain Geforce with no graphics problems at all. You might want to ensure that you have DX8 properly installed. I'm not a Win2K expert but you should be able to get all the graphics features with your set up.

~Pio

------------------

Commander Pioneer

ICV-Striker, Spectre (Antis)

Spectre Fleet

"If you're thinking about losing, you're already dead."

Share this post


Link to post
Share on other sites

quote:

Originally posted by manta:

System Specs :

- PIII 933

- 256 MB

- Leadtek GF 2 MX 32 MB Video Card

- Nvidia Reference Drivers 6.50 for Win 2K

- Win 2K Proffessional with service pack 1 and critical updates applied.

- BC:M demo HC version and selected HIGH quality mode.

- BC:M running in HIGH priority mode on Win2K.

B]

Manta,

I loaded BC:M on my wife's system, which is a T-Bird 800 w/128MB RAM and an eVga GF2 MX card on Win98 and it is awesome at 1024x768. I was considering maxing out at 1600x1200 on her system, but haven't had the chance yet.

Your rig should be fine, but I'm not as sure about the OS. There shouldn't be any issues as long as DX8 is on there. Check DXDiag to see if there's anything wrong.

------------------

Guardian

Commander Greg Graham

UCV Devil's Advocate

External Beta Tester

Battlecruiser Millennium

Share this post


Link to post
Share on other sites
Guest manta

Pioneer and Guardian thanks for your help. My problem is gone. Here what i've done :

I've upgraded my Video Cards Bios.

I've installed The Leadtek's most recent drivers (6.66). A few glitches has gone after this.

And disabled Antialiasing (I'm playing only few games and all of them are OpenGL based. So i've forgot to fine tune the Direct 3D setting by disabling Antialiasing.) Frame rate increased a lot after this.

Everything is fine at the moment now i enjoy the game. smile.gif

Thanks again for help Commanders and thanks for the game SC.

[This message has been edited by manta (edited 03-24-2001).]

Share this post


Link to post
Share on other sites
Guest Archiveian

When I start the demo obvious video problems occurr - the screen is garbled with strange colors. Somehow the game starts, but my craft moves in start and stop, on-again off-again motions. My system meets all the minimum requirements, and my voodoo3 2000 video card has the latest drivers. I followed the fix in the FAQ under game stops after it starts ie. disabled shodowing, updated video card driver, set screen depth and something else to 16 in bcm config file, etc. Same problems persist. Any ideas on how to fix? Allocate memory differnetly?

Thanks for your help,

A.

Share this post


Link to post
Share on other sites
Guest Archiveian

p.s. The only reference to z-buffering I can find is "z-buffer optimization. I disabled this. Please refer to my first post for an explantion of my problem.

Thank you,

A.

Share this post


Link to post
Share on other sites

Post yer system specs.

Also, I know there have been some known issues with the Voodoo3, so you may want to take a look around to see if someone's had a similar problem.

Share this post


Link to post
Share on other sites

Garbled screen colors during startup means that your video drivers/directX are having trouble initializing. This is probably also related to your slow-downs/pauses within the game.

1) Update your video card drivers the latest release version.

2) Make sure are running DirectX 8.0a which can be found here: http://www.microsoft.com/directx/homeuser/...ads/default.asp

3) In the BIOS for your motherboard, make sure that Video Bios Shadowing is turned off.

~Pioneer

------------------

Commander Pioneer

ICV-Striker, Spectre (Antis)

Spectre Fleet

"If you're thinking about losing, you're already dead."

Share this post


Link to post
Share on other sites

...and don't go screwing around with video card options!!! CAN'T YOU READ!?!. The FAQ CLEARLY says that Z-Buffer item is for nVidia cards only. The last time I looked, the Voodoo3 was NOT an nVidia card.

*sheesh*

[This message has been edited by Supreme Cmdr (edited 03-26-2001).]

Share this post


Link to post
Share on other sites
Guest Archiveian

Thanks for your prompt response. I guess I should have been more clear. I have already followed your suggestions. I have direct x 8, video shadowing is disabled and I have the latest video driver for my video card(1.07 - should I go with 1.06 instead?). Any other ideas?

Boy I got slammed didn't I. Temper temper.

A.

Share this post


Link to post
Share on other sites

Archiveian,

Post your system specs. This might not be a graphics problem, but something else. Do you have any joysticks, multiple moniters, etc. Just give us the processor, ram, any modems or ethernet cards attached, sound cards, blah blah blah; you know. The works. Any PCI or AGP cards, and other options attatched. Also, Windows Version, and disk space would be important too.

------------------

Commander Alec Nova (Terran/Mercenary)

UCV Dark Outlaw (Modified SpaceStar Class Ship)

"To me, luck is useless in life; especially if you've

got a bigger gun than the guy next to you."

Share this post


Link to post
Share on other sites

quote:

Originally posted by Steve Schacher:

You say that you set the color depth to 16 in the config files. What about on your desktop? That should be 16 also.

Heh, I think Steve is thinking 16 BIT color. Make sure that your desktop is at 16 bit color as well. It's been the cause of a number of V3 slowdowns. Don't run in 16 color though. Please... For your own sanity... smile.gif

------------------

Guardian

Commander Greg Graham

UCV Devil's Advocate

External Beta Tester

Battlecruiser Millennium

[This message has been edited by Guardian (edited 03-26-2001).]

Share this post


Link to post
Share on other sites
Guest Archiveian

I set my desktop to 16 bit. Still get garbled colors during starup but the game appears to be playable; Still get slow responses when I click on things and, though I can save the game, the restore button will not highlight in blue when I put the cursor over it so I can't restore. Why can't I restore?

System specs: 366Mhz AMD K62 processor, 96 megs ram, voodo3 2000 pci video card, 667megs free hard drive space(4 Gig drive), sound card by ESS Technology( I think its an ES1869 sound card), Realtek RTL8019 NIC card using a cable modem, no joystick, one very old very old monitor(display properties says "Digital Flatpanel(1024 X 768) on Voodoo 3 PCI"),display set to 640 X 480,no other devices attached except the usual mouse, keyboard and printer etc, and I am running Windows ME.

Share this post


Link to post
Share on other sites

You might be getting slow in-game responses just from your low system specs. I'm sure Windows ME(first) is eating up most of your RAM.

Share this post


Link to post
Share on other sites

Archiveian, you barely meet the minimum requirements. You processor is about equal to a Pentium 2 300. K6-2s are slow gaming processors.

Also, your display is at 640X480? Is that the best your monitor can do?

One more thing: Windows ME is probably KILLING your ability to play. Try turning off its system restore feature and then go back to the demo.

Share this post


Link to post
Share on other sites

Archiveian, I have Windows ME too.

Alright. I still use System Restore cwm7.gif , but you can take it off by using these simple steps:

First off, follow this start menu trail: Start Menu->Settings->Control Panel, and click on System.

Next, click on the Performance tab

Go to File System.

Go to the Troubleshooting Tab, and check off Disable System Restore.

That should free up a lot of disk space, and to mention freeing up some memory because Win Me watches every change to the Registry and System Files.

Also, have you manually changed your Swap File settings? It also helps your Hard Drive usage by making sure the Swap File doesn't change size dynamically, because it can go to over 1 gig on some drives.

To change Swap File Size, follow steps 1&2 above, but click on Virtual Memory. Click on Let me specify my own V.M. settings, and then on the minimum and maximum, put the same number down. Put like 4-6 times your physical memory in those boxes (384-576 for your 96mb system), but remember to make the min and max the same.

Finally, try Windows Update for some other patches and fixes -- either go to Internet Explorer (if you're not using it), and go to Tools->Windows Update(should be 2nd or 3rd option), or (if you're already running IE), Click Here, or Here.

They've got updates on most Windows Drivers if yours aren't current, so thats cool, and also have patches, and bug fixes for most stuff. You only need the ones in Critical Updates (the package has all of those patches), and Device Drivers (get those all, they're updated full versions), and you should get the ones in Recommended, because they have other patches for Direct X, and a Hard Drive cache patch, and the latest version of Microsoft Virtual Machine (you don't need this; its only for Java web sites, you still should, if you use Active Desktop, or surf with IE).

(update)You should also go to your manufacturer's web site, and look up your model/make for some patches. I know Packard Bell/NEC does this and so does HP. One more thing to look up is the manufacturer for your major system components (monitor, sound card, and maybe hard drive (you can look up the maker by going to the system properties box, and going to the device manager tab; head down to the bottom for a link if you don't know the site of your company), in addition to the motherboard/chipset, and the graphics)(/update)

Also, I discovered the Save Game but no Restore or Load thing while playing too. Hey SC (Derek), what's up here man? It screwed me up while playing; I was at 14:10, just crusing to sell some stuff I got in a container, and then I was goin into the menu, but I accidently clicked Save, and when I clicked cancel, it brought me to the title.

(update)Oh yeah, I forgot that NIC's take up memory while you're connected (at least mine slowed my computer when I used to have it connected on cable--we got rid of cable 'cause it cost too much back when I had it in Dec 99). Check for some driver updates there (manufacturer site) as well.(/update)

(2nd Update)

Yeah, okay. You can find patches for your part at Winfles' Driver Section. Tried the link myself; It so happens that Winfiles was taken by CNet. Umm. You click on the type of part you have, then use the OS Filter, and look at the huge list from there. Hmmm. The original Winfiles was easier to navigate than this. Sorry; best I can come up with.(/2nd Update)

Well, I hope something works out.

------------------

Commander Alec Nova (Terran/Mercenary)

UCV Dark Outlaw (Modified SpaceStar Class Ship)

"To me, luck is useless in life; especially if you've

got a bigger gun than the guy next to you."

[This message has been edited by Cmdr Nova (edited 03-27-2001).]

[This message has been edited by Cmdr Nova (edited 03-27-2001).]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×