Jump to content
3000AD Forums
Sign in to follow this  
aramike

Misc. Tech Issues

Recommended Posts

If you are having difficulties with the BCM demo that do not fall in the categories of video or sound, please post them here.

Share this post


Link to post
Share on other sites

Here are some previously posted comments that deal with this issue:

dnoyeB!

quote:


--------------------------------------------------------------------------------

If I play for some length of time I eventually get this.

debug assertion failed!

bcm.exe

file: fprint.c

line: 56

Expression str!= NULL

I have vc++ installed so I think its catching this error with a little more info than normal?

For a early version this thing is rediculously solid. I mean for someone who says its not finished, it sure seems so.


Steve Schacher:

quote:


You can thank Mr. Smart's devotion to beta testing for that. A study of the BC3K and BCM version control files will show the great amount of work that went into beta testing his titles.

Joel Schultz:

quote:


Didn't I read somewhere that the demo was based on the Debug beta code?

Advil:

quote:


yeah, this is the same error that always stops me. Seems to happen at about the same time too. I'm not watching the clock, but it seems to pop up after about 30 minutes (real time).

I don't have VC++ installed, and never have on this machine... so I know this isn't related to a VC++ debug on my end.


Starwind_XGP_2001

quote:


Yeah, I have the same problem. It does that around 13:39-13:48 game time.

Share this post


Link to post
Share on other sites

rc51:

quote:


Hello. I downloaded the demo of Battlecruiser Millennium. However, when I double click the exe the game will not start. I just sit there at the desktop. I have a Quadro 2 pro from Elsa. This is the second time ive posted this... once in the technical support forum... although i was told your not supposed too... (?) and then they deleted my message ... so this is the last time dealing with this complete nonsense. thanks.

System spec:

Supermicro P4STA - P4 1.4ghz, 128 rambus

Adaptec 3200s ultra 160 controller

DX 8.0

I think its the video card though. I looked into a log file and noticed some lines that said unable to initialize renderer.


Kurt Meyer:

quote:


--------------------------------------------------------------------------------

"Go to Display Properties. In the Direct3D section of the Advanced settings tab, disable (remove the tick mark from the box the feature described as: Adjust Z-Buffer depth to rendering depth if unequal"

I'm going to assume you did this and are running official Detonator v6.50 drivers with no other programs running in the background.


Share this post


Link to post
Share on other sites

mosselman:

quote:


Hi

I installed the demo correctly. Then i rebooted and started the exec.

Screen went blank and i got thrown back io my dekstop. No messages or anything.

Anyone who can help me?

Here's my system:

*P II 400 - 128 RAM

*RIVA TNT 2 ULTRA

*Windows Millenium

*no additional progs in tray

Tnx.


o0Feral0o:

quote:


I'm having the same exact problem. I read the part in the trouble shooting guide that seems to be describing the same failure, but it says you get a serial number during installation. You're supposed to send the number somewhere(dosn't say where), then you somehow get a new number, then you somehow use that new number to make the game work... I don't know how to do any of this, because I never recieved any kind of serial number during install, and even if I was able to get the final unlock code I couldn't enter it anyways because the game dosn't start.

Osho:

quote:


The serial number stuff is for the full beta, not the demo. That document has details on the entire beta version of the game. Just skip that.

Nvidia owners need to make sure they have disabled the z-buffer checkbox in their video settings. If you don't uncheck it the demo will just exit back to the desktop.


Share this post


Link to post
Share on other sites
Guest Vanguarde

For the record, Vanguarde, if you SIMPLY would have posted this here on the THIRD or FOURTH try, ESPECIALLY after we ASKED you to, you would have received help.

You didn't.

Instead, you posted TIRADE after immature TIRADE in damned near EVERY forum on this bulletin board. They have since all been deleted.

As was your account, and you are now a member of our ban lists.

Here's a tip: if you DON'T like the rules, DON'T USE THE SITE! We're not ASKING you to!

So, goodbye. And good riddance.

[This message has been edited by aramike (edited 03-19-2001).]

Share this post


Link to post
Share on other sites

Someone just posted that it took them several minutes (like 5) to get through this step. Be patient.

If it still refuses to install it may just be a bad download. Not the best news I know.

(and you were rude. Lighten up. It will take others time to respond. Plus we are trying to keep the site clean for ease of searching. This demo forum was made for discussion of the demo. We have gotten compliments on the site before. )

------------------

Vice Admiral Chavik

ICV Phoenix, Sygan Starstation (Sygan)

Fleet Leader - Balor Fleet

Official BC3K Tester

Share this post


Link to post
Share on other sites

There is a known issue with Windows 98SE/2000 where InstallShield will hang if you are running an anti-virus program in the background. Trying shutting down your anti-virus program and restarting the installation package.

~Pioneer

Share this post


Link to post
Share on other sites

128kbps @ 44khz, that's a standard encoding rate and the results are good. I doubt it would go any higher ie for processor usage issues.

Share this post


Link to post
Share on other sites

Try taking a 705kbps wav file an encoding it at 128kbps smile.gif The end result is a low quality rip that can't be played loud. Please don't take that the wrong way. I've already told Markus I like the music in BCM alot. I am pretty easy going when it comes to music. I like anything but country and rap. I especially love techno and trance. The thing is alot of my music is 256kbps and is designed to sound good when played LOUD biggrin.gif I don't really want to encode them at a lower quality (Even tho I have already been doing it smile.gif) either because their is plenty of cpu power these days to play 256kbps mp3. Just think soon we'll have 2gig cpu's. Anyways I'm hoping the in game mp3 player will support 256kbps playback @ 44khz.

[This message has been edited by Kurt Meyer (edited 03-20-2001).]

Share this post


Link to post
Share on other sites
Guest dnoyeB!

These days when it comes to encoding, the CPU is not the issue. Its the speed of the HD.

Share this post


Link to post
Share on other sites

I was not talking about encoding MP3 while playing BCM. smile.gif I was talking about playing back MP3 files in BCM that are higher than 128kbps @ 44Khz.

[This message has been edited by Kurt Meyer (edited 03-20-2001).]

Share this post


Link to post
Share on other sites

We are currently using our own decoder and will probably switch to using the decoder in DirectX 8, which probably supports 256 rates.

[This message has been edited by Supreme Cmdr (edited 03-20-2001).]

Share this post


Link to post
Share on other sites
Guest Brad Marrtin

So, anyone got any ideas on this 'Debug Assertions' crash? I'm having exactly the samr prob. Aside from that, it's looking very good.

Share this post


Link to post
Share on other sites

Hey it's me again (Starwind_XGP_2001, just had to register again, so my name would fit the Fleet DB registration i sent in). I am still having the same old C++ Debug Assertion error. Like I said, it usually happens around 13:38-13:48. Sometimes it shows the error, other times it just goes back to the desktop, and yet again, there are times where my computer locks up, and I am forced to hard reboot (pull the plug and put it back in, because my power button only turns on the comp and is controlled by bios). There is a rare 1 or 2 games out of 8 that work past the 14:00 game time, but I usually finish my mission objectives after that, so I haven't really tried to push it farther. If anyone can help with some input, it could help. I like to tweak my system settings and look at technical stuff, so i'll try to get some of my driver versions up for some refrence as to why this is happening.

System Specs:

HP Pavilon 6630

Intel Celeron 500Mhz

64MB RAM

ATI All-In-Wonder 128 (Rage 128 Chipset)

Windows ME

11.2 GB Hard Drive

It's a great game, almost no glitches/bugs (emphasis on almost), great interface, good music and graphics. 9.4 out of 10 in my book. Can't wait for the Gold Release!

------------------

Commander Alec Nova

UCV Dark Outlaw, Pixan Starstation (Lennen)

-Independent Outlaw/Mercenary/Assasin For Hire

Will take most jobs from Covert-Ops, and Assasination,

to Recon, Trading, and Security Detail. Will Work for any Race/Caste/

Fleet, if you've got the cash. "Always want a challenge....."

"To me, luck is useless in life; especially if you've

got a bigger gun than the guy next to you."

Share this post


Link to post
Share on other sites

This problem recently popped up and I've been working with the Beta testers to try and isolate it. It seems to be happening under certain conditions - but so far, we don't have a clue. And since it is difficult to reproduce (I can't reproduce it), it remains a pending issue. Hopefully, it will be discovered and squashed prior to the E2 demo. If you can find out how to reproduce it, please let me know.

Another most helpful thing you could do is

  1. Create a new BCM DEMO DEBUG shortcut. This time, add /d4 /w to the commandline target so that the shortcut looks like this "C:Program Files3000ADBattlecruiser Millennium Demobcm.exe" /d4 /w

    This will start BCM in a window and in debug mode.

  2. As soon as the game crashes with this error, look in the folder where BCM is installed and send ALL the files with .INI and .LOG extension to [email protected]

[This message has been edited by Supreme Cmdr (edited 03-20-2001).]

Share this post


Link to post
Share on other sites

Installation Problems - Internal Error 2355

Downloaded the demo three different times from three different sites over the past four days from DSL Internet connection at work; downloaded to a Zip 100 disk and then installed on PC at home from the disk. Always the same problem: once the Windows Installer gets about 20% into "Copying new files,.." I receive the fatal message "BATTLECRUISER MILLENIUM Demo Installer Information" indicating "Internal Error 2355". Installation stops, and when I click "OK" on the error box, what installation has occurred is undone.

I have tried to install on Low, Medium and High Skybox settings, with no success.

Download on the Zip disk indicates download size/properties of "91.7MB, (96,245,273 bytes), 96,245,760 bytes used".

POS System:

Micron Milleniun PII 450

Win 98 OS

64MB RAM

DirectX 8.0

VooDoo 3 PCI; drivers v1.07

Desktop set to HighColor - 16bit

800MB free diskspace

Norton AntiVirus disabled

(my other PC is a Porsche)

If I am guilty of not reading the FAQs properly, or if this problem has been asked and answered, I will run, not walk, to the nearest airlock and self-impose a read only exile.

Thanks for any light that can be shared in my installer-challenged dark cave. Maybe I need that new TetraHertz PC with 2gig videocard, huh?

Sleepless and sad in South Bend,

Doc Hoover

[This message has been edited by thanatos (edited 03-20-2001).]

Share this post


Link to post
Share on other sites

Did you MISS the installation issues thread?

wtf is the matter with you people?

quote:


admin/cat, please delete this post once his post appears in the proper forum. Thanks


Share this post


Link to post
Share on other sites

Alrighty then, Derek; I'll try to send some debug info in by tomorrow.

------------------

Commander Alec Nova

UCV Dark Outlaw, Pixan Starstation (Lennen)

-Independent Outlaw/Mercenary/Assasin For Hire

Will take most jobs from Covert-Ops, and Assasination,

to Recon, Trading, and Security Detail. Will Work for any Race/Caste/

Fleet, if you've got the cash. "Always want a challenge....."

"To me, luck is useless in life; especially if you've

got a bigger gun than the guy next to you."

Share this post


Link to post
Share on other sites

SC,

Is the "WTF" directed at me and my "Installation Problem" post? I am sorry if I have violated posting rules. I posted here as Aramike's initial thread states to post here for Non-Video/Non-Sound, Misc. issues. I posted through topics showing up on "Today's Active Topics", and for some reason your "Installation Issue" topic thread doesn't show up.

And I thought I was being so good by not starting still another related thread.

Sorry in South Bend,

Doc Hoover

Addendum at 21:16 hours, 3/20/01, to previous message: Whoops, it does show up, but the heading states "help!", and I missed it as a "Installation Thread". Don't know if missing the new hidden thread deserves the reply.

[This message has been edited by thanatos (edited 03-20-2001).]

Share this post


Link to post
Share on other sites

Alright, Derek. I got it to reproduce. I'll send the info in the email to [email protected] Also, can I put all the INI and LOG files into a ZIP file and then email it? Oh yea, just e-mail me your reply to my question about the zip files. [email protected]

I'm going to have to log off for the night, so I'll get your answer and send it around 7:00 AM Eastern Time. If I don't have enough time before school, I'll send it ASAP (maybe around 3:30-4:30 PM Eastern).

Glad to help man. cwm11.gif

------------------

Commander Alec Nova (Terran/Mercenary)

UCV Dark Outlaw (Garid Class), Pixan Raider Starstation (Lennen)

-Independent Outlaw/Mercenary/Assasin For Hire

Will take most jobs from Covert-Ops, and Assasination,

to Recon, Trading, and Security Detail. Will Work for any Race/Caste/

Fleet, if you've got the cash. "Always want a challenge....."

"To me, luck is useless in life; especially if you've

got a bigger gun than the guy next to you."

Share this post


Link to post
Share on other sites

You can send it zipped or unzipped.

btw, cool sig you got there. You are a marked man, my friend - multiplayer is coming.

Share this post


Link to post
Share on other sites

i should have woken up an hour ago, but i didn't change my alarm clock setting. I just got up a few min ago, but i have to go. just hold on until the afternoon (after all, i only have 56k, so it'll take a while to upload).

thanks about the signature; i love it too, my first sig was way different, but i changed it a bit after a couple posts to what i have now.

------------------

Commander Alec Nova (Terran/Mercenary)

UCV Dark Outlaw (Garid Class), Pixan Raider Starstation (Lennen)

-Independent Outlaw/Mercenary/Assasin For Hire

Will take most jobs from Covert-Ops, and Assasination,

to Recon, Trading, and Security Detail. Will Work for any Race/Caste/

Fleet, if you've got the cash. "Always want a challenge....."

"To me, luck is useless in life; especially if you've

got a bigger gun than the guy next to you."

Share this post


Link to post
Share on other sites

Well fixed speed problems that i had before smile.gif Great game btw, been a fan since v1 - the fatefull Take2 release. Only slight prob i get now is in game. It drops to desktop when I click on commlink frown.gif

Everything else seems to run fine now.

Share this post


Link to post
Share on other sites

OK, the problem with the assert error has been found and fixed. This fix will also be in the E2 demo.

The problem occurs because the demo runs in non-debug mode and there is a particular error that is trying to record to a non-existent debug file. This error relates to NPC transports docking with stations and resupplying them.

To fix this error in the demo, do the following:

  1. delete the default BCM DEMO shortcut (you can't modify it)

  2. Create a new BCM DEMO shortcut (which points to BCM.EXE) and add the /d1 parameter at the end. If you do it right, the shortcut target should look like

    "C:Program Files3000ADBattlecruiser Millennium DemoBCM.EXE" /d1

[This message has been edited by Supreme Cmdr (edited 03-23-2001).]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×