Jump to content

ERROR! Installation, copy protection, cannot locate CD-ROM etc


Recommended Posts

Hi all

After purchasing and installing UC yesterday I had a frustrating time in trying to get the game to locate the CD-ROM. I tried applying the patches as per the Tech Support FAQ, and also tried the SafeDisc patch found at:


I tried uninstalling and re-installing numerous times from both of my CD-ROM drives and to different install paths, all to no avail. After reading over the following Microsoft article:


I found the solution to be method 7. Changing the transfer mode of the primary channel of my ATA controller (in the WinXP device manager) from default/DMA mode to PIO mode solved the problem.

I am wondering if this has anything to do with my having a SATA hardrive and so my ATA controller primary channel is a CD-ROM drive instead of usual hardrive.

Here are my system specs:

Computer make/model: Custom

Motherboard make/model: Gigabyte GA-7N400Pro2

Processor type/speed: Athlon Barton 2500+

Hardrive: Maxtor 80GB SATA drive

Memory type/amount: DDR PC3200 512MB (1 stick)

CD-Rom type/speed: Creative 52x and TDK VeloCD 24/10/40x

Sound card make/model: RealTek ALC650 NVidia nForce Audio CODEC (on m/b)

Video card make/model: PNY NVidia GeForce4 Ti4400

Video card memory: 128MB

Mouse type: Logitech MX310 Optical

Internet connection: LAN

Desktop color depth: 32bit

Operating system: WinXP Pro

DirectX version: 9.0b

Videocard driver version:

Soundcard driver version: 6.14.362.6

I hope this info helps anyone else out there who experiences this problem...and thanks to Tech Support for taking the time on the weekend to help me.


[ 04-03-2004, 10:31 AM: Message edited by: Supreme Cmdr ]

Link to comment
Share on other sites

don't know if it helps, but i had a similar problem. i have 2 cd drives. i installed from the bottom and when i went to run it it said cannot find cd, so i switched the cd to the top drive and it works fine. unfortunatly it's working from the top drive so i'm far to lazy to look into it any more

top drive: dvd

bottom: cd/rw

EDIT: both of my hard drives are IDE

[ 02-09-2004, 07:40 PM: Message edited by: Splad ]

Link to comment
Share on other sites

  • 3 weeks later...

I found myself in the same situation.

I tried Macrovision patch, Windows XP patch and I've installed the game both with my CD burner and DVD reader. The game reads the disk a few times but it doesn't accept it. I've never had problems with cd protection before.

At the end I found my problem. I had a simulated CD-ROM. By removing it in the hardware profile the game works.

I think it could be a good idea to put this on the FAQ, I don't really know why this happens because it seems a silly mistake.

Link to comment
Share on other sites

A simulated cd-rom allows you to have an image on the HD and simulate it as a real CD-Rom.

I use it when a cd is scratched or I just want a faster speed (or I don't want to burn an image).

Link to comment
Share on other sites

Just as I thought. By now, I think every gamer knows that those tools, Alcohol 120% etc all cause problems with copy protection schemes. As such, I'm not putting in the FAQ because NO third-party programs should be running in the background when the game is being installed or run.

Link to comment
Share on other sites


Originally posted by Supreme Cmdr:

Whats a simulated CD-ROM? And how and by what is it installed. And why would anyone need one?

I occasionally use a simoulated drive to run programs on my laptop, which doesn't come with a CD ROM drive (ultraslim) Most games run on it, but BCM & UC don't. At any rate, that's what it's usually used for.

Link to comment
Share on other sites

  • 2 weeks later...


Originally posted by Part-Human:

It is working now. I did the following;

    Removed Alcohol 120% Virtual Drive

    Updated to ATI Catalyst 4.1 Drivers

    Windows Update

    Rebooted a few times

    Removed AVG Antivirus

    Ran a Safedisk driver update from Macrovision (I can dig up the link to those interested)

    Re-installed to C:Program Files... instead of to E:Universal Combat

I think that's it.

Link to comment
Share on other sites

  • 3 weeks later...

Copied over from another thread


Originally posted by Brett:

I had a problem with the install but I found a work-around if anyone else encounters the issue.

Basically the install gave me an error that it could not find the Data1.cab file during the install and gave me a Retry/Cancel option. It made no sense since I was viewing the CD contents and could clearly see the file. A reboot did not fix the issue.

I copied the contents of the CD to a folder under the My Documents folder and ran it from there. The install worked fine.

Hope this helps.

FYI: I closed most of the programs I was running for the install including AV and firewall software.

FYI: I have a stock HP A230N with an add-on Nvidia 5600 Ultra card. Let me know if you need more detail

Link to comment
Share on other sites

All BC games use the latest SafeDisc copy protection from Macrovision. If the game cannot find the CDROM, won't run etc, you need to read this entire thread and take the appropriate action. The copy protection scheme will prevent the game from running if ANY debugger, virtual CD tools etc is currently running in memory.

Read this SafeDisc help document.

If you have the Microsoft Script Debugger installed, read this.

To find out what processes are running on your machine in order to determine which third party apps (virtual CD drivers, debuggers etc) are running, go to SysInternals and download Process Explorer. It gives better information on what processes are running, where they are located etc.

Link to comment
Share on other sites

  • 4 weeks later...

Help, I don't know what to do. I have tried everything,I read all the posts and the game will not start. I downloaded the Process explorer and I don't see anything there that would stop it from running. I called their tech support and they were no help. I am about to start using this CD as a coster, since I can't even return it back to the store. Wasted $20.00 bucks

Link to comment
Share on other sites


Well you don't seem to be able to read so well!

How about adding you system specifications to your signature (a requirement for anyone posting in tech support) and posting that process explorer report?

A detailed explanation of what actually happens when you try to run the game with any exit messages or error codes. would also be a good idea.

It's impossible to offer any advice on how to solve your problem due to lack of information given, to the best of my knowledge we don't have any psychics reading the forum to glean this information but we do have a few psychos and stalkers.

It must be obvious to you from reading this forum that the problem is at your end as there are many people who are able to play the game.

Link to comment
Share on other sites

I don't get any error messages, the game won't run, but here is the report. If you could tell me how to get it running that would be great. thanks

Process PID CPU Description Company Name

Idle 0x0 98 System Idle Process

DDHELP.EXE 0xFFFBAF75 Microsoft DirectX Helper Microsoft Corporation

KERNEL32.DLL 0xFFCFE1D9 Win32 Kernel core component Microsoft Corporation

MSGSRV32.EXE 0xFFFFB641 Windows 32-bit VxD Message Server Microsoft Corporation

MPREXE.EXE 0xFFFFA0F1 WIN32 Network Interface Service Process Microsoft Corporation

mmtask.tsk 0xFFFF9D95 Multimedia background task support module Microsoft Corporation

EXPLORER.EXE 0xFFFD7159 Windows Explorer Microsoft Corporation

SWTRAY.EXE 0xFFFDF0C5 MS GDP Tray Microsoft Corporation

CTLAUNCHER.EXE 0xFFFDDD35 Creative Launcher Creative Technology Ltd

UPDTRAY.EXE 0xFFFC1BB5 Creative AudioHQ Creative Technology Ltd.

AHQTB.EXE 0xFFFDA9D5 Creative AudioHQ Creative Technology Ltd.

EM_EXEC.EXE 0xFFFD2109 Control Center Logitech Inc.

SYSTRAY.EXE 0xFFFD201D System Tray Applet Microsoft Corporation

WMIEXE.EXE 0xFFFC10A1 WMI service exe housing Microsoft Corporation

RUNDLL32.EXE 0xFFFC7C21 Run a DLL as an App Microsoft Corporation

RunDLL.exe 0xFFFC6B85 Run a DLL as an App Microsoft Corporation

MSIMN.EXE 0xFFFA3969 Outlook Express Microsoft Corporation

PSTORES.EXE 0xFFF987B5 Protected storage server Microsoft Corporation

WINZIP32.EXE 0xFFF82E4D WinZip Executable Nico Mak Computing, Inc.

PROCEXP.EXE 0xFFFB3295 1 Sysinternals Process Explorer Sysinternals

Link to comment
Share on other sites

That isn't quite the report Pugwash wanted. We need to know about the computer itself.

What CPU does it have? (AMD 2200 for example or Pentium 4 2.4 GhZ)

How much system memory do you have? (256 or 512 meg?)

What kind of video card?

Are you pretty good with computers and can answer this stuff?

Link to comment
Share on other sites


Originally posted by baronfrost:

I don't get any error messages, the game won't run, but here is the report. If you could tell me how to get it running that would be great. thanks

Have you tried Stopping the background processing on all except for Explorer and systray. After that, run a memory manager to free up alot of memory. See if that helps.

[ 04-19-2004, 10:13 PM: Message edited by: LostInSpace ]

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...