Jump to content
3000AD Forums
Sign in to follow this  
Werewolf

Multiplayer - server CTD

Recommended Posts

Here's a dedicated server crash that happens on 2 totally different machines running win2k. Both using FX 5600 cards and the detonator drivers listed in my profile. I don't know any exact steps to reproduce this, except to just run a server overnight with a few people joining and leaving. It will work for several hours, then it'll just crash.

Screenshot

SC, I suggest setting up a public ded. server with debugger running in background. Let people join, keep the server running for a few days (not just hours) and wait for the crash to happen. Without debugger running this is not going to get us anywhere.

EDIT: Command line for server: @start ucmp.exe -n -x1 -s

Config:

; this is a comment line

[server]

; set this to 1 if a private fleet server

server_fleet=0

; this is the name that shows up in the server browser window

server_name=hoxdna.org

; this message is displayed on successful connection to server

server_welcome_message=Welcome To My UC Server

; the IP of the server. If behind a router and setting up an internet server, check router for the IP address

server_ip=localhost

; the server port. If hosting a server behind a firewall, be sure to open this port!

server_port=2302

; set password to prevent clients from connecting to private server. NO spaces allowed in password

server_password=

; set to 1 if a dedicated server and client on same machine cannot connect

server_dedicated=1

; set to 1 for internet server or 0 for LAN server

server_type=1

; max number of clients that can connect to the server. This should depend on server hardware and bandwidth!

server_client_limit=16

; limit kilobits (Kbps) packets sent to/from the server depending on bandwidth. Set to 0 for no limit

server_bandwidth_limit=4

; limit the max client connection type

; 0=no max, 1=modem(28800), 2=isdn(64000), 3=cable(256000), 4=dsl(128000), 5=lan(1500000), 6=ti(1500000)

server_maxconnection=5

[game]

; delay (in secs) before client is allowed to spawn after being killed

spawn_time=20

; delay (in secs) before client is allowed to enter game world after connecting

start_delay=20

; set to 1 in order to have balanced teams. Players are picked at random and switched

auto_team_switch=0

; set to 1 to enable friendly fire damage from weapons. Does not affect explosion damage

friendly_fire=1

; set percentage of damage to apply to player if friendly fire is off

friendly_fire_penalty=0

; set to allow the display of friendly TTDs in cockpit, fp and tacops

friendly_ttd=1

; set to allow the display of hostile TTDs in cockpit, fp and tacops

hostile_ttd=1

; set to allow the display of neutral TTDs in cockpit, fp and tacops

neutral_ttd=1

; set NPC autogeneration on the server. Use with caution due to performance reasons !!

allow_ag=1

[game.scenarios]

scenario0000=scenario0000

[ 03-15-2004, 07:12 PM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

Please do NOT make repetitive posts about the same thing. I *GOT* the report. Thanks!

[ 02-11-2004, 06:41 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

Alright, alright. BTW, I've now set allow_ag=0 to see if maybe that helps stability. I'll yell if it does.

Share this post


Link to post
Share on other sites

It generates an exception and calls Dr. Watson.

Share this post


Link to post
Share on other sites

quote:

And what did the good doc have to say?

Let me know if you want me to email the log file.

Share this post


Link to post
Share on other sites

quote:

Originally posted by Supreme Cmdr:

uhm, how do you know its dead?

That friendly exception popup told me that. Call it a hunch

Share this post


Link to post
Share on other sites

Hey, I have not been able to reproduce this server crash. And the console server (my version at least), works fine.

However, I noticed a graphics anomaly with the console server, in that if it is covered by another window or you minimize it, the display gets corrupted. I am looking into this one.

Also if you drag the window, it will sometimes crash (due to a terrain engine buffer that it not setup at that time). This one is fixed.

Apart from the above, both the graphical and console servers work fine.

Share this post


Link to post
Share on other sites

quote:

Hey, I have not been able to reproduce this server crash. And the console server (my version at least), works fine.

OK. I just ran some more experiments and discovered that if logging is enabled (l1,l2,l3...)in the command line it will not crash and I get good log files.As soon as logging is removed it works as before.

Hope this helps.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×