Jump to content
3000AD Forums
Sign in to follow this  
Supreme Cmdr

BCM 1.0.08 RC23 Released

Recommended Posts

All previous RC patches have been deleted.

This patch absolutely requires a clean CDROM install of BCM. Check the FAQ for steps on how to uninstall, re-install and apply a patch.

Check GNN for more info on this RC23 patch release.

EDIT:

I forgot to update the contrail tags on the jetpack models in the RC23 update. You can download thisjetpack models update (8K) file and unzip it into the BCM folder (with folders intact) after patching to RC23.

[ 11-04-2002, 09:50 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

You might want to compare your fps in 1.0.07 to those in 1.0.08. Let me know what sort of improvements you are seeing. If you post without your rig specs in your sig, you will be banned.

Share this post


Link to post
Share on other sites
Guest krelian

1.0.07

when stopped in space, my fps was at 30.2

when being attacked in space (lots of missiles, a few fighters), it went down to 23-27

when on a planet, it went down to 20.

when being attacked on a planet (by my ICs) it went down to 17-20.

i found that the fps was pretty much the same in 1.0.07 and 1.0.08rc9.

has the range for galcom's PTA turrets changed? i got destroyed from much farther away than usual. could be just my imagination though.

btw, i use 1024x768 resolution, with all the textures and stuff set to 32. everything else set to on except the music. the intro animation stuttered a bit, but seems to work better now after a defrag. i have tons of free time now, i will play constantly for the next few days.

Share this post


Link to post
Share on other sites
Guest $iLk

DISCLAIMER:

quote:

unless you come across a blatant bug and/or crash caused by this patch.

When starting a new career, and flying my ship down to earth I got out in first person. Every time that I jumped, I would take 5 - 7 points of damage. Just regular spacebar jumping. Didn't have this problem before the patch, and I did a fresh install + install Patch 1.0.07 then unzipped the 1.0.08 patch as instructed.

Also I lost my darned serial number... Please don't hit me.

Any way I could possibly get that emailed to me from the registration database?

Share this post


Link to post
Share on other sites

Playing in 800x600x32

All options are on but music and flight path trails. Particle contrails.

1.0.07

Space - empty : ~60fps

Space - combat : ~30-50fps

Planetary - empty : ~35fps

Planetary - combat : ~5-25fps

1.0.08rc9

All the same, no noticeable improvements.

quote:

Every time that I jumped, I would take 5 - 7 points of damage. Just regular spacebar jumping.

I confirm.

Also, running forward, then hitting F (jetpack) will cause enormous damage in little time, and won't take off.

[ 06-21-2002, 10:22 PM: Message edited by: Epsilon 5 ]

Share this post


Link to post
Share on other sites

quote:


Originally posted by krelian:

has the range for galcom's PTA turrets changed? i got destroyed from much farther away than usual. could be just my imagination though.


No. The only changes made are those in the VCF

Share this post


Link to post
Share on other sites

quote:


Originally posted by $iLk:

When starting a new career, and flying my ship down to earth I got out in first person. Every time that I jumped, I would take 5 - 7 points of damage. Just regular spacebar jumping. Didn't have this problem before the patch, and I did a fresh install + install Patch 1.0.07 then unzipped the 1.0.08 patch as instructed.


Will check it out. You are probably jumping too high. If you look in the VCF, you will see why this is happening. I probably need to reduce the amount of damage when dropping.

quote:


Also I lost my darned serial number... Please don't hit me.

Why do you need it? I see your system profile in your sig just fine. If you need your serial number, check your reg profile. It should be there.

Share this post


Link to post
Share on other sites

quote:


Originally posted by Epsilon 5:

All the same, no noticeable improvements.


I won't expect much from a GF2 card.

My fps on a Radeon 8500 64MB went from 45fps to about 60fps (about the same on my GF3 and a little higher on my GF4 cards) under the same conditions. As always, YMMV.

If you even bothered to run it at 800x600x32 and 1024x768x32, you should probably notice that you don't take a significant fps hit as you normally would.

Apart from that, the loading times have pretty much reduced by half as well.

quote:


Also, running forward, then hitting F (jetpack) will cause enormous damage in little time, and won't take off.[/QB]

Thats normal because the jetpack gives you forward speed and at impact with the ground, thats when the calculations are done. The jetpack is for airborne movement. And I just checked it, as long as your feet are not touching the ground, you won't take any damage from using the jetpack. The whole purpose of putting in these realistic values is to prevent bungie jumping and abuse of the jetpack on mp servers (since only EFMs and the cmdr have them).

When in doubt, read the VCF and it should be obvious how this works. Even for you.

Last warning: EVERYBODY needs to read ALL the VCF entries for 1.0.08.

Share this post


Link to post
Share on other sites
Guest $iLk

quote:

Why do you need it? I see your system profile in your sig just fine. If you need your serial number, check your reg profile. It should be there.

If you mean my system profile info, it's not there.

I took the BCM CD out of the sleeve when I bought it, and stuck it in a jewel case with the serial # attached to it.

Unfortunately the piece of paper that was attached got lost. I may have it backed up somewhere on my backup CD's.

quote:

Will check it out. You are probably jumping too high. If you look in the VCF, you will see why this is happening. I probably need to reduce the amount of damage when dropping.


Well, I was on flat ground outside of the ship. Would only need to *tap* spacebar. Commander jumped to normal jumping height, then when feet touched the ground he made a nasty sex noise and took damage.

Also with Jetpack will it be possible to orient your character so that he flies facing the ground? Ala Jango Fett in EP2?

Share this post


Link to post
Share on other sites

quote:


Originally posted by $iLk:

If you mean my system profile info, it's not there.

No, I meant the registration DB. Login to it and it should be there.

quote:


Also with Jetpack will it be possible to orient your character so that he flies facing the ground? Ala Jango Fett in EP2?


You can already do that many, many versions ago. Check the VCF for the commands

btw, anyone tried troop deploy/evac on planets using the shuttle and waypoints yet? Try it.

[ 06-22-2002, 12:52 PM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

Woo hoo. *Love* the new engine settings. Going at 1700 in my shiny new firestorm. ABs are finally worth something.

Only one problem besides the jumping one that ive noticed.... sent my shuttles down to a planet to deploy mining drones but the drones never deployed. Shuttles just sat there.

Anyone else tried to deploy mining drones?

[ 06-22-2002, 02:52 PM: Message edited by: Kartoffel ]

Share this post


Link to post
Share on other sites

quote:


Originally posted by Epsilon 5:

quote:

No, I meant the registration DB. Login to it and it should be there.

You need the number to login


Doh! thats right

$ilk, check your PM, I just sent you the serial number from your reg profile. Better not lose it again!

Share this post


Link to post
Share on other sites
Guest krelian

i had the same problems with mining drones. I set the waypoints for all four SCs to deploy drones on Earth. The shuttles got to the waypoints, and just landed nearby. Then i got "SC1, dust off in 5..." messages at the top of the screen. after that, all the shuttles RTB'ed. none of the drones were deployed. This only happened under the new patch.

[ 06-22-2002, 02:58 PM: Message edited by: krelian ]

Share this post


Link to post
Share on other sites

quote:

Thats normal because the jetpack gives you forward speed and at impact with the ground, thats when the calculations are done. The jetpack is for airborne movement. And I just checked it, as long as your feet are not touching the ground, you won't take any damage from using the jetpack. The whole purpose of putting in these realistic values is to prevent bungie jumping and abuse of the jetpack on mp servers (since only EFMs and the cmdr have them).


Well when I was doing that I was trying to run, then fly away... I guess I'm not a plane

Next time I'll hit spacebar before hitting the jetpack

Share this post


Link to post
Share on other sites

Sc, I've lost my serial number alsoe, I've tried emailing support a couple of times to get it, but I never got any response, and I never post because I can't set my sig without it. So could you please send me the serial number please. I would really appreciate it. Thanks, and I swear when I get it I'll do my sig. right away.

Share this post


Link to post
Share on other sites

quote:


Originally posted by krelian:

i had the same problems with mining drones. I set the waypoints for all four SCs to deploy drones on Earth. The shuttles got to the waypoints, and just landed nearby. Then i got "SC1, dust off in 5..." messages at the top of the screen. after that, all the shuttles RTB'ed. none of the drones were deployed. This only happened under the new patch.


Lemme guess, you never bothered to check and see if it deploys vehicles or troops, correct?

Share this post


Link to post
Share on other sites

quote:


Originally posted by Vindi89:

Sc, I've lost my serial number alsoe, I've tried emailing support a couple of times to get it, but I never got any response, and I never post because I can't set my sig without it. So could you please send me the serial number please. I would really appreciate it. Thanks, and I swear when I get it I'll do my sig. right away.


1. This is NOT the thread for this

2. I pulled up your profile and ran a search on our tech support and cat DB but didn't find any messages from you.

Share this post


Link to post
Share on other sites
Guest krelian

vehicles and troops don't deploy either. the shuttle lands, you get the "dust off in 5..." message, then the shuttle takes off and RTBs. i tried it with all the shuttles, one by one, and all at once. same thing happens.

Share this post


Link to post
Share on other sites

He's right. I had the same thing. I figured I was doing something wrong so I kept trying.

I set up 3 waypoints which were.

1: Proceed to next

2: Deploy

3: Wait for instructions.

Well it landed, gave me the message about lifting off in 5.., then it counts down, and sits there. Only because of the fact I gave it the wait for instructions waypoint.

Without the wait for instructions waypoint, it takes off after the countdown.

OC didnt deploy, and neither did the marines.

Share this post


Link to post
Share on other sites
Guest Remo Williams

quote:

Originally posted by T-WOPR:

I can't deploy anything from shuttles either.

Just deployed mining drones by shuttle using way points. Worked fine for me. I'll see if I can deploy troops and my other vehicles now.

Sure like how the shuttles land, then count down to dust off. Very cool!

[ 06-23-2002, 01:49 AM: Message edited by: Remo Williams ]

Share this post


Link to post
Share on other sites
Guest $iLk

quote:

Doh! thats right

$ilk, check your PM, I just sent you the serial number from your reg profile. Better not lose it again!

Thanks SC! I've got it saved on my computer now and won't lose track of it again.

Share this post


Link to post
Share on other sites

quote:


Originally posted by Remo Williams:

Just deployed mining drones by shuttle using way points. Worked fine for me. I'll see if I can deploy troops and my other vehicles now.


Let me know about troops and vehicles.

This could be shuttle type related; since the dynamics are different for each craft. So, let me know what shuttle type you folks are using and we'll see if thats the problem. If it is, all it needs is a minor tweak to the dynamics params for the craft.

quote:


Sure like how the shuttles land, then count down to dust off. Very cool!

Another of several subtle BCG feature I ported over to BCM - just for the hell of it.

If you really want to blow your mind, try this

  1. pack a bunch of marines into a shuttle
  2. set three waypoints (1) deploy team (2) deploy drone (3) extract team - around a friendly base and make sure that the distance between the waypoints is at least 2.5km (1.68 mls)
  3. beam down a team (4) of marines about 500m from the location of the 3rd waypoint.
  4. mark all members of the team for extraction
  5. put your CC on hold (A/P) and beam your AE down to the location of marine team marked for extraction.
  6. launch the shuttle so that it carries out the waypoint orders

Depending on where you are, you should see the shuttle land at the 3rd waypoint. And since the team is far away, they will then start to run toward the shuttle.

You can even beam your AE down to the first waypoint to see the shuttle deploy the team, then sprint (or jetpack) your way over to the 3rd waypoint.

When I tried that during testing, it was so cool, I started shooting my marines to make them run faster. I even managed to have the shuttle leave a marine behind once. Poor b*astard was too injured to run fast....and he got left behind. But we went back and got him though.

Now, if you're really up to it, try reproducing this scenario within hostile territory while under fire.

[ 06-23-2002, 11:26 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

quote:


Originally posted by T-WOPR:

I can't deploy anything from shuttles either. Not even SF marines in space. And I get the same problem with jumping too, taking damage.


As I thought, the deployment is a ai+dynamics issue. So, for now, you can either keep trying and hope the shuttle actually does it, or, do it manually yourself from the shuttle HUD menu. Sorry, but it is a release candidate patch

I have sorted out the jumping issue by reducing

the threshold.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×