Jump to content
3000AD Forums
Sign in to follow this  
Supreme Cmdr

BCM 1.0.08 RC23 Released

Recommended Posts

OK, I usually don't try RCs because I don't want anything happening to my save games, but this got me interested. Going to try it out tonight, post about it tomorow night. Sounds like a cool bunch of things happening in this one.

Share this post


Link to post
Share on other sites

Has anyone been able to extract a team of marines yet? I cant figure it out. The shuttle lands a long way away, but my marines dont even atempt to run towards it after its landed.

Ive selected them for evac, but they dont move.

SC, does the fact that the shuttle over shoots its waypoint mean that the AI of the pilot is too low? I dont have any really high AI marines/pilots to see if it lands closer.

Share this post


Link to post
Share on other sites

You won't hear some of the fp weapon sounds. In which case, download this small update and unzip it (with folders) into your BCM install over. It replaces one of the INI files in the DATA folder.

This file is now included in the original RC9 patch which has also been re-uploaded.

BCM 1.0.08RC9(B)

[ 06-23-2002, 07:22 PM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

quote:


Originally posted by Roberto:

Has anyone been able to extract a team of marines yet? I cant figure it out. The shuttle lands a long way away, but my marines dont even atempt to run towards it after its landed.

Ive selected them for evac, but they dont move.

SC, does the fact that the shuttle over shoots its waypoint mean that the AI of the pilot is too low? I dont have any really high AI marines/pilots to see if it lands closer.


I think I know what the problem is. I need to merge some other piece of code I just looked at.

The pilot will seek out the best landing spot. Even the lowest AI pilot should be able to find one. So thats not the problem.

It works fine in BCG and I just tested it in BCM as well (with a change I just made) and it works fine. I'll probably upload another RC today or tomorrow.

In case you were wondering, the default Situational Awareness (SA) value is too low, thats why the marines don't know the shuttle has actually landed. This value was introduced in BCG and never existed in BCM. Up until now, that it

Share this post


Link to post
Share on other sites

Great news . Im assuming that this is the reason why the shuttle wouldnt take off too.

Im looking forward to trying the next RC out, as always

Share this post


Link to post
Share on other sites

Awww I was about to post about the lighting effects on the planets, when I realised you just updated the VCF with a comment about it.

Im glad you caught that one about the light direction moving with the camera.

Nice effects by the way.

Share this post


Link to post
Share on other sites

quote:

# On planet, the daily visual track of the sun is now more accurate in an East to West pattern.

Do some planets spin the other way?

quote:

# FIXED: Marines without jetpacks were able to fly

LOL!!!

Share this post


Link to post
Share on other sites

quote:


Originally posted by Epsilon 5:

quote:

# On planet, the daily visual track of the sun is now more accurate in an East to West pattern.

Do some planets spin the other way?


You are talking about something entirely different.

Ever heard of the Sun rising in the East and setting in the West? Good. Now siddown.

Share this post


Link to post
Share on other sites

quote:

Ever heard of the Sun rising in the East and setting in the West? Good. Now siddown.

Yeah, I was just being curious. Would be fun to have a sun rising in the west and then setting at east.

[ 06-27-2002, 06:09 PM: Message edited by: Epsilon 5 ]

Share this post


Link to post
Share on other sites

actualy venus spins the other way. im not sure if it does it ingame, and i cant check cause im grounded from games for failing english (BCM replaced hw and it didnt turn out to well )

Share this post


Link to post
Share on other sites
Guest MIKE113

quote:

Originally posted by insecttoid3:

actualy venus spins the other way. im not sure if it does it ingame, and i cant check cause im grounded from games for failing english (BCM replaced hw and it didnt turn out to well )

That is true, check the movie here.

Share this post


Link to post
Share on other sites

Sc i wanted to ask you...since the SA on marines are higher when i teleport them into an enemy base or near enemy forces.

Because with MI marines they wouldn't deploy in an SAD mode and wouldn't even pull out their weapons when in hositle territory

Share this post


Link to post
Share on other sites

quote:

Originally posted by MIKE113:

quote:

Originally posted by insecttoid3:

actualy venus spins the other way. im not sure if it does it ingame, and i cant check cause im grounded from games for failing english (BCM replaced hw and it didnt turn out to well )

That is true, check the movie here.


Ahh right.. and I even know why, I remember i read about it a while ago... all planets are bound to slow down in their rotation, but the thick cloud cover of Venus made it stop much faster, and then made it go the other way. All logical, but I can't go in any more details than that, can't remember well.

Share this post


Link to post
Share on other sites

quote:


Originally posted by JJ:

Because with MI marines they wouldn't deploy in an SAD mode and wouldn't even pull out their weapons when in hositle territory


NPCs only ready their weapons when a detected threat is within range. Nothing to do with SA.

Share this post


Link to post
Share on other sites

1.0.08 RC12 has been released. Read my revised first post in this thread for more info and the download location.

Share this post


Link to post
Share on other sites

I've noticed something since 1.0.07 but had forgotten to mention it. The thing is that Artifacts That Need Nothing but installing to function dont work. In a Firestorm Carrier i tried installing the kakaranian reactor and the T.A shields but none of them could be installed, the Upgrade option in logistix wasn't highlighted... Something i haven't noticed/done?

Share this post


Link to post
Share on other sites

I installed the patch over version 1.0.07 and when I clicked on the bcm.exe icon, the program didn't startup. Just to make sure I did a fresh install and then I installed the 1.0.07 patch and then the 1.0.08 rc12 patch on top of that. I don't know if anyone else has this problem.

Share this post


Link to post
Share on other sites

quote:


Originally posted by Cmdr_ Laracuente:

I've noticed something since 1.0.07 but had forgotten to mention it. The thing is that Artifacts That Need Nothing but installing to function dont work. In a Firestorm Carrier i tried installing the kakaranian reactor and the T.A shields but none of them could be installed, the Upgrade option in logistix wasn't highlighted... Something i haven't noticed/done?


Learn how to play the game. Read the manual and VCF while you're at it.

Share this post


Link to post
Share on other sites

quote:


Originally posted by Vindi89:

I installed the patch over version 1.0.07 and when I clicked on the bcm.exe icon, the program didn't startup. Just to make sure I did a fresh install and then I installed the 1.0.07 patch and then the 1.0.08 rc12 patch on top of that. I don't know if anyone else has this problem.


Worked fine when I did it. The RC12 patch will rename some files. So if you didn't (gasp!) apply the patch from within the folder where the game is installed, it won't find them.

Share this post


Link to post
Share on other sites
Guest MIKE113
Originally posted by Cmdr_ Laracuente:

I've noticed something since 1.0.07 but had forgotten to mention it. The thing is that Artifacts That Need Nothing but installing to function dont work. In a Firestorm Carrier i tried installing the kakaranian reactor and the T.A shields but none of them could be installed, the Upgrade option in logistix wasn't highlighted... Something i haven't noticed/done?[/quote

If you are at a station they won't let you upgrade, you have to leave the station and start the upgrade, then you can go back to the station and finish it if you want. That is the only reason I can think of......

Share this post


Link to post
Share on other sites

Applied rc 12 and tested. Found what appears to be a bug. Start game, put a marine in shuttle. Set a waypoint to moon to drop off probe. Shuttle will not return to ship after operation, nor will it RTB as commanded. Just wonders around confused. This all worked in 1.07.

Also dust off count wrong during 10 second increments. Hope this helps.

[ 07-09-2002, 01:53 AM: Message edited by: b1bob ]

Share this post


Link to post
Share on other sites
Sign in to follow this  

×