Jump to content
3000AD Forums
Sign in to follow this  
Supreme Cmdr

BCM 1.0.08 RC23 Released

Recommended Posts

Guest Fox__Trot

quote:

Originally posted by Supreme Cmdr:

Check your system.

And the fact that you're starting the game by clicking on the bcm.exe file, in itself is just foolish. While that should work, there is a reason that program shortcuts are created.

Try adding the /d2 parameter to the shortcut and when it quits, check the resulting .log files (post them here if you want) for clues on what might be the cause.

Have you ever run any of the 1.0.08 RC versions? If not, did you actually
try
running just RC15 prior to patching to RC17, before crying bug? A lot of people are running RC15 - including all the testers - and no such non-startup issue has been reported.

Ok checked the system its working fine and the profile is now updated (it was updated actuly)

I started bcm both With the shortcuts and when I noticed those werent working I figured the shortcut was messed up so I launched from the folder itself

/d2 I just ran the /d2 and the results

bcdebug.txt

Resource files loaded ok

Loading objdefs.dat

-- Game shutting down --

Initialise message queue

Flushing regions

Freeing visitor list

Flushing groups

bcgfxdebug.txt

--- Debug log opened ---

--- Debug log closed ---

(this occourd ONLY with rc 17 with rc15 I couldt even get a log file to be created)

I tried running both RC 15 and RC 17 and i checked them three times *first time patching* then the first re-install AND the second re-install and it NEVER worked

[ 08-15-2002, 10:21 PM: Message edited by: Fox__Trot ]

Share this post


Link to post
Share on other sites

Patch properly and you won't have a problem

The RC15 patch deletes and renames some critical files. If you don't apply that patch problem, you're never going to get BCM to run. Period.

If you know how, go to a console window in the folder where you have BCM installed and type dir /s > bcmfiles.txt.

Then use Notepad to copy and paste the contents of the bcmfiles.txt file here. Make sure you post it within UBB code blocks so that it is readable.

[ 08-15-2002, 10:24 PM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites
Guest Fox__Trot

This is with rc 17 installed however I am sorry if this is not what/where you wanted it to be.

code:

Volume in drive D has no label.

Volume Serial Number is 5033-6D07

Directory of D:Program Files3000ADBattlecruiser Millennium

08/16/2002 12:44 AM <DIR> .

08/16/2002 12:44 AM <DIR> ..

12/21/2001 10:03 AM 153,718 00000409.016

12/21/2001 10:03 AM 308,278 00000409.256

09/24/2001 10:00 AM 77 3000AD Website.url

08/15/2002 10:34 PM 2,287 bcconfig.ini

07/29/2002 10:08 AM 3,358,191 bcm.exe

09/24/2001 10:00 AM 2,238 bcm.ico

08/14/2002 08:29 PM 8,524,740 bcm1007.exe

08/14/2002 04:34 PM 3,947,894 bcm1008RC15_update.exe

08/16/2002 12:44 AM 0 bcmfiles.txt

08/15/2002 10:30 PM 791 bcmsetup.ini

09/24/2001 10:00 AM 33,702 bcmsfx.ini

09/24/2001 10:00 AM 6,356 bcmxpl.ini

08/15/2002 10:11 PM 791 bcsetup.ini

09/24/2001 10:00 AM 33,702 bcsfx.ini

07/25/2002 10:08 AM 6,261 bcxpl.ini

08/15/2002 10:32 PM <DIR> data

08/15/2002 10:32 PM <DIR> docs

07/13/2002 01:24 PM 40,960 DrvMgt.dll

06/16/2002 10:08 AM 49,031 english.lng

09/24/2001 10:00 AM 5,583 eula.rtf

08/15/2002 10:26 PM <DIR> gfx

08/15/2002 10:31 PM <DIR> models

08/15/2002 10:32 PM <DIR> pte2

08/15/2002 10:26 PM <DIR> save

08/15/2002 10:26 PM <DIR> scripts

07/13/2002 01:24 PM 11,376 SECDRV.SYS

08/15/2002 10:26 PM <DIR> shots

08/15/2002 10:27 PM <DIR> soundfx

19 File(s) 16,485,976 bytes

Directory of D:Program Files3000ADBattlecruiser Millenniumdata

[ 08-16-2002, 07:39 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

quote:


Originally posted by Fox__Trot:

This is with rc 17 installed however I am sorry if this is not what/where you wanted it to be.


I edited your post because it was too long. Anyway....

Some of those files are incorrect!!

This file is not from RC17. Look at the date!!!

07/29/2002 10:08 AM 3,358,191 bcm.exe

These files should not exist. The patch is designed to rename them. And going by the

fact that the old and new (renamed) versions exist, this tells me you installed the patch

incorrectly. You probably don't have admin rights to your XP system. I mean admin

rights, not some user logged in as admin.

08/15/2002 10:30 PM 791 bcmsetup.ini

09/24/2001 10:00 AM 33,702 bcmsfx.ini

09/24/2001 10:00 AM 6,356 bcmxpl.ini

Going from the above and the fact that the RC17 patch file itself is missing from

that folder, you didn't install, nor patch correctly. Unless I'm missing something.

The RC15 patch deletes and renames a LOT of files in different folders and most

of yours are wrong (as with the examples above).

Again. Unless you patch properly, you won't be able to run this patch (nor any future

patch for that matter).

In fact, send the bcmfiles.txt and all your INI files to [email protected] and I'll

take a look at them again.

[ 08-16-2002, 08:06 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites
Guest Fox__Trot

I sent the files and im looking at how to get admin rights to my system (As to why a user logged in as admin wouldt already have rights... ) anyways

Share this post


Link to post
Share on other sites

quote:


Originally posted by Fox__Trot:

I sent the files and im looking at how to get admin rights to my system (As to why a user logged in as admin wouldt already have rights... ) anyways


You know what I HATE the most? People wasting my time.

I looked at the INI files you sent, including the entire bcmfiles.txt file.

  1. This patch is INCORRECTLY applied (as I already stated in my previous post)
  2. The files are NOT from RC17 (as you indicated above)
  3. The BCCONFIG.INI file is NOT from a new game because if it was, MOST of the entries below wouldn't be in it!!! e.g. the game's default res is 640x480. You have it set to 1280x1024. How did you get into CONFIG in order to change the defaults, if you CAN'T run the game?!?!?!?!

What does all this mean? Simply that you did NOT follow the instructions for applying a patch. Period. If you had, for one thing, your BCCONFIG.INI file would contain default entries. AND since you claim to have started from scratch, there wouldn't even BE a BCMCONFIG.INI file for the RC15 patch to rename because it would NOT exist if you NEVER did run the game AFTER patching from 1.0.07 to 1.0.08 RC15.

If you were doing this properly, the FIRST time you would've have to run the game, is AFTER patching to 1.0.08 RC17. At which point, a new BCCONFIG.INI file would be created at startup.

Apart from that, there is a good chance that if you load BCCONFIG.INI into Notepad and changed that 1280x1024 to 640x480 or if you just deleted it and let the game create a new one with defaults, the game would probably load. If not, again, start from scratch and apply the patches properly.

code:


[frontend]

saveStats=NUM-

quit=ESC

exit=SHIFT+ESC

logistix=F1

tactical=F2

navitron=F3

tradcom=F4

miscon=F5

roster=F6

commlink=F7

config=F8

ElapseTime1=Ctrl+T

ElapseTime2=Ctrl+Shift+T

ScreenShot=Ctrl+G

[Joystick]

HatMode=ALT+J

FireLaser=JBUTTON1

FireMissile=JBUTTON2

NearestTrgtInLineOfSight=JBUTTON3

ClosestAttacker=JBUTTON4

ClosestEnemyTrgt=JBUTTON5

ClosestAttackerToCurTrgt=JBUTTON6

PrevEnemyTrgt=JBUTTON7

NextEnemyTrgt=JBUTTON8

CycleWeapon=JBUTTON9

[FP]

FireWeapon=MBUTTON00

MoveForward=W

MoveBackward=S

StrafeLeft=A

StrafeRight=D

TurnLeft=Q

TurnRight=E

MoveUp=F

MoveDown=Z

RollLeft=SHIFT+A

RollRight=SHIFT+D

PitchLeft=SHIFT+W

PitchRight=SHIFT+S

Crouch=C

Jump=SPACE

Prone=X

RunWalkToggle=BACK

Run=SHIFT+W

Hover=F

Salute=;

Wave='

FollowMe=SHIFT+;

HoldPosition=SHIFT+'

HolsterWeapon=0

Wristlaser=1

Scat1Pistol=2

Zs10CombatAssaultRifle=3

Bmp9SniperRifle=4

Hd4sgShotgun=5

Lr12RocketLauncher=6

SabreMlsSpaceAssaultRifle=7

GrenadeFrag=8

GrenadeSmoke=9

DIE=O

TDU=P

Medkit=M

Toolkit=T

DisplayInventory=[

DropCurrentWeapon=B

BackpackTransfer=]

ReloadWeapon=R

WeaponMode=G

[config]

Effects=TRUE

Music=FALSE

SoundFXVolume=10

MusicVolume=10

Resolution=1280x1024

ScreenBitDepth=0

TextureBitDepth=0

DynamicLighting=TRUE

Shadows=TRUE

MipMapping=TRUE

SpaceBackground=32

SpaceBackgroundHR=TRUE

HardwareTL=TRUE

DynamicStarsFX=TRUE

HyperspaceFX=TRUE

HyperJumpFX=TRUE

CloakFX=TRUE

GLobalFX=TRUE

NonPlayerFX=TRUE

DefaultRollYaw=TRUE

ContrailFX=PARTICLE

WeatherFX=TRUE

WaterFX=TRUE

PlanetaryClouds=TRUE

BridgeCommsChatter=TRUE

FlightPathTrails=TRUE

FlightDynamics=0

Throttle=1

PrimaryHatMode=1

Controller=1

BCFEFontName=arial

BCFEFontSize=8

BCFEFontFlags=0

BCKFontName1=microgbe

BCKFontName2=arial

[debug]

Debug=0

[reserved]

Gamma=2.0

Language=0

PlayerProfile=0

ExitOption=16384

[player]

Name=

Sex=

Age=0

Race=

Rank=

Status=

Caste=

Career=

SelfModel=

AssetClass=

AssetModel=

AssetName=

PrimaryLaunchBase=

PrimaryLaunchZone=

PrimaryLaunchScene=

Assignment=

ScenarioFile=

DockLocation=

StartRegion=

Currentloc=

Setnavpoint=

Sethsdnavpoint=

Fines=0

Warrants=0

Salary=0

Finances=0

Experience=0

[player_gear]

GearWeight=0.0

PrimaryGear=

SecondaryGear=

Armor=

Ammo=


[ 08-16-2002, 02:20 PM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites
Guest Fox__Trot

... You can kill me now ...

anyways I got rc 15 to work ... by following the steps *I could of sworn I installed those patchs from the folder* RC 15 works but about rc 17 how do you install that its a .zip just extract it into the bcm folder?

[ 08-16-2002, 02:11 PM: Message edited by: Fox__Trot ]

Share this post


Link to post
Share on other sites

quote:


Originally posted by Fox__Trot:

... You can kill me now ...


Thinking what to type...

quote:


anyways I got rc 15 to work ... by following the steps

So, uhm, why weren't you following the steps before?

quote:


but about rc 17 how do you install that its a .zip just extract it into the bcm folder?

Copy it to the BCM folder and unzip it from there. Make sure you unzip it with folders. Also overwrite any files when prompted.

[ 08-16-2002, 02:21 PM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites
Guest Fox__Trot

I thought I was ... of course I also think I figured out what you ment by giving myself admin rights so maybe that was it

Share this post


Link to post
Share on other sites

quote:


Originally posted by Fox__Trot:

I thought I was ... of course I also think I figured out what you ment by giving myself admin rights so maybe that was it


No, that wasn't it. You didn't apply the patches from the BCM install folder.

Share this post


Link to post
Share on other sites

I have some trouble with RC15 and RC17. I put my AE in a shuttle, with some marines in the OC; I drive the shuttle to the Earth surface, land it, and deploy manually my OC. The results are that the OC is floating over the ground, and its status is FTOL and not TAXI. If i deploy the OC when the shuttle is not on the surface, the OC floats at the altitude is deployed, regardeless of the gravity. In this state, the OC does not accept any command and is not drivable.

I have tried with 1.007 and the OC is deploying regularly.

Share this post


Link to post
Share on other sites

1. Beta patches are unsupported

2. Before posting ANYTHING in pre-release Beta patch forums (or ANYWHERE for that matter), READ the VCF - INCLUDING the section CLEARLY marked as reported issues.

m'kay?

Share this post


Link to post
Share on other sites

quote:

The shuttle can deploy assets while still airborne. This causes a problem where a mining drone can still collect minerals if deployed from an airborne shuttle. This problem is only happening due to relaxed rules which do not require the shuttle to actually *land* first. Once the deploy/evac issue described below is resolved, this problem will disappear.


from the version control file.

i believe that is the issue.

but ive been known to be wrong from time to time

Share this post


Link to post
Share on other sites

Sorry SC, I readed the issue, but my intention was to report that the assets (ATV) remains "airborne" also if deployed by a landed shuttle.

I know that the RC patch is unsupported: if the issue is known, excuse me.

Share this post


Link to post
Share on other sites

Salvor,

This is what the VCF reads reagrding this known problem.

quote:

The shuttle can deploy assets while still airborne. This causes a problem where a mining drone can still collect minerals if deployed from an airborne shuttle. This problem is only happening due to relaxed rules which do not require the shuttle to actually *land* first. Once the deploy/evac issue described below is resolved, this problem will disappear.

[ 08-19-2002, 09:04 AM: Message edited by: Roberto ]

Share this post


Link to post
Share on other sites

Do you guys ever read before you post?

Roberto,

may I direct your attention three posts back (to the mesaage from Cruis.In, 08-18-2002, 06:23 PM)?

Share this post


Link to post
Share on other sites

Hey! How did I miss that one. Your right, my fault. Thanks for pointing that one out for me.

Share this post


Link to post
Share on other sites

Calm down folks, the deploy/extract in BCM is not on my top priority list. If you are reading my posts and VCF, you will see that I ported over the new method from BCG - but BCM had those restrictions relaxed (BCG doesn't). Which is why these quirks are happenining. Since its not a crash, but just something I need to investigate and fine tune for how BCM works, its not my top priority (its not like you can't deploy/extract).

I'm going to be looking at it sometime today.

I've already fixed the issue with losing your ammo when going in/out of vehicles in fp mode.

Apparently, nobody noticed that this was broken before; fixed in 1.0.02 RC11 for TA, but not IA or a full game. heh. Any time you enter a vehicle and exit, your defaults are restored. This overwrites what the script or SNG was set to give you when the scenario starts.

Share this post


Link to post
Share on other sites
Guest Fox__Trot

any updates on the above? (Im too scared to install 1.08 rc 17 im going to wait for the exe )

Share this post


Link to post
Share on other sites

I have made several final changes for this patch and will be releasing it before the mp patch as previously indicated.

The VCF has been updated and only one issue that I cannot reproduce reliably, remains.

I think I've covered all existing bugs. The next bugs I'm probably going to see, are in the mp patch

And before you go off half-cocked and think the m patch is coming tomorrow, know this - The mp patch will be available to the public the same week that BCM Gold goes Gold (around the end of November).

Share this post


Link to post
Share on other sites

The VCF has been fully updated for all final fixes going into 1.0.08.

I think I have tracked down the Sygan Triangle phenomenon to a bug in the terrain height calculation in the PTE2 engine and have alerted Darrin to it. It seems to be a precision loss over time and this accumulates across large distances and depending on the speed of travel across the terrain as well. This probably explains why I couldn't reproduce it - but I noticed another similar anomaly which is related, hence the conclusion. Once I get a fix, I'll incorporate it, test it again and have the tester who reported it (and can reproduce it reliably), run it through and see.

Once thats fixed, 1.0.08 should be baked...assuming that report from Lighting Bold Missy, about artifacts, is in fact a bug. I don't want ANY open bugs in this version because the next major patch (which is about two months away for the public) is the mp patch. The last official patch (1.0.07) was in March and this major 1.0.08 which consists of some bug fixes and a bunch of tweaks is the most advanced update yet. I did most of the tweaks in 1.0.08 with mp in mind. You'll recognize these tweaks when you see them.

[ 10-07-2002, 10:50 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

quote:

assuming that report from Lighting Bold Missy, about artifacts, is in fact a bug.

Hey, I heard that! Anyway, like I say, I'm gona check on it for you and report back. Will start a new game using 1.0.07 with script updates and try to reproduce it.

Share this post


Link to post
Share on other sites

quote:


Originally posted by Lightning Bolt Man:

quote:

assuming that report from Lighting Bold Missy, about artifacts, is in fact a bug.

Hey, I heard that! Anyway, like I say, I'm gona check on it for you and report back. Will start a new game using 1.0.07 with script updates and try to reproduce it.


hehe

Share this post


Link to post
Share on other sites
Sign in to follow this  

×