Jump to content
3000AD Forums
Sign in to follow this  
Supreme Cmdr

BCM 1.0.08 RC patches. Discuss!!

Recommended Posts

quote:

Originally posted by Supreme Cmdr:

nah, don't worry about those gits. I just like winding them up. They're pathetically harmless.

Understood, and acknowledged, Sir. By Thursday, the Odyssey should be ready to finally leave spacedock. She's getting a computer upgrade, and several other refits, but the repair team is almost finished. Then I'll be able to run the new RC24 Simulation through its paces.

I'll tell my marines to leave those gits alone, even though some of them are itching for a good fight, and those gits are just asking for it.

Mildly unreltated question -- have you considered the possibility of a Linux port of the game? While Microsoft has a 43% share of the O/S market, Linux has 18%. And is gaining annually. Just curious.

Let me know if there's anything you need or any villians to kill, Sir. Odyssey out.

Share this post


Link to post
Share on other sites

quote:


Originally posted by DraconisRex:

Mildly unreltated question -- have you considered the possibility of a Linux port of the game? While Microsoft has a 43% share of the O/S market, Linux has 18%. And is gaining annually. Just curious.


I considered it at one point but canned the idea because if you're playing PC games, you should have a Windows system.

Besides, there is a reason that companies doing Linux based games are either not making money or are going (or already gone) out of business.

If Linux games were a viable financial prospect, there would be a lot more of them.

Share this post


Link to post
Share on other sites

quote:

don't worry about those gits. I just like winding them up. They're pathetically harmless.


"Never underestimate the power of stupid people in large groups,"

There are certainly alot of them around. The ones I dislike the most are those who pass judgment on an individual from secondary sources without actually personally investigating the issue. I believe SC is the victim of a gross from of misinterpretation for there appear to be people who attack him and have no familiarity with his works or his enterprise.

~

Anyway, anyone who turns out a starship simulation of this caliber and then show the devotion to make the game FLAWLESS should be commended, not scorned by individuals who have insufficient perceptions of reality.

Share this post


Link to post
Share on other sites

I just came across a minor graphics glitch which affects some of the Frontend screens (e.g. stats, Logistix) as as result of another screen glitch fix in RC23. Its not major, but some parts of the screen will be erased incorrectly. Simply select another button to redraw the screen.

Sorry, I didn't notice this before I released RC24 and the testers didn't catch it either. Its not graphics card related (I know whats caused it).

Share this post


Link to post
Share on other sites

*snicker* 200 mps? man.. wish I could run that fast

Wonder if im the only one who is having this problem..

I've played this game ever sense release and never encountered this problem so im completly baffuled

The problem is, ok I downloaded the 1.0.08 RC24 Beta Patch cause had some fixes in there that would fix a couple problems I had in the past.. but now I encountered a new problem

When I install the patch and attemp to run the game it gives me BCM logo, then stops... doesn't load up the intro, nothing, it just stops loading, I attemp to start the game again, and nothing.

Back to 1.0.07 for now.

Anyone know what type of a problem this is?? cuase I have this feeling im the only one getting it =(

Share this post


Link to post
Share on other sites

Try completly un-installing the game (un-install and then delete the 3000ad folder) then re-install, add patch 1.0.08 RC23 then RC24. See if that helps.

What M/B do you have and do you have the most up to date drivers for it?

Also,coz your're running an NT system, try making a batch file with the line,

"echo off

start /high bcm.exe"

Use this to start the game.

If you don't know how to make a batch file-open Notepad, type the above lines and save as "BCM.bat". Change the shortcut to point to this file.

Share this post


Link to post
Share on other sites

quote:


Originally posted by Supreme Cmdr:

I just came across a minor graphics glitch which affects some of the Frontend screens (e.g. stats, Logistix) as as result of another screen glitch fix in RC23. Its not major, but some parts of the screen will be erased incorrectly. Simply select another button to redraw the screen.

Sorry, I didn't notice this before I released RC24 and the testers didn't catch it either. Its not graphics card related (I know whats caused it).


This is an nVidia driver issue which only seems to happen on the 40.72 drivers.

quote:


Originally posted by Kalshion:

When I install the patch and attemp to run the game it gives me BCM logo, then stops... doesn't load up the intro, nothing, it just stops loading, I attemp to start the game again, and nothing.


You either installed the patch incorrectly or it is a SafeDisc problem with your CDROM. I am now using the latest SafeDisc tools.

quote:


Back to 1.0.07 for now.

Good luck. If you don't fix it in the RC24 patch, you'll never be able to run any patches past 1.0.07.

quote:


Originally posted by LBM:

Also,coz your're running an NT system, try making a batch file with the line,

"echo off

start /high bcm.exe"

Use this to start the game.


Thats got nothing to do with anything

[ 11-05-2002, 09:46 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

quote:

quote:

--------------------------------------------------------------------------------

Originally posted by LBM:

Also,coz your're running an NT system, try making a batch file with the line,

"echo off

start /high bcm.exe"

Use this to start the game.

--------------------------------------------------------------------------------

Thats got nothing to do with anything


I know, I just thought I'd mention it!

Share this post


Link to post
Share on other sites

SafeDisc tools??? ummm I never heard of SafeDisc

well I'll attemp to install the patch again... infact I'll try all night =

Could my problem is registry related?

and as for deleting the whole folder I did that before posting my problem and I got the same resuit, so me it looks like the EXE is having problems locating BCM *meaning it has problems locating the batch file that runs the game, I think*

[ 11-05-2002, 05:57 PM: Message edited by: Kalshion ]

Share this post


Link to post
Share on other sites

quote:


Originally posted by Kalshion:

so me it looks like the EXE is having problems locating BCM *meaning it has problems locating the batch file that runs the game, I think*


The game doesn't use a batch file. If the BCM splash screen comes up and the game doesn't run, then it means that (a) the game is installed incorrectly (B) the SafeDisc copy protection cannot find the BCM disc in your CDROM drive.

Share this post


Link to post
Share on other sites

Arghs... and I just got a new CDROM to, what confuse's me is why the game runs on 1.0.0.07 and not on .08 cause before I install this patch I could run the game just fine, it reconized the CD, but after installing the patch its like it can't find it,

Arghs this stinks

Wait a second.. when I reinstalled the game I wasn't able to get any patchs BELOW 1.0.0.07 and I reinstalled the game BEFORE 1.0.0.08 was release'd.... could this be causing my problems?

Somehow I think it is, I order'd the patchs off of Gamespot *im a member* so there coming via CD =) I'll install those patchs and pray they work, if not... well then I'll continue trying! I've been playing this game for FAR to long to stop just becuase a patch wants to be stubborn

[ 11-05-2002, 10:03 PM: Message edited by: Kalshion ]

Share this post


Link to post
Share on other sites

quote:


Originally posted by Kalshion:

Arghs... and I just got a new CDROM to, what confuse's me is why the game runs on 1.0.0.07 and not on .08 cause before I install this patch I could run the game just fine, it reconized the CD, but after installing the patch its like it can't find it,


Didn't I say that I am using the latest SafeDisc tools? I get regular updates from Macrovision and every other patch (including 1.0.07) has used a new update. Since the RC23 patch, I've been using the latest version. And so far, you are the only person having a problem.

So, since you have a new CDROM, you might want to (a) check with your vendor to make sure it has the latest firmware (B) read the BCM FAQ which includes a link to a fix for SafeDisc available from Microsoft.

quote:


Wait a second.. when I reinstalled the game I wasn't able to get any patchs BELOW 1.0.0.07 and I reinstalled the game BEFORE 1.0.0.08 was release'd.... could this be causing my problems?

If you don't read the FAQ - specifically the section about patches - you only have yourself to blame.

Even this announcement thread contains several posts (including the FIRST post) about how to patch up to the latest version of the game. So, what exactly did you miss?

quote:


Somehow I think it is, I order'd the patchs off of Gamespot *im a member* so there coming via CD[/QB]

I don't think you have a clue what you're doing - even though it has been stated over and over and over.

You only need ONE SINGLE PATCH to go from the clean CD install to 1.0.08 RC23. To go from RC23 to RC24, is a smaller patch.

[ 11-06-2002, 08:41 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

bangs head 97 times on his keyboard, keyboard breaks in half

Sorry

Lower's head and awaits the Supreme Cmdr to pull a gun on him

ok.. it works now... I knew i was doing something wrong, But I have NEVER had to download the zip file and put it into the install folder then unzip, I have never had to do that. So it never crossed my mind that it was needed.

But I have it working now... soo how you gonna kill me?? *I didn't read FAQ cause I didn't know there would a answer to my problem*

[ 11-06-2002, 02:33 PM: Message edited by: Kalshion ]

Share this post


Link to post
Share on other sites

Support vehicles will not folloew orders for me correctly in rc 23/24. They also have trouble leaving a planets surface, will skim around at gorund level and not launch.

Share this post


Link to post
Share on other sites

quote:


Originally posted by HiPingScoba:

Support vehicles will not folloew orders for me correctly in rc 23/24. They also have trouble leaving a planets surface, will skim around at gorund level and not launch.


Read the VCF

Share this post


Link to post
Share on other sites

quote:

Originally posted by Supreme Cmdr:

quote:

Originally posted by HiPingScoba:

Support vehicles will not follow orders for me correctly in RC 23/24. They also have trouble leaving a planets surface, will skim around at gorund level and not launch.

Read the VCF


Is this the same as the collision avoidance issue, in the VCF? Ships in space seem to avoid their targets, ie fighters or shuttles given orders to return to base, or jump at a specific gate, will get about 38 units away and then abort.

Share this post


Link to post
Share on other sites

quote:


Originally posted by HiPingScoba:

ie fighters or shuttles given orders to return to base, or jump at a specific gate, will get about 38 units away and then abort.


Rubbish

Share this post


Link to post
Share on other sites

quote:

Something is causing the ships to not RTB (cruiser). They only get so close and then stop.

Not happening here, your statement is vague but I tried several test and was not able to reproduce. Here's what I tried:

Used both Super Cruiser - Warmonger and Heavy Cruiser - Star Cruiser for my test.

Launch base - Galcom

From Space:

Launched Shuttle and ordered it to Fly To a jumpgate (which it did) and then RTB - Worked as designed.

Launched Shuttle and ordered it to Jump At a gate (which it did)and then RTB - Worked as designed.

Launched Shuttle and had it immediately RTB - Worked as designed.

On Planet (Earth) Deployed Drone/RTB yes shuttle did slide on the ground for a bit but it then lifted off and RTB - Worked as designed.

This was known by the SC and is listed in the VCF

quote:

Implemented landing VTOL dynamics (from BCG code) for craft deploy/evac ops - making it easier for NPCs to carry out ops

The only things I know that will prevent you from docking are No power to Launch Control and damage to the launch bays. You did check these right?

[ 11-08-2002, 10:15 PM: Message edited by: Gordon ]

Share this post


Link to post
Share on other sites

Hello all,

I've i've done a clean install of BCM and patched up to RC24 and started playing.

I've launched several probes and they don't seem to be behaving as before.......They are travelling very slow. When I launched one in the Jupiter zone and ordered it to jump to Sirius it started that way.....but after several hours it still isn't even halfway to the wormhole.

Is this correct behavior? Is anyone else having this experience? They seemed to move much faster before.

[ 11-09-2002, 12:59 AM: Message edited by: Stormshadow ]

Share this post


Link to post
Share on other sites

From the VCF RC20:

quote:

The probe had two extra zeros in its max speed rating. These have been removed, making its max speed 15000 m/s


Share this post


Link to post
Share on other sites

Each region is about 2.50 million km edge to edge. If the probe is traveling at 15K m/s, which is about 900 k/m, do the math.

If you want to launch a probe, look at your map, then move as close as possible to the jump anomaly that its going to use to leave the region. Then launch it.

I caught that 150K m/s value quite by accident; and I reduced it. I might increase the current (and correct) 15K m/s value after running some tests. But the fact is, 150K m/s is just too fast.

[ 11-09-2002, 02:13 PM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites
Sign in to follow this  

×