Jump to content
3000AD Forums
Sign in to follow this  
Supreme Cmdr

UC 2.00.30 RC15 Patch Released

Recommended Posts

Check the reg page. The online VCF has also been updated.

You have to positively read the VCF before applying this patch. You HAVE been warned.

For those of you new to UC. You need to install the v2.00.00 patch first, before installing this patch on top of it.

WARNING: Due to users going from the base 2.00.00 patch to the current 2.00.xx patch; this patch WILL delete ALL saved games. So, if you are upgrading from 2.00.19 or higher, backup the files in the SAVE folder before applying the patch. If you run an mp server, you should also backup your UCSETUPMP.INI file. After applying the patch, copy them back to the SAVE folder. If you attempt to do this with any saved game version earlier than the specified version, good luck bud.

Share this post


Link to post
Share on other sites

This patch contains our unified GameCQ lobby which was to be released in the final patch. All our future games (including UCO for which it was designed), use this lobby.

It is add-free, spam free and provides a unified interface for chat, server browsing and joining, net browsing etc etc.

It is very much a Beta which we will keep on improving until finalized when Universal Combat Online goes Beta next year; since most of its features are specifically designed for that game only.

The VCF shows you how to install the program. It contains docs which describe the basic features. Everything else is self-explanatory.

Welcome to the future.

EDIT: If you get a "bootstrap" error when you try to connect to a server from within the lobby, your game path is not configured correctly in the registry. Go to this registry entry and make sure the "path" variable is correctly set to where the game is installed. Pay attention to the trailing backslash character in the path!!!

quote:


[HKEY_LOCAL_MACHINESOFTWARE3000adUniversal Combat]

"path"="C:Program FilesDreamCatcher3000ADUniversal Combat"


Do NOT go editing your registry if you don't know what you are doing!!!

[ 07-03-2005, 07:10 PM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

Looks like I packed an incorrect script into the patch. When you try to connect, the client is launching the single player world instead of the mp world.

Looking into it right now. Standby.

EDIT: OK, I have re-issued the patch. If you downloaded it before, grab it again and re-apply it as normal.

[ 07-03-2005, 08:42 PM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

I refreshed the patch this morning. Everyone needs to re-download and apply it on top of the current installation.

The new UCSETUPMP.INI file now contains fields allowing user servers to report to the GameCQ lobby.

Share this post


Link to post
Share on other sites

SC,

I have downloaded and re-downloaded the RC15 patch and it is giving me a message Unable To Locate Component:

This application has failed to start because d3dx9_25.dll was not found. Re-installing the application may fix this problem.

I have re-installed and it is still giving this message. Before I start from scratch, just wanted to see if I may be doing something wrong during the installation process.

Share this post


Link to post
Share on other sites

quote:

Originally posted by Courtney Cox:

SC,

I have downloaded and re-downloaded the RC15 patch and it is giving me a message Unable To Locate Component:

This application has failed to start because d3dx9_25.dll was not found. Re-installing the application may fix this problem.

I have re-installed and it is still giving this message. Before I start from scratch, just wanted to see if I may be doing something wrong during the installation process.

You don't have the latest version of Direct X

Share this post


Link to post
Share on other sites

quote:


Originally posted by Darkling:

You don't have the latest version of Direct X


Why did you tell him? Some of this people think that I spend time documenting VCF because I don't have better things to do.

Share this post


Link to post
Share on other sites

If you are getting a crash when changing game resolutions in Config, I have uploaded a patch refresh. Simply apply on top of the current version.

The version number has not changed.

Share this post


Link to post
Share on other sites

quote:

Originally posted by Supreme Cmdr:

quote:

Originally posted by Darkling:

You don't have the latest version of Direct X

Why did you tell him? Some of this people think that I spend time documenting VCF because I don't have better things to do.


Sorry, didn't see your post until after I posted mine then I had to leave because the baby woke up.. I'll read the entire thread next time before posting.

Share this post


Link to post
Share on other sites

quote:

This application has failed to start because d3dx9_25.dll was not found. Re-installing the application may fix this problem.


Caught me by surprise too until I actually read the instructions on the reg page. Sometimes ya have to pay more attention than normal.

Share this post


Link to post
Share on other sites

quote:


Originally posted by Cmdr Chavik:

quote:

This application has failed to start because d3dx9_25.dll was not found. Re-installing the application may fix this problem.


Caught me by surprise too until I actually read the instructions on the reg page. Sometimes ya have to pay more attention than normal.


Wot!!!

Share this post


Link to post
Share on other sites
Guest Shingen

Hey, I didn't know if I should've started a new tech thread or this is just a simple problem.

Anyway, I getting weird graphical glitches on planetary surfaces for some reason. I was wondering if anyone else was seeing this or if it's just on my end somewhere.

I don't remember it happening with that last patch.

shot 1

shot 2

shot 3

Thanks

Share this post


Link to post
Share on other sites

Same problem here.

Updated divers to the latest Catalyst 5.6 plus did a clean install of UC.

Didnt help.

Zoom to a mission zone like Insurgent/Earth18[s Base]/Base_Earth02.

Plus I have some other information which may help.

Share this post


Link to post
Share on other sites

I think I know whats going on. Lemme check something quick. brb

EDIT: Glitches due to DirectX 9 revisions. A new patch will be released later today.

[ 07-07-2005, 07:41 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

This application has failed to start because d3dx9_25.dll was not found. Re-installing the application may fix this problem. I am also getting this error when I try to run the game after installing the ver 200.30 patch. I have directx 9.0c, whatelse could be wrong? I read the VCF but just bought the game today, New unplayed install. Patch version 200.00 works, the game starts no problem, only when I install ver 200.30 do I get this error.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×