Jump to content
3000AD Forums
Sign in to follow this  
Supreme Cmdr

UCAWA 1.00.14 Patch Released

Recommended Posts

This patch requires the April 2006 (or later) DirectX runtime

Use the game Updater to download and apply the patch.

The online VCF has also been updated.

NOTES:

If you use the game's Updater, the process will go like this:

  1. If you have any version lower than 1.00.07, it will download the 1.00.07 update first. After applying this, you need to run Updater again so that it can download the incremental update to the latest version. You will have to run the Update multiple times to get all the updates to the latest version.
  2. If you already have 1.00.07 or higher installed, it will download only the incremental update to the latest version.

If you don't want to use the Updater, then you have to check one of the public mirrors for a link to the full patch; which you should then copy into the game's folder and execute from there.

Though this latest patch contains a new SETTINGS.INI file, if the Updater downloads the patch but it doesn't run or you discover that it didn't patch, you may need to edit the SETTINGS.INI file in Notepad and make the following changes :

  1. version=1.00.13 to version=1.00.12 (or change this to whatever the previous version was)
  2. location=. to location=%updater%

Then save the file and run the Updater again.

WARNING: DO NOT DOWNLOAD THE PUBLIC PATCHES AVAILABLE ON DOWNLOAD MIRRORS IF YOU HAVE THE DOWNLOAD (e.g. DIRECT2DRIVE) VERSION OF THE GAME!! USE THE UPDATER INSTEAD. ONCE THE PUBLISHERS MAKE THEIR VERSIONS OF THE PATCH AVAILABLE, THE UPDATER WILL DOWNLOAD THEM. THE TIMETABLE FOR THOSE PATCH RELEASES IS UP TO THE PUBLISHER DUE TO HOW THEIR PROTECTION SYSTEM WORKS.

[ 05-12-2006, 06:30 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

I downloaded the 1.00.14 patch and installed it, and it works great in single-player, but when I try to get onto one of the multi-player servers it keeps crashing on me. One time it crashed I did see a dialog box with the message 'floating point not loaded'. Is this the same problem as 1.00.13 had?

Share this post


Link to post
Share on other sites

Odd. Lemme check.

Also, try running it in a window to see if thats the message you are actually getting.

Anyone else with an AMD proc having the same problem? I can't reproduce it on my 4800+ and its not happening in the single player, then it should not be happening in the multiplayer.

[ 04-11-2006, 06:01 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

btw, if your mp window shows 1.00.13.01 version number, just ignore it. I later refreshed the version number, but only for the Starforce version. If you want that version, just edit your settings.ini file, set the version to 1.00.13 and run the Updater.

Share this post


Link to post
Share on other sites

I just ran it again but in a window and got a dialog box saying:

-------------------------------------

Runtime Error!

Program: E:Games3000ADUniversal Combat A World ApartUCAWAMP.EXE

R6002

- floating point not loaded

-------------------------------------

Share this post


Link to post
Share on other sites

I can confirm. Exactly the same results as Matchoo, sp no problems, mp crashes after the scenario is loaded (but before deployment) with the floating point not loaded message

(I have an AMD64 3500+)

Share this post


Link to post
Share on other sites

OK, thats weird. Anyway, I refreshed the build yesterday. So edit your settings.ini file and set the version back to 1.00.13 and run the Updater again. Then try mp. If it still has the same problem, let me know.

Ben, I'll create a topic later today in Area 51 so that we can research this. Since you can reproduce it, please check my post and response accordingly.

Share this post


Link to post
Share on other sites

Apparently, I posted to the wrong thread before I found this one. I am having the floating point error as well. I tried deleting from the other thread but it won't let me. "I downloaded the D2D version and it worked fine but as soon as I patch to 1.00.14, I get the floating point (r6002, floating point not loaded) error. I've downloaded the latest directx drivers, tried patching with the version provided at D2D and also tried using the updater." My difficulty is in all modes. I cannot run single or MP mode.

Jon

Share this post


Link to post
Share on other sites

That's OK, we'll get to the bottom of this (well, SC will, the rest of us just do what we can to help him narrow down the possibilities )

Please add your system profile to your signature when reporting a technical issue. It helps us narrow things down.

Share this post


Link to post
Share on other sites

please use this thread for testing your signature (it avoids cluttering up other threads.

Thanks,

Share this post


Link to post
Share on other sites

Ben and I are working on it. Apparently its now fixed in the mp version, but the sp version is now having the error.

This is definitely isolated to some AMD chips because the compiler is trying to be smart and is not loading the FPU libs when it should. So far, none of us devs have any frigging clue why Microsoft's compiler seems to be having this problem with [some] AMD and not Intel CPUs. It probably due to how the FPU is on the individual chips. Either that or its a conspiracy.

Share this post


Link to post
Share on other sites

Oh, no, SC, you used the c- word! You'd better head for your bunker before the microsoft snipers arrive

Share this post


Link to post
Share on other sites

OK, I've resolved it and will be uploading a patch refresh later today. I will post when its built and uploaded.

Share this post


Link to post
Share on other sites

I have uploaded a refresh. You ONLY need it if you have an AMD processor and are experiencing the problem mentioned in this thread.

To download this refresh, follow the procedure in the first post to set your INI version number to 1.00.13, then run the Updater.

EDIT: The Direct2Drive version is not up yet. I'm waiting for IGN to send me the protected files so that I can build and upload the patch.

Share this post


Link to post
Share on other sites

The Direct2Drive version is up on our site via the game Updater. It should be up on their site later today.

Share this post


Link to post
Share on other sites

I have, so far, been unable to get this to work (D2D version). I have used the updater as well as downloading from the website. I am still receiving the floating point error.

Jon

Share this post


Link to post
Share on other sites

It now works without problems for me, so our systems are obviously different in some crucial way.

Anyone else still experiencing this problem?

Share this post


Link to post
Share on other sites

quote:


Originally posted by Milamber:

I have, so far, been unable to get this to work (D2D version). I have used the updater as well as downloading from the website. I am still receiving the floating point error.

Jon


Apart from the DRM being used, the executable is no way, shape or form different.

So, try following the instructions again for rolling back to the previous version then use either the in game Updater or the direct link (it has now been updated) from the Direct2Drive patch page.

Share this post


Link to post
Share on other sites

Ok, I deleted and reinstalled the entire thing this morning. Tried the patch again this evening. Interesting results. I cannot begin a new game but I can restore the one I've been playing under version .08. THAT game was saved with a view of the bridge, the ship in close proximity to Phobos, 8 fighters deployed and 4 mining drones deployed. No enemies (just to give you some idea of the AI environment). I had also turned off the nuke reactor and engines. When I restored under the patch, I had the following effects:

1. The deployed fighters continue their patrol and comms.

2. I have physical control of the ship. I can access the icons on the left and turn the shields, engines, etc. on and off.

3. Accessing TACOPS causes an immediate floating point crash but I CAN access logistix and tactical and all of their submenus and successfully return to the bridge.

4. F1-F4 work correctly but F-9 or F-10 is another FP crash.

5. Mouse hover on the targets in the center display will crash but not immediately. Clicking one of those targets is a crash.

6. I can access the command menus on the right. I can issue my CC an order to Patrol or SAD (it doesn't do it) but if I access a menu to tell anything like a fighter to fly to: as soon as I click "friendly", "enemy" or anything of that nature, crash.

7. I can access the right-hand window displays (sorry, I'm new to this game and I don't have all the display acronyms memorized yet) and see all of the relevent information there.

On a good note though, I've been playing the unpatched version all doggone day. Awesome game! I hope the info is helpful and I really hope it's not something stupid I'm doing.

Jon

Share this post


Link to post
Share on other sites

NONE of the above has ANYTHING to do with the issue as it regards the 1.00.14 patch.

All you were supposed to verify is whether or not you were still getting the floating point error with this patch. If you are using a corrupt or incompatible saved game, thats a completely different issue entirely and has no business being in this thread.

Your post will be deleted shortly.

Share this post


Link to post
Share on other sites

OK, I've deleted the file on the server and re-uploaded it, just in case. Please rollback to 1.00.13 as described in the FIRST post in this thread. Then use the game Updater to re-download and apply the patch again. Let me know the results.

Please do NOT do a clean install as thats just a waste of time.

Share this post


Link to post
Share on other sites

In single or multiplayer?

What is the date/time stamp and size of the UCAWA.EXE and UCAWAMP.EXE files?

Are you 100% certain that you are doing the rollback correctly and patching using the game Updater and not the patch on the [yet-to-be-updated] Direct2Drive downloads page?

In fact, roll back to 1.00.12 by setting your INI file to that version. Then run the Updater to grab the 1.00.13 patch. See if the game runs. If does, run the Updater again (no need to change the INI file) and it will then grab the 1.00.14 patch.

Also, please correct your registration profile and put in the exact model of your AMD processor (e.g. AMD 3500+). What you have there right now is incorrect.

[ 04-15-2006, 08:06 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites
Sign in to follow this  

×