Jump to content
3000AD Forums
Sign in to follow this  
Supreme Cmdr

How to patch Universal Combat A World Apart using the Updater

Recommended Posts

UCG has an Updater which checks the server for updates. If an update is found, it will download it for you, copy it to the game folder and run it.

The downloaded patch file will remain in the game folder.

If no patch is found - or if you already have the current version - the Updater will just quit.

Note that the Updater will ONLY download officially released patches.

If you want to re-download a patch e.g. if the same patch version was re-issued (e.g. due to mishap, missing files etc). Open up the SETTINGS.INI file (in the game runtime folder) in Notepad and edit the version= line to the previous version.

e.g.

If you updated to 1.00.02 and that same patch was re-issued. You need to delete the patch file (e.g. ucAWA_1.00.02.exe), then change version = 1.00.02 to version = 1.00.01. When you run Updater again, it will re-download the 1.00.02 patch.

NOTE: All e-commerce versions of the game, use various DRM based copy protection schemes. For this reason, each requires its own unique patch.

e.g. you cannot download the patch for a version of the game that uses Starforce ProActive (e.g. BMT Micro) for your TryMedia purchase (which uses their own ActiveMark DRM scheme). For this reason, each version of the game has a unique game Updater settings which will download the correct patch if available on our servers. When patches are released, they are released for all versions of the game.

So, if you go and [manually] download a StarForce patch version and install on your ActiveMark DRM version, you won't be able to run the game.

[ 10-05-2005, 09:24 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

Got my copy yesterday

Install

Meet Starforce

Input my CD key

Running

Reboot

Running UCAWA

Everything look awesome,planets,ships,fighters,Everything!

But when I quit UCAWA,everytime I try to use Updater,it got "Can't connect to server" message~

I've set my firewall allow updater to connect to internet,is server down??

Share this post


Link to post
Share on other sites

I am still having the same problem with not connecting to the server for updates. I have checked my ports on my router, including MP ports from the VCF. I even turned off the Windows firewall(forgot to turn it off when I installed my router ) Is there a particular port that needs to be open for the updater? I have looked in the troubleshooting faq and the VCF and can find no mention of such a thing. Searches in the forums turn up nothing either.

I apologize for the dearth of info in my last post. Due to the lateness of the hour my brain had stopped working properly a couple of hours before.

Share this post


Link to post
Share on other sites

The patch server works just fine. It is running on the same server that the CD-KEY auth is running on. Sometimes - during a reboot - it may be down.

If the mp game can access the internet, so can the Updater tool.

Also, the Updater will attempt to connect to the developer site in order to update itself. If their site is down, then it won't update itself. Download this version and extract into your game folder; overwriting both files when prompted. This new version allows Updater to check our website instead of the developer's in order to self-update.

quote:


Originally posted by Commander Shih:

Running UCAWA

Everything look awesome,planets,ships,fighters,Everything!


Hey, Clown. Are you aware of this thread?

[ 08-26-2005, 08:41 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

That was it! Thank you.

Share this post


Link to post
Share on other sites

quote:

Originally posted by Supreme Cmdr:

The patch server works just fine. It is running on the same server that the CD-KEY auth is running on. Sometimes - during a reboot - it may be down.


Cannot get the updater to connect. I've opened the ports mentioned in the VCF for Multiplayer, also downloaded and used the updater posted earier by SC, still says "cannot connect to server."

The activation went through flawlessly even before opening those ports on the router.

Is there a specific port that needs to be opened for the updater to connect? I've tried everything I can think of and it simply will not connect to the server.

Any ideas?

Opened ports per VCF...

2302-2304 (UDP/TCP)

2425-2427 (UDP/TCP)

27243-27245 (UDP/TCP)

27900-27900 (UDP)

Share this post


Link to post
Share on other sites

The servers are down for maintenance but you can download the patches from several online mirrors via the file downloads page.

[ 02-15-2006, 09:06 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×