Jump to content
3000AD Forums
Sign in to follow this  
Matchoo

Random and inconsistent CTD issues

Recommended Posts

I have been trying to play UCAWA, but after about 10 minutes the game will crash on me, sometimes giving me the lovely generic microsoft error, and other times just going straight to the desktop. One of the times when it crashed with the error I brought up task manager and noticed that UCAWA.exe was using around 450,000K of memory. I have been having a problem recently where my Visual Studio .NET will leak memory and eventually crash, but no other programs on my PC were having the problem(that I've noticed), so I figured it was just Visual Studio. Now with UCAWA crashing, though, I'm wondering if it's a system problem rather than a Visual Studio one.

Should UCAWA use this much memory? If it's not supposed to, then I will go ahead and reinstall Windows to try to 'plug' the leak. If it is, then I'll try some other things.

Thanks.

[ 09-06-2005, 08:01 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

450MB of memory is nothing.

Please don't create tech support threads about issues that are either nothing directly related to the game or conclusive of same. The game's requirements are crystal clear and there are no crashes, memory leaks or whatnot (we have tools for that) or there would have been a patch released by now.

Unless it can be reproduced, it can't be fixed.

...plus, your system barely meets with the game's minimum requirements.

Share this post


Link to post
Share on other sites
Guest Chavis

OK, here's one that's 100 % reproducible.

Roam - Spaceforce Marine - GalcomHQ.

Start the game,dock at GalcomHQ,check cargo.

Get a 'Microsoft Visual C++ Runtime Library' dialog indicating a Runtime Error.

Share this post


Link to post
Share on other sites

Did you select an asset for the SFM?

And please don't hijack a thread again. Create your own thread with a conclusive report. Next time, the post will be deleted.

EDIT: I have reproduced and fixed this. In fact, its been in there since UC. The SFM is not supposed to have an asset; hence the reason the cargo table is not implemented. Apparently nobody noticed.

[ 08-21-2005, 08:18 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

quote:

Originally posted by Supreme Cmdr:

450MB of memory is nothing.

Thanks. I was just looking for confirmation that that amount of memory use was fine.

quote:

Originally posted by Supreme Cmdr:

The game's requirements are crystal clear and there are no crashes, memory leaks or whatnot (we have tools for that) or there would have been a patch released by now.

Sorry, I wasn't trying to imply that the game had a memory leak, just that my system could since my Visual Studio is suffering from one.

Share this post


Link to post
Share on other sites

One little trick that I found was to do this:

Right Click Desktop->Properties->Advanced->Troubleshoot

You should see a radio box called "Enable Write Combining". Click this OFF. I found that with my NVIDIA cards that this enhanced the stability of this game quite a bit. I have seen advice before on "AGP Fast Write" Mode and some others, but not this one. Worked well but does require you to reboot your machine.

Hope this helps somebody. Maybe somebody with an ATI card can try this as well.

Share this post


Link to post
Share on other sites

Well after running the game for a few more days and trying every audio, video and game adjustment I can think of I am finally very happy with the game stability on my system.

The thing that seems to have worked for me is lowering the resolution from 1280x1024 to 1024x768.

I put sound back at full acceleration, video write combining back on etc etc.

At 1024x768 with 4xAA and 16Xaf and all the effects at max, the game looks and plays just great!!

Share this post


Link to post
Share on other sites
Guest Chavis

Ok,I have a saved game that will throw an exception on a fairly regular basis,per the request for a saved game in Hellbinder's post.

Just let the ship pass through the wormhole to Sirius.Within a few seconds after passing through the wormhole,a CTD will occur,or in my case throw an exception with a Dr Watson crash log.

This may happen 2 times in a row,or not may happen for several tries.

Sending to [email protected] using the requested protocol.

Share this post


Link to post
Share on other sites

quote:

Originally posted by Andergum:

Well after running the game for a few more days and trying every audio, video and game adjustment I can think of I am finally very happy with the game stability on my system.

The thing that seems to have worked for me is lowering the resolution from 1280x1024 to 1024x768.

I put sound back at full acceleration, video write combining back on etc etc.

At 1024x768 with 4xAA and 16Xaf and all the effects at max, the game looks and plays just great!!


I found that the game seems to run it's best with all the ATI video card settins all to Highest Quality. For some reason when I try to set certiain things to Higher Performance I get random CTD's.

Share this post


Link to post
Share on other sites

quote:


Originally posted by Chavis:

Ok I will.

I filled out the info on the ChoiceMail One page.


Yeah I got it now. Will look into it tomorrow because I'm taking the day off.

quote:


Originally posted by Darkling:

I found that the game seems to run it's best with all the ATI video card settins all to Highest Quality. For some reason when I try to set certiain things to Higher Performance I get random CTD's.


Could you be a little more specific please?

Share this post


Link to post
Share on other sites

quote:


Originally posted by Chavis:

Ok,I have a saved game that will throw an exception on a fairly regular basis,per the request for a saved game in Hellbinder's post.

Just let the ship pass through the wormhole to Sirius.Within a few seconds after passing through the wormhole,a CTD will occur,or in my case throw an exception with a Dr Watson crash log.

This may happen 2 times in a row,or not may happen for several tries.

Sending to [email protected] using the requested protocol.


I tried your saved game ten times on four different machines and never had a crash.

Unless someone else can download that file and corroborate your findings, I am going to close this issue.

Share this post


Link to post
Share on other sites
Guest Chavis

quote:

four different machines and never had a crash

By any chance did you try an AMD platform,since most of the players with a problem have either 32 or 64 bit athlons/semprons?

Anyway,thanks for checking.

Share this post


Link to post
Share on other sites

What do you think?

You should be tied to the back of shuttle and dragged across a planet for asking me such a stupid question.

Do I come across as a time waster to you? And someone who doesn't check something thoroughly? WHY else do you think we're so stringent around here about people having ACCURATE info in their sigs?

Share this post


Link to post
Share on other sites

OK, so it is random then. Oh well, can't help with that, since I have no idea how to solve that.

If it is unique to AMD processors, then you're all screwed (for now) I guess.

Let me ponder on this for a bit.

Share this post


Link to post
Share on other sites

Its not a driver issue. I've just reproduced it using his saved game.

I loaded it on an AMD machine, wrote a script to keep loading and unloading the saved game (unattended) until it crashed.

It crashed about 2 mins ago and it seems to be related to auto-generation and intruders being beamed abord the craft.

I'm on it. Expect a patch shortly, since this is a serious issue.

In the meantime, use the ROAM scenario without AG.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×