Jump to content
3000AD Forums
Sign in to follow this  
Ben Zwycky

Supply station menu inoperative when using DIE

Recommended Posts

Found this when trying out some of the IA FP scenarios, and have reproduced this in roam:

Problem: when your DIE is activated and you use a supply station, the menu appears but none of the buttons respond to mouse clicks.

to reproduce:

1. Start new game as terran military mobile infantry marine using the default launch base and profile.

2. locate the nearest supply station and move over to it.

3. activate your DIE (using the 4 key)

4. use the supply station (using the U key) and confirm with the Y key

The leave/medical/weapons/repair buttons appear as normal, but do not respond to mouse clicks. pressing any key clears them away and frees you to move again. This is the same no matter what DIE mode you are using. Using the supply station without your DIE activated works just fine.

This problem also occurs in UC, but only if youÔÇÖre using a DIE mode other than tactical view mode. (the / key to access the supply station selects the nearest target in line of sight instead when your DIE is in TVM).

This is the reason I didnÔÇÖt notice it until now (I only ever use tactical view mode with the DIE and the key change in AWA eliminated the key assignment conflict).

Can someone else please confirm this?

Share this post


Link to post
Share on other sites

This is not a bug and works as designed. When the DIE is active, the keys are mapped to its functionality.

Read the manual. Nowhere does it say that you should have your DIE active in order to use the station. So don't.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×