Jump to content
3000AD Forums
Sign in to follow this  
nasos073

Performance drop after 1.00.04 patch

Recommended Posts

First of all, I have purchased and installed UCAWA download version from www.regnow.com, which comes at v.1.00.04

When I first installed it, my system (see profile), would pull 50-90fps in space, 20-25fps on planetside, showing minimal impact on various ingame or graphics driver settings.

As soon as I updated to 1.00.06 and 1.00.07 later, I get 35-75fps in space and 7.8-11.4fps on planetside.

I've tried everything that came to my attention:

defragging, reverting to older audio and graphics drivers, checking BIOS settings, lowering ingame settings, 2 Windows repair attempts and finally reformatting HD/reinstalling Windows (this costed me my activation slots but SC was kind enough to give me one more round).

No result so far...

Ofcourse, reinstalling UCAWA and keep it on v1.00.04 would be an easy way, but, updates contain fixes and therefore are meant to be installed, don't they?

I've run out of ideas here, any suggestions?

[ 10-05-2005, 05:15 PM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

There is nothing in the updates which would impact performance. If you actually looked at the VCF, you'd see the difference in updates.

Plus, you have an Audigy2 sound card. Enough said.

Share this post


Link to post
Share on other sites

First thing before coming and posting, was to look at VCF. Indeed I didn't notice anything that could affect performance in any way...

About my sound card, after i read the related topic, it was the main reason I reformatted my system-dedicated partition, so that I would be sure that I eliminated any chance of remaining parts of any driver that would conflict with my configuration.

After some further reading, I disabled ingame soundFX just to see what would happen. Still the same. Unless...

...without trying to be picky or something, who packed Regnow's 1.00.04 version? 3000AD or the vendor himself?

...on the other hand, RTPatch would hang if something went wrong during update (bad package or something)...

Anyways, I'm gonna re-download the UCAWA package, although I didn't get any faults on my original download... glad that I paid for that extra 1yr download avaibility.

Share this post


Link to post
Share on other sites

SC says your Audigy2 sound card is the source of problem,which means you can disable sound acceleration in DXdiag~

Maybe that could solve your problem.

Share this post


Link to post
Share on other sites

quote:


Originally posted by APOLLO:

...without trying to be picky or something, who packed Regnow's 1.00.04 version? 3000AD or the vendor himself?


I - personally - package all versions of my games and the RegNow version is 100% identical to the version sold on CD-ROM by BMT Micro.

quote:


...on the other hand, RTPatch would hang if something went wrong during update (bad package or something)...

Then you have an unrelated problem on your system, because RTPatch should never - ever - hang.

quote:


Originally posted by Commander Shih:

SC says your Audigy2 sound card is the source of problem,which means you can disable sound acceleration in DXdiag~

Maybe that could solve your problem.


uhm, no. It could be the source of the problem, but only if that is the same sound card he has running 1.00.04 and 1.00.07 on. The only way to figure that out, is through testing with the same conditions, drivers etc.

It could also be that the Starforce protection makes the game run slower under certain conditions on his machine. This is probably unlikely since the same protection was used on both of those game versions.

[ 10-05-2005, 09:16 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

First of all, I'd like to thank you SC for clearing out my packaging question:)

Reducing DirectX accelleration trick doesn't work on me (been using it in other occasions too, aircraft simulations mostly).

Starforce Proactive... never had problems with it also (I run Lockon 1.1 with this kind of protection too without a single hickup).

I tried to run UCAWA in window mode, while having task manager open, in performance tab. From what I've seen, the game takes the CPU usage up to 97%, while still in the main menu.

And continues like that, except while loading a savegame. I could easily blame my sound card for that, but in the main menu it's just playing music and some interface sounds. After all, if it was clearly a sound card issue, I would at least be able to track it down by switching all soundFX off. As I said above, tried it and didn't see any good.

Another thing to mention is that while in the main menu, the various items(buttons) take some time to light up when hovering the mouse cursor over them. Also sometimes it takes more than 2 clicks to activate a submenu. All of these, while CPU usage is at constant 97%-99%.

I'm going to check again my system just in case I overlooked something, yet I'd like to see similar performance results so that I can crosscheck them with mine...

Share this post


Link to post
Share on other sites

quote:


Originally posted by Wolfheart:

You're talking about the latest version right? Cause your last post suggests that your problem is
this
.

Just in case..


Yeah, thats what I was thinking too actually!!

Anyway, on a 2.8GHz machine, on the main menu with no music, the game takes 12-15% of the CPU. With music, it takes about the same.

There's definitely something going on.

Did you do ANY SW/HW upgrades recently? At least since the 1.00.04 patch?

Also, use the method described in that thread that Wolfheart pointed out and try the 1.00.05 and 1.00.06 patches as well and see if they produce the same results.

Remember that the Updater will download all patches to the game folder. So, you don't need to re-download them. You can just apply them on top of each other. To go back to the latest 1.00.07, be sure to edit the SETTINGS.INI file or you won't be able to grab the next patch (e.g. 1.00.08).

Share this post


Link to post
Share on other sites

Sry for my late reply, just came back home, everyday's things to do never stop...

12-15% nominal CPU usage without any actual load... I was expecting/afraid of something like that, since not much ppl have similar issues.

I'm using the latest version (1.00.07). No hardware updates, no driver updates, no extra/new software installed. As a matter of fact, my latest upgrade was the sound card and it happened long before I purchased and installed UCAWA.

What seems to be my problem, is that something is choking my CPU, thus not allowing it to play the game in a more efficient way. And this happens everywere ingame: main menu, space and planetside (except while loading game data).

I'll try different patches and be back later with my results.

Thanx in advance:)

Share this post


Link to post
Share on other sites

Got it. So you have Alchohol 120% installed huh?

Anyway, also use the Starforce driver removal tools on the Starforce site. Then run the game again; it will then re-install the drivers.

Share this post


Link to post
Share on other sites

Will do. in the meantime, here's what I got after incremental patching.

UC1.00.04 - Average CPU Usage: 95%

UC1.00.05 - Average CPU Usage: 98%

UC1.00.06 - Average CPU Usage: 95%

UC1.00.07 - Average CPU Usage: 95%

All values were taken upon main menu. In all cases and at that particular state, the memory usage wouldn't exceed 67800k.

Share this post


Link to post
Share on other sites

Couldn't find any tools on Starforce site, so I used the Protect.exe in my UCAWA folder to uninstall and reinstall the protection drivers. In other words, job is done. Issue still remains: CPU usage up to high heaven...

Share this post


Link to post
Share on other sites

Well, I thought you said that the performance in 1.00.04 was better? From what you posted above, that does not seem to be the case.

Share this post


Link to post
Share on other sites

Well, I never thought to monitor UCAWA's CPU usage in various versions, untill now.

The general picture (at least the way I see it from here) is that back in v1.00.04, even with 95% usage, my system would manage to pull the framerates I posted above, even with a choking CPU. In later versions, somehow the workload increased a bit, but that little bit was huge on my machine simply because my CPU is still choking.

Since in a P42.8GHz you get 12-15% CPU load on UCAWA main menu, I could say that my system should run the game in a way more efficient way, something that just doesn't happen...

Btw, SC, may I assume that the CPU usage results you showed me above are from a machine that runs the unprotected version? I mean that the problem could be simply the way Starforce is implemented into the executable.

Or, we can come back at the Audigy2-UCAWA compatibility and say that, with UCAWA sound engine playing a couple of sounds in main menu is just too much for my sound card, that it takes all my CPU cycles just to play... a couple of sounds? It's a little bit hard for me to believe it.

PS: If my syntax sounds weird, bear with me, English is not my native language

Share this post


Link to post
Share on other sites

When I run public tests, of course they are from the protected version.

Also, I'm not sure how you are able to determine the CPU usage of the game, when in fact it runs in fullscreen and will not give you access to task manager.

Running in fullscreen, the game will take as much as the CPU as possible. In my test above, I was running it in a window.

You are beginning to bounce all of the place with this and I'm this close to giving up. First you started talking about in game frame rates. Now, instead of continuing with those tests, you're bugging me about - inconsequential - main menu fps which bear NO relevance to the in game processing that you previously reported.

....and now we're back with talking about sound cards. Which you already stated has not changed since 1.00.04.

I simply don't have the time for this. So, unless you're going to be consistent and clear, I'm going to just bypass this and leave you to sort it out on your end.

Share this post


Link to post
Share on other sites

quote:

Originally posted by APOLLO:

I tried to run UCAWA in window mode, while having task manager open, in performance tab. From what I've seen, the game takes the CPU usage up to 97%, while still in the main menu.


Allready mentioned.

Here are the facts so far:

1) Framerate has been reduced since 1.00.04.

2) Running UCAWA in window mode shows me UCAWA CPU usage at 95-98%, while still in main menu. The same thing continues in space and planetside. No wonder why it can't pull sufficient framerate.

Reinstalled, patched incrementally, ran the game after each patch in window mode, posted the results shown above.

I'm trying to figure out what's going on as well, so I'm posting my personal thoughts about it too. Just thoughts.

Share this post


Link to post
Share on other sites

Well I'm totally stumped.

Lets try something. I just noticed that Starforce updated their protection servers on 09-30. Not sure if their new updates could be the cause.

Download this 13MB file and extract into your game folder overwriting existing files.

Run the tests again and get back to me.

Share this post


Link to post
Share on other sites

Please try not to clog the thread. I didn't need to know that. All you had to do was post the results once you'd downloaded it.

Share this post


Link to post
Share on other sites

Framerate has been restored: 50-80fps in space and 20-30fps planetside, in crowded areas.

Disabling sound acceleration (this time it worked) gave me 90-190fps in space, 35-45fps planetside (same crowded area).

SC I want to thank you for all your efforts to help me. I'm sure this will help others with the same problem I've encountered.

You've made this Commander-Wannabe very happy lol

Share this post


Link to post
Share on other sites

OK, I was right. I didn't make *any* changes to the code. All I did was connect to the Starforce server and re-protect the UCAWA.EXE and UCAWAMP.EXE files using their latest SDK version.

Anyway, I have now pushed this revised 1.00.07 to the auto-patch server.

You (and anyone who wants this version) need to do the following:

  1. Open the SETTINGS.INI file (located in the game folder) in Notepad.
  2. Where you see the 1.00.07, change it to 1.00.06
  3. Save the file and exit Notepad
  4. Run the Updater using the shortcut or by double-clicking on the Updater.exe file located in the game folder.

Updater will then grab the v1.00.07 patch refresh and re-apply it on top of the previous version.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×