Jump to content
3000AD Forums
Sign in to follow this  
Cruiser

CTD and intruders

Recommended Posts

Ok, I know I'm pushing it here, but now when I got the Borealis crash verified, I know that Its not only my machine.

So I'm gonna hang my balls out there again (so to speak, not really....hmmm).

I'm experiencing a crash, when I have intruders on board and I switch to PERSCAN (ALT + P). I've tried this many times now, and with this save game I am able to reproduce it about 80% of the times I tried (tried about 20 times).

If you want to help me one last time, do as follows:

1. download from URL above ("this save game")

2. replace save folder with this one (back up your existing).

3. RESTORE the only save profile under Cruiser.

4. You now have 4 intruders on board. Please switch to PERSCAN (ALT + P) every 8-10 seconds or so. If you do not immedeately CTD, then switch to bridge and wait.

I've reached the conclusion that it is some kind of state change of an intruder that causes the crash. Due to the complex behavior of the intruders this will not happen every time, but almost.

NOTE: I'm running at 1024x768 resolution. The intruders section of perscan almost always is "compressed" so I have to drag it out to display intruder info. This also sometimes results in a crash.

I hope I'm not pushing it too far here. I know I'm at risk of being called a whining newbie, but hey, I just want my favorite game to perform as good as it can.

Due to the very complex AI behavior, and the following many state spaces of the game, I reckon it is very difficult to test, and discover these kind of error.

I really appreciate any input.

Thx.

Share this post


Link to post
Share on other sites

Once again, someone needs to try it on their own without using your saved game. If you've somehow corrupted your saved game or your game install environment, you will get problems like this which nobody else has.

quote:


I've reached the conclusion that it is some kind of state change of an intruder that causes the crash.

Rubbish. There are no such state changes. If you want help, stop with the speculation since you have no idea what you're talking about, not knowing how the game's internal mechanics work.

Share this post


Link to post
Share on other sites

quote:

Once again, someone needs to try it on their own without using your saved game. If you've somehow corrupted your saved game or your game install environment, you will get problems like this which nobody else has.


Ok, I see your point. I will reinstall and start a new game.

quote:

Rubbish. There are no such state changes. If you want help, stop with the speculation since you have no idea what you're talking about, not knowing how the game's internal mechanics work.


Sorry about that, I'll stop speculating then.

But I don't think I will be able to produce a 100% reproducible case when I can't control the intruders. Well, I guess I just have to wait and see if anybody else has experienced this problem.

Share this post


Link to post
Share on other sites

Just tried it on several machines with no crash whatsoever. There are five intruders on board when the game is restored and they are eventually killed. At one time, one of them got into shuttle 4.

Until someone else reproduces this and with a reliable method of testing it, there's nothing that I can do.

Trying running it in a window then post the error message (if any) if/when it does crash. Add something like /d5 /w1 to your shortcut.

quote:


NOTE: I'm running at 1024x768 resolution. The intruders section of perscan almost always is "compressed" so I have to drag it out to display intruder info. This also sometimes results in a crash.

I don't see why the display would shrink. It works fine for me and I don't have to do anything.

Share this post


Link to post
Share on other sites

I have to agree to Cruiser's posting. I watched intruders on the perscan now for quite some time and had quite a lot of CTDs. Being not sure, if it is my , my computer's, my installation's fault, i also watched the forum, if somebody else would notice that problem.

Well, i'll go and collect some usefull infos about those crashes and post them later. Perhaps this may help to find a bug, if there is one.

Share this post


Link to post
Share on other sites

I have experienced this problem as well, though I haven't had time to play much since getting the last patch because of the whole moving to college thing.

I'll go find time and get some intruders to replicate the problem. However I will say that it doesn't -always- happen for me while I view perscan. There may be some trigger for it, though until I look at it a lot more closely I won't guess at what it may be.

Share this post


Link to post
Share on other sites

quote:

Trying running it in a window then post the error message (if any) if/when it does crash. Add something like /d5 /w1 to your shortcut.


Ok, I admit that I've no idea what information you want. I've create a little text file with error information. There's also all the debug stuff that windows lists in a listbox, but I can't seem to copy it.

Is this anything like what you're looking for? Probably not I guess.

quote:

I don't see why the display would shrink. It works fine for me and I don't have to do anything.


No, you're right, when I run in window'ed mode, then it does not occur.

Share this post


Link to post
Share on other sites

And BTW, I was wrong in my procedure for reproducing this. Apparently it occurs even if you just view the intruders in PERSCAN and not when you access PERSCAN.

And even with my saved game, it occurs far from every time.

Share this post


Link to post
Share on other sites

Good point. Lets me re-phrase

At first i thought that I could only reproduce the CTD if I accessed the perscan at the exact moment the game was in a certain state. I was not able to reproduce by just watching PERSCAN.

But then a seems that I was only "lucky" in my tests where I just let the display stay in PERSCAN.

The CTD also occurs if you immediately switch to tacops and just watch your marines fight back the intruders.

But not every time. I can't see any similarities in the cases where I get CTD. I have tried to get it with both 5 intruders left, and also when only 1 was left in shuttle 4.

Share this post


Link to post
Share on other sites

quote:


The CTD also occurs if you immediately switch to tacops and just watch your marines fight back the intruders.

...erm, how are you able to view that from Tacops?

Share this post


Link to post
Share on other sites

Here are just some facts of 17 tests with 2 different saved games, which i reloaded several times each:

- Running UCawa 1.00.11 on 2 different machines with /W1 and /D5 parameters

- I started a new game, was at Jupiter and moved anywhere some km away from any possible waypoint of any hostile craft, so i didn't get attacked. When i got an intruder, i saved the game and used that one to reload later

- During the tests i watched the Perscan continuously, except that one time with 5 intruders, there i checked the detention hold each time the number of intruders was reduced

- No marines or any other personnel got killed during any test, only wounded

- Most of the time i had 1 intruder, once 4 additional intruders were transported onboard, so i had 5 at once (i mentioned that earlier)

- After each test w/o a CTD (13 out of all tests) i checked the tactical computer for prisoners and found no one in detention (sounds strange, but check my last point)

- The intruders, if there was no crash, have been wounded and killed in several different places like the medibay or any corridor, after different times. Some intruders healed themselve at the medibay and escaped to another place, where they finally got killed

- Test 6, 8, 12, and 16 ended up a CTD. All of these 4 tests have in common, that the CTD occured right before the screen should have been updated after that x second lasting delay. At 3 of those 4 tests, i heard a last "MaMaMaMarines are engaged in combat on Deck 2", whereby that repeated "MaMa..." was probably caused by a delay, while the system generated the debug-file *shrug*. Anyway, the screen got frozen right after that sound output and the last update of the Perscan didn't happen

- After i captured no intruders at all, i also checked those saved games w/o watching the Perscan and only twice in about 15 times i captured one, so it happens not too often at all

I hope, that this will help.

Oh, reading my own post, i missed one point:

All CTDs also have in common, that they occure, when the intruders are nearly dead, like at a health of 6, 10, or 12 percent, and after the next update of the screen they very probably would be dead.

[ 01-23-2006, 06:31 PM: Message edited by: Keron ]

Share this post


Link to post
Share on other sites

I can't reproduce it. So none of this helps. Until I get a saved game in which I can reproduce it, there's nothing that I can do because its just not happening here.

Cruiser, check your PM please.

ps: The next person to post in this thread when they don't have UCAWA, will be banned from the site.

Also, I don't want ANY further posts on this matter, except from Cruiser because you folks are just posting inconclusive data and confusing the issue.

Share this post


Link to post
Share on other sites

Ok, at fist I should find out that the debug exe you sent me only worked in my Starforce version, you gave me during testing the PTA problem.

But then, weird, I can't get the debug exe you sent me to crash. Here are my test results so far:

* Starforce / full screen | 2 crashes / 2 runs

* Starforce / w1 mode | 1 crashes / 1 run

* Starforce / debug exe / w1 mode | 0 crashes / 5 runs

* Starforce / debug exe / full screen | 0 crashes / 3 runs

I don't know what's special about this exe file, but it is affecting the stability of my system.

Bottom line, I can't get this debug build to crash, so I can't report any errors. Sorry.

Share this post


Link to post
Share on other sites

BTW, I also reinstalled my D2D version, ran the updater, started a new game, got intruders onboard, saved, resumed, watched PERSCAN, crashed.

Share this post


Link to post
Share on other sites

quote:


Originally posted by Cruiser:

Ok, at fist I should find out that the debug exe you sent me only worked in my Starforce version, you gave me during testing the PTA problem.


Yeah, I know. I only sent you the Starforce version because I can only protect Starforce and Trymedia versions. For the D2D version, I have to send the files to IGN and wait for them to protect and send them back to me.

quote:


But then, weird, I can't get the debug exe you sent me to crash. Here are my test results so far:

* Starforce / full screen | 2 crashes / 2 runs

* Starforce / w1 mode | 1 crashes / 1 run

* Starforce / debug exe / w1 mode | 0 crashes / 5 runs

* Starforce / debug exe / full screen | 0 crashes / 3 runs


I don't understand. You said that you can't get it to crash, but above you listed that you got a total of three crashes.

quote:


I don't know what's special about this exe file, but it is affecting the stability of my system.

It is a debug (and much slower) version designed to spit out a debug error if/when it does crash. This way I can tell where in the code the crash is occuring.

I have also tried running the D2D version with no crashes.

quote:


Originally posted by Cruiser:

BTW, I also reinstalled my D2D version, ran the updater, started a new game, got intruders onboard, saved, resumed, watched PERSCAN, crashed.


What exactly happens when it crashes? Don't you get a message from Windows?

And did you say that when run in a window it doesn't crash at all? Did you try this with /w1 as well as /w2?

Share this post


Link to post
Share on other sites

quote:

I don't understand. You said that you can't get it to crash, but above you listed that you got a total of three crashes.

By "Starforce / full screen | 2 crashes / 2 runs" I meant the original exe file, not your debug build. The debug build test runs is the ones with "debug exe".

So what I meant was, that in test-runs with the debug exe, I got no crashes, but apart from that my Starforce version crashes just as regularily as the D2D version. But what ever I do, I cannot get the debug build to crash. I tried all combinations with and without /w1 and /d5.

quote:

What exactly happens when it crashes? Don't you get a message from Windows?

When the game CTD's I get a message of the kind:

AppName: ucawa.exe AppVer: 0.0.0.0 ModName: ucawa.exe

ModVer: 0.0.0.0 Offset: 0006006a

And a lot of other windows-stuff about kernel32.dll. I've attached the windows generated txt file (http://cruiser.person.dk/intruders_ctd_details.txt) in one of my first posts in this thread.

quote:

And did you say that when run in a window it doesn't crash at all? Did you try this with /w1 as well as /w2?

It also crashes at /w1 mode. This is from my post above:

* Starforce / w1 mode | 1 crashes / 1 run

Sorry for my self-invented notation, but this mean: Starforce version (not the debug exe), /w1 mode, made total of 1 run and got a total of 1 crash.

I have not tried with /w2. Good idea. I will do that.

Share this post


Link to post
Share on other sites

quote:


Originally posted by Cruiser:

quote:

I don't understand. You said that you can't get it to crash, but above you listed that you got a total of three crashes.

By "Starforce / full screen | 2 crashes / 2 runs" I meant the original exe file, not your debug build. The debug build test runs is the ones with "debug exe".


Try not to confuse the issue please. I'm not interested in any other version tests, except the versions I specifically ask you to test with. In this case, the Starforce debug build.

Share this post


Link to post
Share on other sites

Ok, only debug build.

I ran some more tests with /d5 /w2 and bottom line is, that I've not had one single crash with the debug build, using my previously mentioned saved game, running in either /d5 /w1, /d5 /w2, just /d5, and with no parameters at all. It's rock stable.

Share this post


Link to post
Share on other sites

Ok, just tried D2D with /w2 and /d5 /w2. CTD on both tests.

But still, the debug exe for Starforce hasn't produced a single crash on my machine.

And at the same time you've never been able to produce 1 single CTD? And you do just like me: Get some intruders and then watch them until they're dead in PERSCAN?

If I hadn't heard a number of other players reporting the same, I would believe it was my machine.....

[EDIT]

Ok just received your PM. Will try now. Just remember that I tried in my previous test with a plain Starforce build. It crashed just as much as the D2D (hmmm, not really a plain Starforce, as I remember you sent me files to modify the D2D into a Starforce version).

Share this post


Link to post
Share on other sites

quote:


Originally posted by Cruiser:

And at the same time you've never been able to produce 1 single CTD? And you do just like me: Get some intruders and then watch them until they're dead in PERSCAN?


Yes. I'm not stupid. If it was a bug that could be reproduced do you think this thread would still be going on?

At this point, I don't think it has anything to do with the game.

quote:


If I hadn't heard a number of other players reporting the same, I would believe it was my machine.....

You are reading about something completely different. And the other person who posted here, didn't have UCAWA. So I deleted their post. There was an issue wrt intruders which was fixed in both UC and UCAWA. Read the VCF and stop confusing the issue.

quote:


Ok just received your PM. Will try now. Just remember that I tried in my previous test with a plain Starforce build. It crashed just as much as the D2D (hmmm, not really a plain Starforce, as I remember you sent me files to modify the D2D into a Starforce version).

For the LAST time, I'm going to ask you to stop refering to builds that I have NO interest in.

That Starforce build you are talking about is the same as the D2D build, except for the protection used. So yes, if one crashes, then the other will as well. And neither is a debug build.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×