Jump to content
3000AD Forums
Sign in to follow this  
Cruiser

CTD and intruders

Recommended Posts

I asked you to provide me with the screen display showing the crash info so that I can see where it is crashing. Where is it?

Also I need the saved game that you are using.

And as I suspected, this has nothing to do with intruders, but is rather a graphics driver issue.

Share this post


Link to post
Share on other sites

Yeah ok. It's just showing the same error as in the other cases, but ok, if you can use this offset for anything, I'll provide this also.

Saved game? I did not save the game while testing. I'm a little at loss here .... help me

Share this post


Link to post
Share on other sites

I get the error:

AppName: ucawa.exe AppVer: 0.0.0.0 ModName: ucawa.exe

ModVer: 0.0.0.0 Offset: 0006185a

Anything else you need?

Share this post


Link to post
Share on other sites

If you are running the SF executable (it is about 12MB) I sent you, it has debug information and should display more info than what you have displayed above. Are you sure you are running the correct UCAWA.EXE file?

Also, if you reproduce this error in a new game, save the game and send it to me.

You also need to try running at 800x600 and let me know if it crashes when you attempt to resize the window. You seem to be running at 1024x768 and you should be able to display ALL 20 marines on the left pane. The only time you will see 19 marines on the left-pane, is if you drag the top part of the right-pane up/down.

The ONLY time a window can be resized, is if it has been shrunk. You can left-click on any window heading and drag up/down to shrink/expand it.

And I need to know WHICH pane you are dragging that is causing the CTD.

EDIT: You might want to update your drivers. The latest is 82.12

[ 01-30-2006, 04:27 PM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

Ok, will try tomorrow morning first thing, and answer your questions. Have to hit the sheets now.

One thing though, if I reproduce the error, and it crashes, how can I save the game if it has already crashed?

Thanks.

Share this post


Link to post
Share on other sites

You save the game first. Then restore and see if you can still reproduce it. If you can, then send me the save game.

Share this post


Link to post
Share on other sites

quote:

If you are running the SF executable (it is about 12MB) I sent you, it has debug information and should display more info than what you have displayed above. Are you sure you are running the correct UCAWA.EXE file?


Yes, I am executing the 12 meg file that you sent me. When I run the game, It's displaying v1.00.12. It's not displaying any further crash information than this. Will try some more times though.

quote:

You seem to be running at 1024x768 and you should be able to display ALL 20 marines on the left pane. The only time you will see 19 marines on the left-pane, is if you drag the top part of the right-pane up/down.

Yes, when I'm running full screen 1024x768 all marines fit on the left, but when I run /w1, even if my ucconfig.ini says 1024x768, apparantly the screen only gets 1024x755? You can see this on the screenshot resolution in one of the shots in post above.

quote:

The ONLY time a window can be resized, is if it has been shrunk. You can left-click on any window heading and drag up/down to shrink/expand it.

And I need to know WHICH pane you are dragging that is causing the CTD.


When I'm watching the PERSCAN, the intruders section is collapsed per default apparantly. I have to resize it to see the intruders. Sometimes this does not cause a CTD though. I've uploaded an image from a test with full screen where I indicate what bar I drag to resize the intruders section.

quote:

You also need to try running at 800x600 and let me know if it crashes when you attempt to resize the window.

EDIT: You might want to update your drivers. The latest is 82.12


Ok, I will try this. Thanks.

Share this post


Link to post
Share on other sites

I'm still testing, but don't think I can supply a savegame where the intruders section is collapsed. In my experience you have to be watching PERSCAN WHILE you are being boarded. If you exit PERSCAN, and enter it again, the section is aligned normally again.

I've not been able to reproduce the first type of intruders CTD with the 12 Meg SF version. By first type I mean CTD while intruders section expanded. With the SF version I've only seen the CTD while dragging the section "end of log" bar.

I've not reproduced a CTD since I updated my drivers, so I will also test the "clean" D2D install again using these new BETA 82.12 drivers.

Share this post


Link to post
Share on other sites

I've now "succeeded" to get the CTD while dragging the bottom bar with the SF v1.00.12.02 both in full screen and in windowed 1024x768 + 800x600.

The error msg is the same as before.

I have one question though. As you can see on some of the images I have linked to in my previous posts, the arrow is pointing UP in the intruders title bar, while in any other section, when collapsed, the arrow in the corresponding title bar is pointing down. I've no idea what this means?

Well, thats all from me.... for now at least.

Share this post


Link to post
Share on other sites

I can't reproduce it. Sorry.

If someone else can reproduce it reliably, then I would be willing to revisit the issue. Until then, I have no choice but to close this issue forthwith.

Share this post


Link to post
Share on other sites

Yes, I can certainly understand your standpoint in this, but let me give you a great THANKS and for trying to help.

Hope I will be able to supply better information at some point in the future. Maybe it will correct itself in a future Nvidia driver update.

Cruiser.

Share this post


Link to post
Share on other sites

It is of no use to me. As I said before, I can't fix what I can't reproduce. I did everything I could and spent enough time on this. So, whoever is having this problem, needs to look at their video drivers because this has nothing to do with intruders. It seems to have to do with the window scrolling.

Share this post


Link to post
Share on other sites

Hi, one question for anyone who can read these crash dump file from dr. watson (I sure don't know how).

What does the following mean:

code:

function: UCAWA!PERSON_CLASS__active

0046184c cc int 3

0046184d cc int 3

0046184e cc int 3

0046184f cc int 3

UCAWA!PERSON_CLASS__active:

00461850 55 push ebp

00461851 8bec mov ebp,esp

00461853 51 push ecx

00461854 894dfc mov [ebp-0x4],ecx

00461857 8b45fc mov eax,[ebp-0x4]

FAULT ->0046185a 0fbf80b2030000 movsx eax,word ptr [eax+0x3b2] ds:0023:203523d2=????

00461861 83e002 and eax,0x2

00461864 8be5 mov esp,ebp

00461866 5d pop ebp

00461867 c3 ret

00461868 cc int 3

00461869 cc int 3

0046186a cc int 3

0046186b cc int 3

0046186c cc int 3

0046186d cc int 3

Does it necessarily mean that a fault occurred while in function PERSON_CLASS__ACTIVE?

Share this post


Link to post
Share on other sites

Memory read fault ->

this is a symptome but not the cause of the crash

visibly the method PERSON.CLASS_ACTIVATE received a bad pointer (ecx).

Share this post


Link to post
Share on other sites

Do you have that saved game Cruiser? If so, send it along with a description of how to reproduce it.

Once again, I'm not in the mood for you to waste my time. So you only get one chance this time to clearly explain what you were doing and how to reproduce it. If I have any doubts or questions, it means that you weren't clear. Which means I won't revisit this issue

again.

Share this post


Link to post
Share on other sites

It's still the same issue, so I don't ask you to get into this again. I don't want you to waste your time on something you can't reproduce.

I just wanted to understand the Dr. Watson dump so I could get a clue of whats going on with my system.

Apparently your system is totally immune to this error, so I think I'm gonna let this go until I have a way to reproduce it, and have this verified by at least two other people.

I've gotten several PM's from people who's been experiencing the same issue with totally different systems.

So please, just forget this issue until I have something concrete to give you. Until then, I will shut up about this, at least in the tech suppport forum.

Thanks.

Share this post


Link to post
Share on other sites

quote:


Originally posted by Cruiser:

Apparently your system is totally immune to this error, so I think I'm gonna let this go until I have a way to reproduce it, and have this verified by at least two other people.


I have seven PCs in my lab and with a variety of configs. NONE of them exhibit this problem.

quote:


I've gotten several PM's from people who's been experiencing the same issue with totally different systems.


All of which is meaningless unless (1) They post about it (2) There is a common denominator between your report and theirs

btw, that Dr. Watson report you posted didn't come from the recent .12 release, did it?

Share this post


Link to post
Share on other sites

quote:

I have seven PCs in my lab and with a variety of configs. NONE of them exhibit this problem.

Yes, I know from earlier issues that you're very thorough in your testing. Thats why I'm gonna let this issue go, because if you could reproduce it, I think you would've done it by now.

quote:

btw, that Dr. Watson report you posted didn't come from the recent .12 release, did it?

No, I think it was from the .12.02 SF test release you gave me at that time.

You're right, let's just let it go for now.

Share this post


Link to post
Share on other sites

uhm, thats not how it works around here. Usually if I can't reproduce a bug, a group of folks get together, sort it out amongst themselves, then post a thorough report.

So, if you've had PMs from others, then you folks need to get together (in this thread), post your comparisons etc. I won't investigate until I see something that catches my eye.

As to the Dr. Watson report, thats what I figured when I looked at the output. That version I gave you had debugging turned on. I will build a debug version of the current .12 release now and upload later for you folks having this problem, to check out and compare results. We have changed compilers from VS6 to VC2005, so the code that is produced by the compiler has changed significantly.

Anyway, if this problem is in there, a variety of factors (e.g. memory) could cause it to be a random event and which is very hard to reproduce.

I have to address this restore game issue recently reported and I'm going to look into that today before releasing a .13 update because it is CAT 1 bug. If you guys can figure this stuff out, I can roll that fix (if thats what is needed) into a .13 release as well.

Share this post


Link to post
Share on other sites

I believe that I may have found the cause of this and a fix for it.

The issue is related to video cards and that pane constructor for when intruders are captured and turned into prisoners; which then causes a new (off-screen) pane to be created. On some video cards and drivers, it may blow up.

In fact, I'm quite certain that this is the cause.

Fix (I hope), coming up; though I can't reproduce the crash. I gleaned all this from the Dr. Watson report above.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×