Jump to content
3000AD Forums
Sign in to follow this  
nasos073

SMD and player assets

Recommended Posts

It's funny, but while I can see stores manifest for friendly units (even when it shows "0.0"), I get absolutely no stores info on support units, my own assets in other words.

Let me give a couple of examples:

[*]I send a shuttle to deploy a mining drone on a planet. After a while, the drone starts loading with minerals but when I switch to SMD I get no info on what minerals it has on board. Just the 'NO STORES INFO' tag.

[*]I send a shuttle to pick a cargo pod. when I hover the cursor over the shuttle's slot on HUD, the shuttle will show 'n' items on board, but 'NO STORES INFO' on SMD.

Same happens for Fighter Crafts (FCs) too

I'm sure it's not a patching problem, I used the updater after all.

Any ideas?

Share this post


Link to post
Share on other sites

No clue what you are talking about and NONE of those steps above, make any sense. You might want to EXACTLY describe what you're doing and the steps taken.

e.g.

when I hover the cursor over the shuttle's slot on HUD makes no sense.

Also, it never was possible to view a drone's stores.

[ 05-23-2006, 09:00 AM: Message edited by: Supreme Cmdr ]

Share this post


Link to post
Share on other sites

SC you're right... this thing was never there. I checked it again about half an hour ago.

While I was trying to figure out why was I so sure that stores info was available for player assets, I fired up UC just in case things got mixed up in my head somehow... well they did. This feature was available in UC and maybe even BCM.

Anyways, sry for taking up forum space for nothing... I should've known better.

PS.: It would be a nice addition for UCAWA though, don't you think?

EDIT: I just thought to link up a couple of UC shots, showing where exactly I got confused...

http://i23.photobucket.com/albums/b400/Atk...eStoresInfo.jpg

http://i23.photobucket.com/albums/b400/Atk...sStoresInfo.jpg

[ 05-23-2006, 10:37 AM: Message edited by: APOLLO ]

Share this post


Link to post
Share on other sites

Come to think of it, I don't ever remember removing it from UCAWA. I'd have to check my dev notes on that and see why it was done. The last thing I remember changing in UCAWA related to SMD, was the ability to view the cargo contents of scripted objects *as well as* friendlies in VDD/SMD mode.

Also, are you sure that you are viewing your own asset's stores? Are you using the TACSCAN/SUL filter or not?

Anyway, post some pics so that I can see what is going on in UCAWA.

Anyway, in the future, please be *specific*. Your first report made it some like you were talking about the mouse-over in the shuttle section of the HUD (right side). That display never had the ability to do this. Thats why there is a specific SMD mode in the VDD.

Share this post


Link to post
Share on other sites

One image is better than a thousand words hehe. Here it goes:

[*]1) loaded up some stuff on a shuttle

2) launched it

3) mouse over shuttle's icon on shuttle area (HUD)

UCAWA: http://i23.photobucket.com/albums/b400/Atk..._mouse-over.jpg

UC:

same normal response, no need for extra screenshot

4) SMD (HUD)

UCAWA:

http://i23.photobucket.com/albums/b400/Atk...uttlestores.jpg

UC:

http://i23.photobucket.com/albums/b400/Atk...eStoresInfo.jpg

5) TACOPS Video Mode Cycling (VDD)

UCAWA:

http://i23.photobucket.com/albums/b400/Atk...OPS_shuttle.jpg

UC:

http://i23.photobucket.com/albums/b400/Atk...OPS_shuttle.jpg

6) TACOPS Video Mode Cycling (SMD)

UCAWA:

http://i23.photobucket.com/albums/b400/Atk...uttlestores.jpg

UC:

http://i23.photobucket.com/albums/b400/Atk...uttlestores.jpg

As for the mining drones in UC,

http://i23.photobucket.com/albums/b400/Atk...sStoresInfo.jpg

http://i23.photobucket.com/albums/b400/Atk...COPS_mdrone.jpg

http://i23.photobucket.com/albums/b400/Atk...dronestores.jpg

stores info are present and available in both HUD and TACOPS, while NOT in UCAWA.

Ah, yes, I'm pretty sure I'm looking at my own assets

Share this post


Link to post
Share on other sites

You need to reproduce the IDENTICAL instances in UCAWA. The shots you show of UC, are of a shuttle on the planet. The shots from UCAWA, are of a shuttle in space.

So, those results are inconclusive and I'm not going to investigate until I know for certain what is going, what you are doing and how you are doing it.

Share this post


Link to post
Share on other sites

Believe me SC, UCAWA doesn't show stores info on player assets, (neither on SMD, nor TACOPS VIDEO feed) no matter the region/engine (planetary/space).

However, I'll start getting shots of the planetary and space engine for UCAWA and UC respectively, reproducing the same situation in both games.

Share this post


Link to post
Share on other sites

SC, I gathered the data you need (or so I think).

The scenario is simple:

1) I started identical games on both UC and UCAWA

2) Loaded SC1 (any other shuttle would do as well) with stuff

3) Manned it

4) Set a "deploy mdrone" WP down to Earth

5) Launched SC1

InSpace Screens:

[*]Just after SC1 is launched

UCAWA:

http://i23.photobucket.com/albums/b400/Atk...CAWA/UCAWA0.jpg

UC:

http://i23.photobucket.com/albums/b400/Atk...C-UCAWA/UC0.jpg

[*]SC1 SMD view

UCAWA:

http://i23.photobucket.com/albums/b400/Atk...CAWA/UCAWA1.jpg

UC:

http://i23.photobucket.com/albums/b400/Atk...C-UCAWA/UC1.jpg

[*]SC1 TACOPS view (SMD)

UCAWA:

http://i23.photobucket.com/albums/b400/Atk...CAWA/UCAWA3.jpg

UC:

http://i23.photobucket.com/albums/b400/Atk...C-UCAWA/UC3.jpg

Planetary Screens:

[*]SC1 TACOPS view (SMD)

http://i23.photobucket.com/albums/b400/Atk...CAWA/UCAWA4.jpg

UC:

http://i23.photobucket.com/albums/b400/Atk...C-UCAWA/UC5.jpg

At this point I established planetfall to monitor SC1 from upclose

[*]SC1 SMD view

UCAWA:

http://i23.photobucket.com/albums/b400/Atk...CAWA/UCAWA7.jpg

UC:

http://i23.photobucket.com/albums/b400/Atk...C-UCAWA/UC7.jpg

[*]MDRONE SMD view

UCAWA:

http://i23.photobucket.com/albums/b400/Atk...CAWA/UCAWA9.jpg

UC:

http://i23.photobucket.com/albums/b400/Atk...C-UCAWA/UC9.jpg

[*]MDRONE TACOPS SMD view

UCAWA:

http://i23.photobucket.com/albums/b400/Atk...AWA/UCAWA11.jpg

UC:

http://i23.photobucket.com/albums/b400/Atk...-UCAWA/UC11.jpg

I launched fighter crafts too.

UCs SMD showed me 'CARGO MANIFEST 0.0' on them. Perfectly clear since interceptors don't have cargo bays.

UCAWAs SMD showed me 'NO STORES INFO'

Share this post


Link to post
Share on other sites

Weird. Looks like this was disabled back in 08/05 in the version before the final Gold. I have no clue why; but I have now re-enabled it.

I'm surprised that nobody has noticed this since then because this hasn't worked in ANY version of UCAWA since its release.

I'll see about rolling out a patch over the weekend.

Share this post


Link to post
Share on other sites

quote:

Originally posted by Supreme Cmdr:

I'm surprised that nobody has noticed this since then because this hasn't worked in ANY version of UCAWA since its release.

Umm... it's not that impossible for something like that to pass undetected.

You see, most ppl wouldn't switch to SMD to check if a shuttle has actually picked that cargo pod, review what has been sent down to a planet with that shuttle, or check what has that drone been gathering all this time down to a planet/moon.

Just think that I took notice of it when I decided to get back into the mining business lol.

Polaris-1 is great this time of season

Thank you very much for your time SC

Share this post


Link to post
Share on other sites

But that SMD display is not used solely for that. Its the same display used for viewing what cargo (if any) another ship is carrying. For e.g. in some missions, I specifically script cargo items (e.g. weapons) in some ships. Without using this display, there is no way of finding out if in fact such an item is onboard.

Share this post


Link to post
Share on other sites

I know. In fact, I checked the ACM again, this time while having launched a loaded shuttle of mine. The scripted cargo vessels had cargo manifest available but my own ships still didn't.

Share this post


Link to post
Share on other sites

Downloaded the patch about half and hour ago and it works like a charm! No conflicts on Campaign mode as well.

Many thanks SC for your efforts!

Share this post


Link to post
Share on other sites

This is what I'm talking about here... What other game developer responds directly to player input like this. This is why I'll always support and buy your games SC!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×