Jump to content
3000AD Forums
Sign in to follow this  
Supreme Cmdr

UCCE 1.00.03.02 Patch Released

Recommended Posts

This patch requires the November 2007 (or later) DirectX runtime

Use the game Updater to download and apply the patch.

The online VCF has also been updated.

NOTES:

  1. This patch uses a different installer. Be sure to confirm the location of your install in the dialog which appears!!
  2. If you use the game's Updater, it will download the patch and apply it.
  3. If you don't want to use the Updater, then you have to check one of the public mirrors for a link to the full patch.

WARNING: DO NOT DOWNLOAD THE PUBLIC PATCHES AVAILABLE ON DOWNLOAD MIRRORS IF YOU HAVE THE DOWNLOAD (e.g. DIRECT2DRIVE) VERSION OF THE GAME!! USE THE UPDATER INSTEAD!!!

NOTE

Games supported:

  1. UCCE v1.00.03 Full (Take2 DVD-ROM retail version)
  2. UCCE v1.00.03.01 Full (Direct2Drive version) *
  3. UCCE v1.00.03.01 Full (Digital River version) *
  4. UCCE v1.00.03.01 Full (BMT Micro UCSE to UCCE upgrade version) *

* IF YOU BOUGHT THESE VERSIONS BEFORE 11-01-07, YOU HAVE TO EDIT YOUR SETTINGS.INI FILE BEFORE USING THE GAME UDPATER. THIS IS BECAUSE IT NOW SUPPORTS ALL THE VARIOUS DRM VERSIONS. FAILURE TO DO THIS WILL RESULT IN YOUR DRM SIGNATURE BEING INVALIDED (DUE TO AN INCORRECT PATCH BEING DOWNLOADED AND APPLIED).

Go to your game install folder and make a backup of the SETTINGS.INI file. Then load the SETTINGS.INI file in Notepad.

Go to the UPDATEINFO section and make the following changes depending on which version you have. If you have the current version, no changes are required.

DIGITAL RIVER

Change the download URL to: URL=http://downloads.3000ad.com/updateinfoUCCE-DR.xml

DIRECT2DRIVE

Change the download URL to: URL=http://downloads.3000ad.com/updateinfoUCCE-D2D.xml

BMT MICRO

Change the download URL to: URL=http://downloads.3000ad.com/updateinfoUCCE-UPG.xml

When done, save the file, exit Notepad and run the Updater.

If you run the game and you are prompted for license info, then you messed something up. In which case you will have to rollback to the previous 1.00.03.01 patch and do it over.

Share this post


Link to post
Share on other sites

I own the PC/DVD copy of UCCE and have it updated to version 1.00.03.01. When I try to check for updates using the updater to obtain version 1.00.03.02, I get a NSIS Error stating, "The installer you are trying to use is corrupted or incomplete. This could be the result of a damaged disk, a failed download or a virus". I attached a screen shot of the error with this post.

I've re-installed the game and continue to get this error. I've read the various instructions that pertain to downloaded copies of UCCE and the changes to the settings.ini; but, these instructions don't pertain to the PC/DVD copy. The mirror sites for manual download still contain version 1.00.03.01 of the update.

FWIW:

When I originally installed UCCE, I had some really wierd "plaid pants" like coloring display that would overlay the game screen. I read the FAQ giving instructions on fixing video issues. After installing the latest drivers for my ATI X800 video card, everything looks great now.

My first encounter with the Battlecruiser series was the first iteration BC3000AD version 1. I put it down because of the "issues" at that time. I am looking forward to re-engaging the thrusters and taking the CC out for a spin. I have a lot of fun discovering and executing the simple stuff (since this is a REAL CC in space) and thinking, "Wow, I finally got the probe launched" <g>.

Cmdr-IT.Ripster

post-7898-1194104911_thumb.jpg

Share this post


Link to post
Share on other sites
When I try to check for updates using the updater to obtain version 1.00.03.02, I get a NSIS Error stating, "The installer you are trying to use is corrupted or incomplete. This could be the result of a damaged disk, a failed download or a virus". I attached a screen shot of the error with this post.

That makes no sense whatsoever. (1) The NSIS installer has nothing to do with the Updater (2) The Updater does not use NSIS (3) Running the Updater does not immediately run the installer

When you run the Updater, it firsts checked for an internet connection, then downloads the [NSIS created] patch (ucce_1.00.03.02.exe for your DVD-ROM version) file from the server, copies it to the game install folder and then runs it.

If you have a corrupted file download, then that could explain the error message you are getting when the patch itself is executed.

You may have a bad download because I just downloaded the patch file and checked it. Check the game installer folder for the patch file mentioned above. The size should be 17,269,405 bytes. If its anything else, then you have a corrupted download.

So, you need to re-download the patch file again. Check the SETTINGS.INI file. If the current version is 1.00.03.01, then you can just run the Updater. But if it says 1.00.03.02, then you need to change it to the previous version and then run the Updater.

Please, if you are going to report a problem, be 100% accurate so that its easier to assess the problem and be able to assist in a timely fashion.

btw, if you passed on the original BC3K, boy are you in for a heck of a time; since UCCE covers all the games in the series but running on more advanced engines in which everything that I can think of, has been resolved. Hence the reason its the sayonara version. B)

Share this post


Link to post
Share on other sites

Repost 1515 hours CST: After reading Supreme Cmdr.'s reply, I performed the same start->programs->3000AD->Universal Combat Collector's Edition->Check for Updates and now it worked perfect. I dunno why I posted exactly what occurred before, but it is working for me now. Thanks!

Share this post


Link to post
Share on other sites
Repost 1515 hours CST: After reading Supreme Cmdr.'s reply, I performed the same start->programs->3000AD->Universal Combat Collector's Edition->Check for Updates and now it worked perfect. I dunno why I posted exactly what occurred before, but it is working for me now. Thanks!

Yeah, sounds like you had a bad download or something.

Share this post


Link to post
Share on other sites

I've tried many times to install this patch. I have BMT Micro version and I have made the changes to the settings.ini and changed the install path to my install folder. When I try to start the game I get error: "PTE2 Error Cannot find file pteObjects.ini"

Share this post


Link to post
Share on other sites

ack!!!

The UCSE to UCCE upgrade uses a different (the default UCSE one) path for the PTE3 terrain files and this patch installed the global default INI version which overwrites the one required.

  1. Open up UCSETUP.INI in Notepad
  2. Edit the [three] PTE related lines by changing them from pte to pte3
  3. Save the file

The end result should look like this

[setup]
version=1.00.03.02
;
[resource]
archive=RESLIB1A.RES
directory=.\data\ /z
include=*.*
directory=.\gfx\ /s
include=*.*
directory=.\gfx\ /z
include=*.*
directory=.\mods\ /z
include=*.*
;
archive=RESLIB2.RES
directory=.\data\ /z
include=*.*
directory=.\gfx\ /s
include=*.*
directory=.\gfx\ /z
include=*.*
;
archive=RESLIB3.RES
directory=.\pte3\ /s
include=*.*
directory=.\pte3\ptetex\ /s
include=*.*
;
archive=RESLIB4.RES
directory=.\data\ /z
include=*.*
directory=.\gfx\ /s
include=*.*
directory=.\gfx\ /z
include=*.*
directory=.\models\ /s
include=*.*
directory=.\pte3\ptetex\ /s
include=*.*
;
archive=RESLIB5A.RES
directory=.\soundfx\ /z
include=*.*

;End of resources[/code]

In your game install folder, you should also have a PTE and PTE3 folder. Move all the files from the PTE folder into the same path in the PTE3 folder and delete the PTE folder.

I'll fix and re-upload the BMT version of this patch in a few mins. You can wait about 15 mins after the time stamp of this post and re-run the updater again (after rolling back your version num) to download and apply the corrected version. You will still have to delete the deprecated PTE folder.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×