Jump to content
3000AD Forums
Sign in to follow this  
RT

Naval assets wont stay afloat.

Recommended Posts

Sorry, should have added it's a UC:CE issue in the thread title.

I'm not sure to what version that issue is related, it doesn't appear in my UC:CE Direct2Drive vanilla version( v1.00.03.01) and I just noticed it when playing IA0003 (PS PILOT, NAVAL CARRIER DEFENSE) using version 1.00.10, however it is reproductible in any other Instant action, ROAM and ACM games.

I can't find other, in-between patches, so I only tested with these two version (1.00.03.01 and 1.00.10). The Direct2Drive 1.00.10 version was downloaded and installed using the game updater.

Some words used:

ZOOM on <mzone/scene>: use the TACOPS 'zoom' button to zoom on the given scene from the indicated mission zone.

Observe <planet>: using TACOPS, click on the indicated planet/moon and select 'observe' to bring you to the planet's map.

V1.00.03.01 test:

Install the D2D v1.00.03.01 game. No beta patch, nothing. Clean install.

Run the game, go to the Instant Action page, select PS PILOT scenario IA003 NAVAL CARRIER DEFENSE and launch it.

Your should start in a Starmonk Light fighter, on the deck of a Naval Carrier, in EART/TER-MIL/EARTH331[NBASE]/NBASE01. There are bandits inbound so you may want to activate the EMD jammer to survive long enough to check some things.

From what you saw in the cockpit view, the naval carrier is floating well, as is supposed to.

Switch to exterior view using F9 and look around a bit. Your altitude should be oscillating between 200 and 300 AGL, which is the expected behavior (yeah, the deck is high).

Get back to cockpit view and target the naval carrier you're on using the TRS in GND mode. Now switch to target view and check the targets altitude, which should be oscillating between -20 and -80 MSL, nothing out of the ordinary. Look at other naval crafts, they should all be fine too. So far so good.

Just to be sure, we'll check other scenes as well.

Open tacops, click 'zoom', select 'TER/MIL' then select EARTH13[NBASE].

There are three naval bases in that mzone, check them all. If you know how to use tacops, you'll figure out all the crafts that are supposed to be floating...well, float.

Also check TER-INS/EARTH17[NBASE]. There are several naval bases there too. All crafts are floating.

Leave that game.

Start a new ROAM game, you'll be an Terran Military Elite force pilot flying a shuttle MK1. At the MISCON page, select ROAM AND EXPLORE. Accept.

You start in the Earth region, near GalcomHQ.

Using TACOPS, we'll have a look at various naval bases again.

Open TACOPS, bring up the EARTH map using the 'observe' command. ZOOM on the mission zones we checked earlier in the IA003 scenario (TER-MIL/EARTH331[NBASE], TER-MIL/EARTH13[NBASE], TER-INS/EARTH17[NBASE]).

All of the naval crafts present in the scenes from these mzones float correctly.

While you're at it, add a waypoint for SC1 near the naval carrier in TER-MIL/EARTH301/NBASE01. Leave TACOPS.

Target EARTH using the NID, press 'shift'+'9' to jump to it, press 'Y' to accept planetfall. Once you're done with planetfall, switch the TRS to GND mode, target the naval carrier and land on it. From what you can tell, the carrier and the naval crafts surrounding it are floating.

We'll also check another planet with oceans and naval bases. Leave the current game.

Star a new ROAM AND EXPLORE game. This time, we'll be playing a gammulan Elite Force Pilot starting in gamma1, flying an MK1 shuttle.

Launch the game. Bring up TACOPS, observe GAMMA1, ZOOM on GAM-TRA/GAMMA1107/NBASE01. Add a waypoint for SC1 in the vicinity of the naval carrier there. Leave TACOPS, target GAMMA1 using the NID, jump there using shift+9 and accept planetfall.

once again, once the HJ and planetfall transition are over, descend to 2000ft, and fly around a bit. Of course, your goal is to check all crafts float fine, do so.

Leave your game, close UC:CE.

v1.00.10 test:

Open the game updater, update your game to the 1.00.10 version. The process is quite straightforward, I'm not describing it in full details here. Make sure to accept and install the august 2008 DX update. Check everything was installed fine, then open UC:CE again.

From what we gathered with the previous, 1.00.03.01, testing there shouldn't be anything wrong with naval crafts. They should be floating.

Let's check.

We started with the IA003 scenario, so we'll start with it again.

Instant action -> IA003 PS PILOT NAVAL CARRIER DEFENSE-> Accept.

Once the game is done loading, you'll notice that..well, you're lying on the seabed. Activate the EMD jammer using J to be safe.

Switch to exterior view using F9 and monitor the surroundings. Your starmonk is indeed at the bottom of the ocean, as are all the naval craft that should be floating at water level.

If you look closely, you'll notice all the naval craft are actually slowly going upwards. Target any of them using the TRS in GND mode, then switch to target view using F10.

Monitor your target's 'altitude': it should be somewhere at -3000 MSL and increasing. It's going upwards. Now target the naval carrier and watch its behavior. It's going up way faster than any other craft and will eventually reach sea-level. however, once there, it will go up in the air up to around 1000 AGL.

If youy're an experienced player, you should have already noticed that fighters can't touch water without triggering the SOS device, their status switching to 'floating' and most systems displaying 'MALFUNCTION'.

Indeed, but the craft isn't considered yet as 'floating'. You're simply taxiing on the seabed as you can read on the FPA.

You can, if you're patient, press F to get into VTOL mode and make your way up to the sea level, slowly, and eventually get up in the air and then get to FTOL mode (yes). As long as you're underwater, you cant get into FTOL mode yet. Also, if you ever press W, the game WILL detect that you're underwater and set your status to 'floating' and your MFDs to 'MALFUNCTION'.

We'll now check and see if all naval assets in other naval scenes act the same.

Bring up TACOPS and ZOOM on TER-INS/EARTH17[NBASE] (we checked these naval bases in the v1.00.03.01 test, and know for sure they should be floating).

Monitor all the naval crafts in that mission zone. They are ALL underwater, be it on the sea-bed or slowly going up to the surface.

Leave your game.

We'll now check the behavior of naval bases in a ROAM game as we did with the v1.00.03.01 test.

ROAM, TER/MIL Elite force pilot, shuttle MK1.

Once again, you'll use TACOPS to monitor the mission zones we monitored earlier (TER-MIL/EARTH331[NBASE], TER-MIL/EARTH13[NBASE], TER-INS/EARTH17[NBASE]).

Check all naval bases there. Yep, they're all underwater too. Add a waypoint for SC1 near the naval carrier in TER-MIL/EARTH301/NBASE01. Leave TACOPS.

Jump to EARTH, establish planetfall.

There should be no boat floating there. Check your TRS in GND mode, target any of the nearby ships and switch to target view.

No, there's definitely something wrong there.

Be carrefull not to descend below 2000 ft, you may bumb into the naval carrier that's behaving oddly, jumping out of the water 1000ft AGL high.

Leave the game.

Start a new ROAM game. You're a gammulan, military elite force pilot flying a shuttle MK1. You want to start at Gamma1.

Then again, open TACOPS, Observe GAMMA1, ZOOM on GAM-TRA/GAMMA1107/NBASE01. Add a waypoint there, jump to GAMMA1, establish planetfall.

Switch the TRS to GND mode and check your surroundings. Use TACOPS and target view. Yes, boats behave the same way here than on earth: they wont stay afloat.

Share this post


Link to post
Share on other sites

Did u try it with IA0211? That is a scenario with you on the naval carrier deck. If its broken there, let me know.

In the v1.00.10 build I revised the height handling of terrain objects and that may be causing the naval units to no longer float.

Share this post


Link to post
Share on other sites

Funny that you mention it, I already tried with that scenario but didn't felt like it was of much importance to report it too.

Anyway, I just double-checked, just to be sure, yes, the same behavior occurs in IA0211.

Share this post


Link to post
Share on other sites

Try it now with Beta 04 and let me know. IA0211 will let you know if it works or not. I tried it here and it works fine again.

Share this post


Link to post
Share on other sites

Both Naval carrier defense scenarios work fine now, thanks. These are my favorite! (and the most FPS-eater too)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×