Jump to content
3000AD Forums
Sign in to follow this  
Mitovo

Major performance drop

Recommended Posts

Hello,

So, I've been doing some more exploration/testing of LoD, but am finding it difficult to do much in the past couple days, as there's been a serious drop in frame-rate, specifically on planets. Stations are still fine. For a few days, I was getting smooth performance, but with a sort of "hitching" every few seconds. Now, however, running the game at the same settings that was yielding almost 60FPS my first few days in the game, even while recording footage at those settings, I'm now dropping into the single digits, going as low as 7FPS at one point. 

Have changes been made to the terrestrial part of the engine, or some part of the renderer, that might explain this? I can try and gather more specific information to help identify it, if it would help.

Also, is there a limitation to how many players can currently inhabit a given planet location? I saw there was one person on Gulge, so I thought "Oh cool! I can interact with another player". Except it won't let me connect to that zone, no matter the method (drop, direct log-in, or teleporter). I tried a few times. Each time, it brought me back to the login screen.

I'll keep trying to figure it out, but it's been rough getting much done in the last couple days.

Edit: I did a force update (just in case), and deleted the config file to reset everything, then logged in again. Thought maybe changes I made to the defaults might provide a clue. But that turned out to be negatory. Same results, even with full default settings.

Share this post


Link to post
Share on other sites

Hi Mitovo:

I'm thinking that they are still optimizing the other scenes.  Heatwave runs pretty good, but the other 3 planetary scenes sort of run with a little "jerkiness", for lack of a better term.  My guess is that they just haven't gotten to those ones yet in the ongoing optimizations.

As for not being able to connect to Gulge with the 1 person there, yes, I ran into that as well the other night.  I added to a ticket I already have in.  They said they are aware of the problem and are investigating it.

You may want to consider posting your LoD testing notes over on the Steam Forum.  I think it will make it easier for the developers to check out the feedback rather than coming here to the 3000ad forum.  At least for the moment! :)

 

-Sho

Share this post


Link to post
Share on other sites

Ah okay, so that's the preferred place to post anything that pops up, then? Given the rather caustic/unhelpful nature of many on the Steam forums, I'd thought this might be the preferred place for bug/issue related feedback.

No problem, though. I'll post over there going forward, then.

Thanks!

 

Share this post


Link to post
Share on other sites

Quick note...

Got in for a little bit before I crash for the night, and trekked around Frostbite. Caught a cool sorta "long snow drift" blowing by, which looked awesome. It was night, so it had this sorta "ghost train" type of appearance, especially as it passed by and receded into the distance.

Anyway, the main point of my post is that it looks like the performance is back, and I was hitting upward of 60FPS again (@1920x1080 with the DX9 client).  Didn't get to test any of the other areas again, but can give them a look tomorrow.

I'm really looking forward to hopping into a ship, and getting to interact with other players, even if it means (as it probably will lol), getting my butt kicked into next week.

So, just wanted to pop in and follow up on the topic.

'til next time!

o7

Share this post


Link to post
Share on other sites

You can still post here, Mitovo, no problem.  It just that Derek monitors the Steam Forum as well as here.  I'm a mod over there, so we try to keep the riff-raff out. :)

Good to hear that Frostbite is running good for you! :)

 

-Sho

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×