Jump to content

SafeDisc Issues - Emulation software, debugger error, cannot locate CD-ROM

Recommended Posts

If you get a similar message when trying to run the game, read ALL the posts these two threads.

ERROR! CD/DVD emulation software or debugger message at game launch

ERROR! Installation, copy protection, cannot locate CD-ROM etc

[ 12-10-2004, 07:59 AM: Message edited by: Supreme Cmdr ]

Link to comment
Share on other sites

Based on an NFO file sent in by someone earlier, here is the response from Macrovision.


Can you please confirm if the user is getting "Debuggers message" or "Emulation detection message".

I found ELBYVCD.SYS driver loaded on user’s system which is basically a Clone CD driver. This

should give emulation detection error instead of debugger detection error. Can we get the snapshot

of the error?

Attached is the snapshot of the clone CD finding.

By the way I can see a number of SafeDisc protected program installed in user’s system and I am

assuming all running fine. They might have used a little older version of SafeDisc.

Some suggestion I found on the net on how to remove Clone CD.

(1) Uninstall the VCD. Uninstall CloneCD if you have to; before doing that, make sure you have

your CloneCD serial handy.

(2) Search the registry(Start>run>search files)) for ELBYVCD.DLL and ELBYVCD.SYS files and delete them.

Try the game again after removing ELBYVCD

Clone CD is from Elaborate Byte and I think Daemon tools is the older name.

If you look in the NFO file you sent, that driver that Macrovision is talking about is in C:WINDOWSSYSTEM32DRIVERS folder

Basically, this person has remnants of an older version of CloneCD, which was previously not uninstalled properly. If you remove this remnant (follow the instructions above), then re-install CloneCD/Daemon tools and then *disable* them properly before running the game, everything should be fine.

Link to comment
Share on other sites

Update from Macrovision, edited and formatted for the general public.


What we found that this debugger’s message is NOT coming from SafeDisc itself. This debugger message shows a Red Cross mark with the message
Unload the Debugger and Try again

Here may be the cause of the debugger error which you have reported: Our engineers found this on a web site for a

product called Blaze Media Pro. If you search for the exact error message you will also get a few other hits e.g.

CDFreaks, where people have reported the problem on their machines. According to the text below, the message is

caused by DivX. One of the hits found was on a OpenGL website.

It is probably the case that the DivX code thinks that WE (SafeDisc protected program) are the debugger :-)

Although the text below mentions reverting to an earlier version of DivX, I think there may be a more recent

version which fixes the problem.

"I am attempting to convert video files, but the following message is shown:

Debugger detected - please close it down and restart. Windows NT users: Please note that having

the WinIce/SoftIce service installed means that you are running a debugger.

I do not believe I am running a debugger. What could be the problem?"

This error is caused by DivX 5.1. The issue you have mentioned is a bug in this release of the DivX codec. The

codec is actually what`s showing the error, and shutting down Blaze Media Pro because it is erroneously detecting

the software as a debugger. You can uninstall DivX 5.1 and revert to DivX 5.05, and you will no longer have this


The fix appears to be to try and update (or downgrade) the DivX drivers. From the information we found , it won't

just be SafeDisc products which have this problem.

Link to comment
Share on other sites

  • 4 months later...
  • 3 weeks later...

I have had an issue with a non SafeDisc related error and found that this was caused by the latest NERO Burning Rom patch that I have applied a few days ago; I don't know what exactly caused the problem but seems like the patch triggered something....

I'm still trying to pinpoint the element causing the problem, I'll post here with more details if I'll find something.

Link to comment
Share on other sites

  • 1 month later...

As of UC v2.00.19 patch, we are now using the latest SafeDisc 4.x protection. Some notes to bear in mind if you have problems. You can also read this thread.

  1. In the case of CloneCD, all you have to do is made sure the "Hide CD-R" option is turned OFF; you do NOT have to uninstall the program.
  2. Upgrading from an Elaborate Bytes version of CloneCD (e.g. V4.2) to a SlySoft version (e.g. V5) might cause SafeDisc authentication issues. To fix this, reinstall the previous version and then uninstall it completely, ensuring all registry settings are removed.

Link to comment
Share on other sites

  • 2 weeks later...


I need assistance getting UC to run. I have followed all of the suggestions on this thread. I also sent a nfo file of my system, and tech support's reply was that it was of no value to them, even though this is what the instructions said to do.

Any help would be appreciated.



Link to comment
Share on other sites

Thank you so very much for answering. I appreciate your taking the time to help. I tried one other thing, I uninstalled Nero Ultra 6, even though there was no evidence of it running. That worked, and the game started. I reinstalled Nero, and the same problem cropped up. Is there anything I can do so that both programs can co-exist on my computer?

Again, thanks for everything, and have a great holiday season.



Link to comment
Share on other sites

I can take a stab at this.

I use Nero Suite 6, an OEM version that came with my DVD/CD burner. It does not come with Nero ImageDrive but it looks like the Ultra version does. I'm betting the UC copy protection does not like ImageDrive. Perhaps if you do a selective install, i.e. install the complete Nero suite except ImageDrive your problem will go away.

Link to ImageDrive page

Link to comment
Share on other sites

Thats no true. I have Nero Ultra installed and you can enable/disable ImageDrive. If you have ImageDrive enabled, SafeDisc will fail to authenticate.

So, thats whats causing your problem because NO disk mounting software (e.g. CloneCD, ImageDrive) should be enabled.

[ 12-10-2004, 08:08 PM: Message edited by: Supreme Cmdr ]

Link to comment
Share on other sites

Again, I thank you for your help. When I click on ImageDrive in the Nero folder on the start menu, I get a message telling me it is disableed, would I like to enable it. I looks like it is already disabled, and I still have the same problem. I even enabled it, and then disabled it, but it did not help. But, when I completely remove Nero software, the game starts. I wish I could be more helpful, and less of a pest, but I really don't know what else to do. If I have to uninstall Nero, I will. I don't use that program much anyway. I can always reinstall it as needed.

Thanks again for the help


Link to comment
Share on other sites

Dear SC:

I wish I knew what the problem is. Is there any chance of your forwarding a copy of my System Info to Macrovision? I have tried to contact them, but they have not answered my e-mails. I guess that is because I am not a software developer, which is understandable. They might accept it from you.

Best wishes


Link to comment
Share on other sites

Hey there SC

Just installed .19 on this new system, when I had it on my old one I had no problems... now it seems I do and I really have no clue why

Whats odd is that even though I get a non-safedisk window. This problem started AFTER applying the patch

It says I have a debugger active, I've disabled MDM and DivX but still have the issue, my process list is as follows (by teh way, thank you very much for posting the image's for non/safedisc windows.. made it eaiser to understand ) Perhaps you can help me, cause I've really hit a brick wall here

System 4 1

smss.exe 564 Windows NT Session Manager Microsoft Corporation

csrss.exe 616 1 Client Server Runtime Process Microsoft Corporation

winlogon.exe 648 Windows NT Logon Application Microsoft Corporation

services.exe 692 Services and Controller app Microsoft Corporation

svchost.exe 876 Generic Host Process for Win32 Services Microsoft Corporation

msmsgs.exe 3348 Windows Messenger Microsoft Corporation

svchost.exe 944 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1044 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1144 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1244 Generic Host Process for Win32 Services Microsoft Corporation

CCSETMGR.EXE 1308 Common Client Settings Manager Service Symantec Corporation

CCEVTMGR.EXE 1404 Common Client Event Manager Service Symantec Corporation

spoolsv.exe 1592 Spooler SubSystem App Microsoft Corporation

CTSVCCDA.EXE 1952 Creative Service for CDROM Access Creative Technology Ltd

NAVAPSVC.EXE 164 Norton AntiVirus Auto-Protect Service Symantec Corporation

nvsvc32.exe 236 NVIDIA Driver Helper Service, Version 61.21 NVIDIA Corporation

symlcsvc.exe 472 Symantec Core Component Symantec Corporation

wdfmgr.exe 492 Windows User Mode Driver Manager Microsoft Corporation

MsPMSPSv.exe 552 WMDM PMSP Service Microsoft Corporation

SymWSC.exe 620 Norton Security Center Service Symantec Corporation

alg.exe 1352 Application Layer Gateway Service Microsoft Corporation

cisvc.exe 2112 Content Index service Microsoft Corporation

cidaemon.exe 1844 Indexing Service filter daemon Microsoft Corporation

lsass.exe 704 LSA Shell (Export Version) Microsoft Corporation

taskmgr.exe 3488 Windows TaskManager Microsoft Corporation

explorer.exe 1856 Windows Explorer Microsoft Corporation

CTSysVol.exe 1736 CTSysVol.exe Creative Technology Ltd

CTDVDDET.exe 1756 CTDVDDET Creative Technology Ltd

CTHELPER.EXE 1796 CtHelper Application Creative Technology Ltd

PDVDServ.exe 1900 PowerDVD RC Service Cyberlink Corp.

CCAPP.EXE 1332 Common Client User Session Symantec Corporation

jusched.exe 2148

jucheck.exe 2248 UpdateChecker Module

MsgPlus.exe 2240 Messenger Plus! Patchou

RcMan.exe 2400 Remote Control Manager Creative Technology Ltd

ctfmon.exe 2416 CTF Loader Microsoft Corporation

acrotray.exe 2524 AcroTray Adobe Systems Inc.

PopMenu.exe 2536

msnmsgr.exe 2940 MSN Messenger Microsoft Corporation

IEXPLORE.EXE 2200 Internet Explorer Microsoft Corporation

procexp.exe 3896 1 Sysinternals Process Explorer Sysinternals

SYSDOC32.EXE 3432 Norton System Doctor Symantec Corporation

winhlp32.exe 312 Microsoft® Help Microsoft Corporation

Process: System Idle Process Pid: 0

Type Name

I hope I gave you enough information and posted this in the right area.. if I didn't please let me know, thanks

Link to comment
Share on other sites

  • 2 weeks later...

Just ran across this on the web and it may explain some of these problems some are having with debugger messages and also have a Audigy2:

"Hello All, I had this same problem when I tried to run Medal of Honor:Allied Assault after installing an Audigy 2 Platinum Sound card. After searching the Web for an hour or so, I found a solution that worked just fine, and it actually made some sense. For those of you who installed the driver/application software from Creative Labs Audigy 2 Platinum, you simply need to "uncheck" the box that lets that annoying Creative Introduction/Getting Started/Demo screen launch on startup, then reboot your system to see if A-the annoying startup graphic stops launching at startup and B-your game stops prompting you to "unload the debugger" when you try to run it. "

"I found the answer for myself - I just got an Audigy2 retail and started having this problem with Battlefield 1942. After reading this post I went in to 'msconfig' (Start ---> run: 'msconfig') and disabled 'CTSysVol'. After that, Battlefield 1942 runs just fine.... Cheers!"

Try that and see if it helps.

Link to comment
Share on other sites

Here is what Macrovision had to say about your post above.


No. We never heard of this exact problem. However there have been some video player related problems recently, some of the new video player software have inbuilt anti-debugging code to check and stop people from hacking into the video stream etc, and some times this software detects SafeDisc as a debugger and sometimes we detect them as debuggers. The net result being that the games don't load.

Link to comment
Share on other sites

Hi. I'm new to this forum, and just bought Universal Combat. I had the "debugging" error message as well. I deactivated both Web Debugger and Machine Debugger, still had the same message. Like others, I uninstalled Nero 6 Ultra edition, and the game now runs. So, there is validity to all those who've had to do this. The only issue I have now is the Indeo Codecs on the opening animation and some of the HUD animations, since MS no longer supports Indeo Codecs and I don't feel like paying for them. Just thought I'd let you know that there is a conflict with Nero Ultra and the game.

Thanks, Boscoe

Link to comment
Share on other sites

  • 2 weeks later...

I Have A big Problem !!!


Debugger detected - Please Close it down and Restart.

Windows NT Users: Please note that having the

WinIce/SoftIce Service installed means that you are

Running a Debugger.

Is this Problem Solved.?

How and where can i find the Solution of it.


I post a reqeust But that is delete.


Link to comment
Share on other sites

Guest Arthur_Dent1976

Hi there ed-Dutchie, welcome to the forums and the game! Please put a link to your system-specs in your signature. The people on these boards use the info provided there as a first step in determining what can cause your errors. To add the specs, please follow the guidelines posted here. That link also gives you info on why moderators sometimes delete posts.

As for your problem concerning the debugger dialog box, you might want to follow the first link in the first post in this thread. You can send me a private message in Dutch if you need additional help!

Edit: I see you already fixed your sig. Thanks

Link to comment
Share on other sites

  • 2 weeks later...

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...