Jump to content
3000AD Forums
Sign in to follow this  
Cougar_DK

Problems with stutter

Recommended Posts

Hi, I have some pretty bad stuttering going on when playing missions on planets, manning planes, vehicles or on foot. The longest one has been nearly 6 secs where I could do nothing in the mission IA0115 MI Marine.

I havn't played so much around in space yet, but I have seen some stuttering.

I have tried to delete the "ucconfig.ini" file and played the same mission with the standard settings. I also disabled the music just in case. Same result.

My next step was to try the "-preload" command parameter but it didn't help out either.

I then tried to unzip all the sound files as of the troubleshooting file. (And deleting the zip files). I helped a little but not enough.

It seems it has something to do with playing sounds. But its only a guess.

I have my DxDiag file here if it could give you some info.

I'm very open for suggestions or trying things out.

Share this post


Link to post
Share on other sites

I have experienced the same thing in the situations you describe. Planetside during the long freezes, it also appears that the sound is looping.

Additionally, I have experienced brief stutter in space, as well.

I also suspect it is sound-related. It consistently stutters when a hostile appears in-system and my guess is it is related to the alert klaxon that announces the hostile's arrival.

I am running UC with the sound accelaration and graphics acceleration tabs dropped one notch, per instructions.

In options, I have the music turned off. All other options are set to their maximum or best quality, and the game is running fullscreen at 1024x768, which matches my desktop resolution.

My system signature is up-to-date, with the exception of the CATALYST driver, which I upgraded to 4.1

Share this post


Link to post
Share on other sites

Both of you have Audigy 2s...

Anyone else without an Audigy 2 experiencing this? (I have an Audigy Gamer, but can't tell you until I pick up the game tonight! )

I'd give you a link to update drivers for the audigy, but stupid school computers eat cookies instead of store them or something, (wont remember my region on soundblaster.com so i cant go anywhere)

Try

http://www.soundblaster.com and look on the bottom right side for "Drivers"

Share this post


Link to post
Share on other sites

I had this for a while, but a combination of defrag (several and using a third party defrag) and -preload all but elminated it. I still get some big pauses when observing a planet the first time, but once it's cached it's ok.

I also noted that with preload UC uses 750mb of ram, so if you have less than 512 you might not want to use it.

BTW I tried to unzip the sound files and deleted the zips, but then I'd get no sound effects at all.

Share this post


Link to post
Share on other sites
Guest BaBaBooey

I get the same thing. I have a Soundblaster PCI512 card. Every time enemies appear on my scope it happens. Also happens around planets as stated.

Share this post


Link to post
Share on other sites

Its nothing to do with sound. The short delay occurs when a batch of objects are created all at once.

If you defrag your HDD, add more memory etc, it will be minimized.

It is more noticeable on planets because there is a lot more processing going on and because when an npc person (e.g. marine) is loaded, it loads the base model, textures and ALL of its animations. Thats what causes the pause. Nothing I can do about it. The /preload option is designed to alleviate that somewhat, but it won't do any good if you don't have enough base memory to hold all the models etc because once a model that is not in the /preload cache is needed, its going to flush something to make space. It'll cause a pause again.

I was experimenting with a new caching scheme, but with everything else going on, coupled with Dreamcatcher's rushed release of the game, I abandoned it. In fact, thats what that /preload option was for. That was the first pass test to see where the loading needed to be cached, preserved etc etc.

Share this post


Link to post
Share on other sites
Guest Fox__Trot

Yeah, I've only had a stutter problem once and that was in this god awfull fight - where I almost lived til I realized my nuclear reactor was ab out to go up (pta turrets off the solar reactor?) - in space ... it's never happened to me on the ground though

Share this post


Link to post
Share on other sites

I've had similar problems in the past with my soundblaster live, but I've also found a way to fix it. Bring up the control panel, go to multimedia options, select advanced properties, and turn the hardware acceleration off on the soundcard, almost always fixes the stutter for me.

*edit*

I just tested this and i too was getting a stutter with the UC demo until i turned the hardware acceleration off on my soundblaster live

Share this post


Link to post
Share on other sites

quote:

Originally posted by Supreme Cmdr:

Its nothing to do with sound. The short delay occurs when a batch of objects are created all at once.

If you defrag your HDD, add more memory etc, it will be minimized.

It is more noticeable on planets because there is a lot more processing going on and because when an npc person (e.g. marine) is loaded, it loads the base model, textures and ALL of its animations. Thats what causes the pause. Nothing I can do about it. The /preload option is designed to alleviate that somewhat, but it won't do any good if you don't have enough base memory to hold all the models etc because once a model that is not in the /preload cache is needed, its going to flush something to make space. It'll cause a pause again.


What part of the SCs post is unclear?

Share this post


Link to post
Share on other sites

Here's my experience, using IA0115..

Defragging helps a lot, especially for the small stutters when the game is loading sound effects, such as thunder during the storm or some friendlies show up in your view. I still get a 2 or 3 second delay when the game appears to be loading a lot of data, most notably when you get the "hostile target identified" for the first time, and the hostiles show up on radar.

Share this post


Link to post
Share on other sites

quote:

Originally posted by Fox__Trot:

Yeah, I've only had a stutter problem once and that was in this god awfull fight - where I almost lived til I realized my nuclear reactor was ab out to go up (pta turrets off the solar reactor?) - in space ... it's never happened to me on the ground though

Yeah but you also have 1 gig of ram... maybe I should screw around with the 3 Gig max on my mobo? Would the game even utlize that massive ammount of memory (or anything (software wise) for that matter, I heard windows wont' even recognise that much ram)

Share this post


Link to post
Share on other sites

quote:

Originally posted by Bandus:

...What part of the SCs post is unclear?

Would it be possible, that the stutter (which I receive too, but thought it was on account of my 900mhz cpu) is lessened when audio hardware acceleration is turned down because perhaps the soundcard was caching information too?

Then when the audio acceleration is turned down it allows more caching of other game stuff?

I understand that it's not sound card related but perhaps turning down the audio acceleration frees up computer resources that can now help process all the new entities, etc. and other stuff that also had nothing to do with the sound card...

Share this post


Link to post
Share on other sites

quote:

Then when the audio acceleration is turned down it allows more caching of other game stuff?


I tried all levels of sound acceleration in directx and turned off both music and sound effects in UC with no noticible difference. I have onboard sound. I suppose I could try disabling the sound in the bios but nothing seems to point to a sound issue as the SC has already said.

I'll keep tweaking. I enjoy this kind of thing.

Share this post


Link to post
Share on other sites

I've been getting some pretty bad stuttering too, I have 1gb of ram (oh! have to update my system config...) and I'll give preload a shot... so...

is it /preload or -preload in the shortcut?

Share this post


Link to post
Share on other sites

The sound card causing performance issues, is a completely different issue entirely. So, ladies, lets not get confused.

Share this post


Link to post
Share on other sites

Wow... note: Pre-load takes a long time to load the game. hehehehe.

EDIT: yeah yeah... I got it.

[ 02-13-2004, 09:58 PM: Message edited by: CedricB ]

Share this post


Link to post
Share on other sites

quote:

Originally posted by Bandus:

Are you kidding me?

If you've two options to choose from....and one gives you an error....which one do you think was the right way?

I mean come on, time to log on, post ... blah

anyway

Has anyone else had any ideas with this?

-Launched from GALCOM, flew to the Moon... jumped aboard FC 5 and took a trip to the moon's surface... landed, and attempted to get out. I sat there for nearly a whole minute thinking my game froze, the music was looping like a scratched record. Finally I popped out and everything was fine.

-Other times new hostiles in the sector appear and i get momentary "freezes" where music loops (or sound if I'm shooting, etc)

quote:

It is more noticeable on planets because there is a lot more processing going on and because when an npc person (e.g. marine) is loaded, it loads the base model, textures and ALL of its animations. Thats what causes the pause. Nothing I can do about it.

quote:

I was experimenting with a new caching scheme, but with everything else going on, coupled with Dreamcatcher's rushed release of the game, I abandoned it. In fact, thats what that /preload option was for. That was the first pass test to see where the loading needed to be cached, preserved etc etc.

Between those two post one kind of gets the idea you were working on fixing (i.e. optimizing the loading, etc)... do you have any inentions of continuing work on the side to alleviate that pause SC? Or is that out of scope condiering your development time has been killed? (i.e. too massive for a patch)

Share this post


Link to post
Share on other sites

quote:


Originally posted by Aphelion7:

do you have any inentions of continuing work on the side to alleviate that pause SC? Or is that out of scope condiering your development time has been killed? (i.e. too massive for a patch)


There's nothing I can do about it. In your case, you're running a 1.3Ghz machine, which barely the minimum requirement for the game.

Share this post


Link to post
Share on other sites

I'm getting the same stutter. I've tried everything suggested in the FAQ and in this thread including the preload, unzipping the audio files, running with the sound accelaration and graphics acceleration tabs dropped one notch, defragging, ect. No matter what I do I can't seem to improve it at all. I don't get any audio looping but the stutter is so pervasive even in space it's making the game almost unplayable. Its very disappointing at this point.

Share this post


Link to post
Share on other sites

Funny thing is, I have that same machine sitting here in a corner (its a file server), but with a GF4 Ti4600 in it. Smooth as butta.

Nothing I can do about stuttering because its not the game, its a system issue and you need to find and resolve it.

All of you should go into your BIOS and disable things like AGP Fast Write, on-board audio (if you're not using it) etc etc

Share this post


Link to post
Share on other sites

All right. I ventured into the BIOS and disabled the AGP but could not disable the on-board audio less I get no sound at all. This has yielded no improvment. Are there other items within the BIOS I should look out for? It's encouraging to hear you have a similar system one which the game plays smooth. Gives me hope that once I turn on/off the right switch on this darn machine of mine everything will fall into place. Any further tips/ideas would be greatly appreciated.

cheers and the game looks great and I would have gladly paid the $40 spot for it (assuming I can get my machine to handle it).

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×