Jump to content
3000AD Forums
Sign in to follow this  
Supreme Cmdr

BCM Episode 2 demo - Help!!!

Recommended Posts

I just finished installing the demo2. I went thru the setup with no problem. When i went to start it, i got the little BC3000 introduction. Then, it crashed to the desktop. Anyone else have this problem? I remember when this happend with the original game, i created a shortcut for it. And it ran fine. Do i have to do the same thing here? Thanks.

Share this post


Link to post
Share on other sites

Couple more minor things; when playing the bonus mission, if I switch to an F9 view, all I see are the tail fins (or whatever they are) and the nose cone of the fighter. This only happens if I die in the mission (which is quite a lot) and restart it. Same thing happens in the marine mission in the ATV, only the gun turret is visible (but only if the bonus mission has been installed) could this be related to the 'big planet' syndrome previously described by myself and Harlocke?

Share this post


Link to post
Share on other sites

Hi, I'm having a little problem with the controls in the second mission of the demo (E2). I have a Gravis Xterminator Digital gamepad, which has a little throttle on it, but when i'm in the ATV, i can't move forward at all. I can turn and shoot and go through the different menus (all via the gamepad), but the stupid truck just won't move forward.

I also noticed that there is an option to turn the throttle on or off, in the joystick configuration. If i turn the throttle off, then what keys do i use? I looked in the manual and the keyboard commands file and i missed them if they were there.

I don't know if this problem is in the 3rd mission or not, because i haven't tried it yet, but i'm assuming that it would be there too, as the ship needs a throttle also.

Also, what kind of joystick/gamepad are other ppl useing - out of curiosity?

Thanks.

Share this post


Link to post
Share on other sites

Has the hyperjump.avi file been implemented in the demo?

It runs in Media Player and Creative Playcenter, but I can't see it in-game.

Share this post


Link to post
Share on other sites

That animation is unused and will be deleted at some point. The hyperjump animation is now done with real-time effects.

Share this post


Link to post
Share on other sites

I've started playing the second scenario and it's pissing me off.

Here is a typical situation that I encounter in this scenario:

Scenario begins --> I set the throttle to maximum --> Three Insurgent aircraft attack me --> I take evasive action --> I am blown to bits.

Average playing time: 15 seconds.

I've tried taking cover, but the enemy guns go straight through.

I've tried zigging and zagging, but I'm still bombarded by rockets.

I've tried bombarding them with Radix missiles, but their guns keep ripping me up before the missiles hit.

As soon as their guns start hitting me, it's game over; no matter what evasive maneuvers I make, they stay on me.

I need some hints. I REALLY need some hints.

[ 07-26-2001: Message edited by: Menchise ]

Share this post


Link to post
Share on other sites

quote:

Originally posted by Rico Jansen:

Ehm, have you considered raising shield?

I didn't realise ATVs had shields.

And yes Menchise, I get the same problem. The only way to avoid getting killed immediately is to put your throttle on full, and drive behind some of the bigger buildings. Then you pop out to shoot some stuff, and THEN invariably get blown to bits.

At least you last longer that way

While I'm here, anyone thought about the 'giant planet and corrupted model associated with Bonus Ep2 mission (GPCMABEp2M) syndrome' I mentioned in a previous post?

Share this post


Link to post
Share on other sites
Guest $iLk

When I install Episode II bonus mission I get a HUGE ASS Planet that almost swallows the space station that appears in Episode II mission I...

It doesn't seem to effect the bonus scenario... perhaps it is because it has overwritten planet attributes for the other mission?

Anyhoo just letting you know you aren't the only one.

Share this post


Link to post
Share on other sites

As I have written before, the E1 and E2 demos use a different kernel.

Also, the bonus mission was designed for the E2 demo. And its data files contain the final sizes for those planets. In the previous E1 kernel, they had the default sizes (smaller).

Share this post


Link to post
Share on other sites

Those big planets don't half look polygonal though....

Have you come across the invisible models though? To re-iterate; if I die in mission 2 (marine) or 4 (pilot) and restart the mission, most of vehicle/fighter is missing. For instance, with the ATV only the turret is visible, and with the fighter only the tail fins and nose cone.

Share this post


Link to post
Share on other sites

Thats been fixed. The kernel wasn't being properly re-initialized if you quit/die and start a new game from the main menu without fully quitting to the OS.

Just quit all the way out to the OS, and restart.

Share this post


Link to post
Share on other sites

Please forgive me, was thinking capital ships, like a BC. You know, allmost made an all-nighter. Wasn't using my brains.

(hides behind a bulkhead)

Share this post


Link to post
Share on other sites
Guest Hellbinder[CE]

I have this little problem....

In mission one, I just fly off to the planet to do some exploring.

Problem. After planetfall. Even with AP turned on in either mode, when i go to tacops to check things out My ship instantly falls thousands of feet ti the ocean floor. It is very broken at that point and i have to star all over....

I tried several things. No matter what i try the second i switch to tacops game over. the big bad boom. I am quite sure its because im doing something wrong.

Also, I searched the key commands but found no way to accelerate time. Is there a unlistd key command that does this in the demo?

Share this post


Link to post
Share on other sites

it is a known issue that is under investigation and might be fixed... I'd have to check the VCF to know for sure.

Share this post


Link to post
Share on other sites
Guest Hellbinder[CE]

hmmm, had a thought.

SC.

I am planning to upgrade my computer in september. I am still tossing around weather I will get an Athlon or go for the mid range P4. (currently I have a p3 866)

Which processor will benefit BCM the most? do you have a lot of SEE/2 coding in the game? Or will the more "raw" FPU power of the Athlon do just as well?

Share this post


Link to post
Share on other sites

quote:


it is a known issue that is under investigation and might be fixed... I'd have to check the VCF to know for sure.

Theres no might, it will be fixed....once I find out what's causing it I suspect that when you go into Tacops, because it defaults to the center of the region, which has a different altitude, the view pos gets reset when you switch back. So, if the Tacops alt was, say, 5K' and you were at, say 3K', it will attempt to reset you back at the lower alt, resulting in your alt taking a dip, hence the damage.

Its a pretty complex piece of code, which I don't particularly want to mess with atm. The work around is to stay in VTOL before going to Tacops (when on a planet) either on the ground or at a high alt.

quote:


I am planning to upgrade my computer in september. I am still tossing around weather I will get an Athlon or go for the mid range P4. (currently I have a p3 866)

Which processor will benefit BCM the most? do you have a lot of SEE/2 coding in the game? Or will the more "raw" FPU power of the Athlon do just as well?


You can go with any P4 (do you really need a P4?) or an Athlon or Intel 1Ghz+, to pair with your Kyro-II

I'm not doing *any* chip specific optimizations. I'm relying on the drivers for that. The chips are so fast now, that its just not worth the extra dev time for me.

Also, the results are negligible.

You really need a TnL card if you're going to be running BCM at anything higher than 800x600x32 with all options turned on. As I've said before, BCM can and will bring that Kyro-II to its knees, without breaking a sweat.

If you have a P3 866, I would consider just getting a P3 1Ghz+ chip (if your current mobo supports it) and some PC133 memory (about 256MB+), rather than wasting money on a new mobo, chip etc

On one of my WIN2K rigs, I am running a P3-1Ghz on an Asus CUV4X-E mobo, 512MB RAM, a GF2 GTS vid card, swap file fixed at 500MB and can play BCM, with a massive fleet battle (using bitmap, instead of particle conrails), with MP3 music, at 1024x768x32 quite comfortably and sustain about 40fps sometimes. For IA scenarios (which the demo uses), I can go up to 1280x1024x32 and still play quite comfortably.

Share this post


Link to post
Share on other sites
Guest Hellbinder[CE]

Thank you for the info.

Currently my system is this

P3 866

Intel 815EEA motherboard

256mb Pc 133 ram

Windows 2000

Prohet 4500 (kyro 2)

P3's only go up to 1ghz (currently) and my mobo does support it. I did not think that extra 133mhz would up my performance that much. I had also been tossing around doing exactly what you suggested and just maxing out my mobo. there is always next year to. Thats when Doom2000, GCO and the other MONSTER requirment games are comming out.

AS far as my vid card. I fully intend on getting the Kyro3 (4 pipelines, DDR, T&L) in november or december when it comes out. I also have my eye on a XBA card if they actually ever ship something. Now that would be news!

Share this post


Link to post
Share on other sites

With your rig, I would seriously consider just getting the 1Ghz cpu and an extra stick of 256MB PC133 memory, and calling it day.

Then, start saving for the end of year blowout sales.

Yep, am waiting for that K3 myself, actually.

Share this post


Link to post
Share on other sites

quote:

P3's only go up to 1ghz (currently) and my mobo does support it. I did not think that extra 133mhz would up my performance that much.

Apart from the clock speed, the P3 1GHz CPUs also have a 256kb L2 cache, which makes it even faster than some of the low end P4s.

Share this post


Link to post
Share on other sites
Guest Hellbinder[CE]

all P3's from 733mhz and up are based on the newer core and have 256k internal cache.

Please, someone tell me what the key to increase the speed of time in the BCM demo.

Update: After some searching i think i found it.

[ctrl-alt-shift-t]

I will try this now and see what happens. The more I play the demo, the more I realize that the game to a large degree is like digging for gold. Its about taking the time and effort to unearth the gems. The more you sift through the vast quantities of information and possabilities, the more rewarding the game becomes.

I almost feel like im cheapening the experience by asking gameplay oriented questions.

Enough pondering, back to the game.

[ 07-28-2001: Message edited by: Hellbinder[CE] ]

[ 07-28-2001: Message edited by: Hellbinder[CE] ]

Share this post


Link to post
Share on other sites

You can't accelerate time in BCM because it screws up the AI processing. Thats why this feature was removed back in BC3K v2.0x.

I dunno where you found that key combo you posted, but its certainly NOT from the BCM demo keyboard commands file. Is it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×