Jump to content
3000AD Forums
Sign in to follow this  
alvarete

game crashes

Recommended Posts

Hello, I have been playing the last year with the BCM gold in a coputer with the win98 system and everithing run succesfully. The problems begun when i put windows XP, then the game beguns, but suddenly drops me and close the game.

I have a AMD with 1.3 gHz, 256 Mb RAM and a nVidia Gforce 32 Mb

Can you help me please?

Share this post


Link to post
Share on other sites

Please READ THIS and put you system info in your sig as requested before posting again.

Thanks.

Share this post


Link to post
Share on other sites

First off your system specs are missing way too much information for anyone willing to help you. I would suggest that you finish filling out your system specs so we can all see what drivers you are using.

Also have you read the troubleshooting FAQ provided with the game? I have a funny feeling with the vague description that you gave in your post that your problem is this;

quote:

Q. I just bought a new system that came with winXP Service Pack 1 and the game won't play the intro or explosions

A. With the September 2002 update to Windows XP (known as Service Pack 1), Microsoft is no longer distributing any version of

the Indeo codecs with its operating system. This only affects users with new PCs that are shipping with Windows XP Service

Pack 1, or clean installs of Windows XP SP1 on an older system. Installation upgrades of SP1 and the use of Windows Update

does not remove existing Indeo codecs from your system.

Microsoft have a fix via their KB 327979 article. If that does not work, you could try downloading and installing the 5.1l legacy Indeo codec AT YOUR OWN RISK!

That of course was taken directly from the FAQ and is just a guess since as I said your System profile is incomplete and your post is very vague. I could keep guessing until I'm blue in the face but you guessed it, I'm not about to do that.

If you have not read the FAQ then I would suggest that you start there and try all steps pertaining to your machine. If after doing all of the above you still can't get it to work come back here and give us more details including all of the things that you have tried.

Again, since the only information that you have provided is a switch in O/S from 98 to XP make sure ALL of your drivers are updated to the latest available for your rig.

Share this post


Link to post
Share on other sites

Sorry, my english is not as good as yours, and I have not the capacity to be so funny with my trouble as you. I┬┤m not stupid, of course I read the FAQ, and I notice, that If the game works on my computer with Win 98 is not a hardwarwe problem, is a software problem. I have done all the things the FAQ said, even I have download a crack that make the game run with no CD, and the problem contiues. I have read near all the forum, and I notice that a lot of people have the same problem with the game, and the solutions are very differents all of them. I have download new drivers, and the game crashes exactly the same.

Now i have a little difference, the game crashes and go to the desktop, but still working on the sistem tray (i thing this is the name) so i make a click on it and continues working. But at the end the game crashes compleatly.

To finish, i have a lot of games on my computer and all of them works without any problem. A lot of them needs more sistem specs to work and all of them works. So is easy to thing that the problem comes from software, not from hardware.

Share this post


Link to post
Share on other sites

Please be nice here on the boards.

The only thig that GORDON was asking is that you fil all the fields in the system specification, included the driver versions; otherwise techies cannot be of any help because they lack relevant info on your machine.

Share this post


Link to post
Share on other sites
Guest Remo Williams

Besides that Denny, as he said in his first post the game was running fine with windows 98 then he switched to XP and started having problems. Meaning the problem isn't the game as usual, but an improperly configured OS. If he don't want to provide the needed info in his profile so we can attempt to help, and were under no obligation to do so BTW then I'll just close the thread. Especially since its not an issue with the game.

Share this post


Link to post
Share on other sites

quote:

Originally posted by alvarete:

To finish, i have a lot of games on my computer and all of them works without any problem. A lot of them needs more sistem specs to work and all of them works. So is easy to thing that the problem comes from software, not from hardware.

As for me, I have a lot of games that work and require some fixing to get running on Windows 2000 which uses the same NT as WindowsXP. Anyway, I digress, the techies need a few things from you:

1: Motherboard Make and Model. The tech's need this because they need to know is it a VIA or SIS chipset. If it's an older motherboard, you might need to update the Bios for WindowsXP so we need your bios info also.

2: Video card driver version. I see you have an NVIDIA TNT. Is this card an actual NVIDIA card or made by a third party? In either case we need to know the driver version you have installed.

3: 32mb that's rather low for a WindowsXP OS especially when you are trying to run a BC game.

4: Soundcard. What soundblaster is it. Creative has many flavors from Soundblaster16-Audigy 2. Techies need to know what model and driver versions you have.

5: DirectX 9 which one is it A, B or C.

That's about it for now.

Share this post


Link to post
Share on other sites

quote:

Originally posted by LostInSpace:

3: 32mb that's rather low for a WindowsXP OS especially when you are trying to run a BC game.


EDIT: 32mb video memory that is rather cutting it especially for newer games coming out.

Share this post


Link to post
Share on other sites

quote:

Sorry, my english is not as good as yours, and I have not the capacity to be so funny with my trouble as you.

There is no place in my post where I am making fun of your problem so lets not go there.

How could you say it's a problem with the software when you yourself said that you've been playing the game for a year on a Win98 system. I have been running this game on my WinXP system and it does not crash when I start the game so it's not a software problem.

I just checked your system profile and you still have not provided us with any important information regarding your machine, without it you're on your own. Software emulation programs are known to cause problems with some games, did you try to disable it and see if the game will run? Do a search of these boards and you will find those that were running such software and what they did to resolve THEIR problem.

Again, without you providing us with your COMPLETE system specs you will not find help from anyone, we are not paid to help we do it of our own free will. Based on your last reponse to my post I'll will not be providing you with any additional help, your on your own unless someone else wants to help you with YOUR problem.

Share this post


Link to post
Share on other sites

You┬┤re right, i┬┤m sorry for my last post, I┬┤m trying to change my system profile, but I don┬┤t find were is the link to do it, anyway I have to find the documentation of my pc.

Share this post


Link to post
Share on other sites

Thanks for taking this into the right way.

Head HERE and login with your info to fill your system spec page.

Share this post


Link to post
Share on other sites

quote:

Originally posted by alvarete:

Hello, I have been playing the last year with The problems begun when i put windows XP, then the game beguns, but suddenly drops me and close the game.

Where exactly in the game do you get to before it crashes to the desktop?

Share this post


Link to post
Share on other sites

Well, I have already complete the system profile, the moderboard type is misterious for me, if you need it I can open the computer and see if i found the name.

The game crashes aleatory, for example, when i beggin in the default base near the earth, and i try to arrive to any space jump point, sometimes i can cross the space jump point, sometimes no. The last try I begun fightin betweem a isurgent violon and when i deestroy it the game crash.

I have try too with a no cd crack i found, and the problem continues, but the first time, the game onli drop me to the desktop, but without closing the game. But at the end the second time close the game and put me in the desktop as if I never open the BCM.

Is a nice game, and i really enjoy it in the win98, so i will like to play once again, if you can help me I┬┤ll be very pleased.

Share this post


Link to post
Share on other sites
Guest Arthur_Dent1976

Hi there alvarete, thanks for updating your system profile. While I personally own UC instead of BCMG and thus cannot give any advise that has been tested on my own system, I have some quick remarks that may be of use:

First of all, it would appear your system meets the minimum system requirements. However, I'm a bit unsure about your graphics card: The Riva TNT2 Model64 is quite ancient (released in 1999 if i'm correct) and might not be directX 8 compatible. Besides that, it's a budget version of the normal TNT2 card wich runs slower. Since you've succeeded in running the game in Win98 however, I would assume the crashes aren't directly related to this piece of hardware.

Second, as Remo already mentioned, your problems might be related to your Win XP configuration. Are you running a lot of programs in the background? Virus scanners, for instance, messenger programs or even more obscure pieces of code? I'd suggest re-installing Win XP, updating it with all service packs and fixes, and re-applying all the latest drivers for your hardware. See if the game works then, and well, don't go overboard installing additional software that runs in the background

Third, I read you've tried a no-cd crack. Applying such software could be potentially dangerous (who knows what hidden code lurks in such executables), not to mention useless: the only thing you will bypass is the copy-protection wich will not give you problems anyway since you already own the original.

Hope this helps a bit..!

Share this post


Link to post
Share on other sites

Thanks Arthur.

I dont thing that the problems come from lots of programs runing in the background, because bcm was wan of the first programs that I install on my computer before the change to XP.

I thing perhaps the problem comes for low RAM memory, people said that 250Mb are not enaugh to run properly under XP.

Now i┬┤m runing the game with the parameter -n, and i have been playing with no problem till i destroy the first enemy. I have heard the explosion and the game have send me to the desktop but with a message that said that the program has made an non valid operation and it┬┤s going to be closed,perhaps this can help you.

More, with this parameter i can┬┤t see the earth, i appears as a black hole, but sometimes appears with all the colors, The suttle icon and all the icons of the bridge also do the same.

Share this post


Link to post
Share on other sites
Guest Arthur_Dent1976

Hi alvarete, a quick reply before I catch my train: the order in wich you install software onto your machine isn't really important as far as programs running in the background are concerned: A game can crash due to other software no matter if it is installed before or after the software. That said, I'm wondering if you have perhaps installed two operating systems onto your PC. Your second sentence of your last reply seems to indicate so. If you have installed BCMG on a partition running Win98 and then try to run it using your newly installed WinXP, you're bound to run into problems. Then again, this might have been just a grammatical error

As for the use of system resources: Yes, WinXP uses more than Win98 and 256MB of RAM is a rather small amount. I'd suggest an upgrade to at least 512MB if you can afford it, and not just for running BCMG: You'll notice smoother performance all over. Also, you might want to tweak WinXP a bit so it runs a little more efficient. A good guide to tweaking can be found here. Be advised that some tweaks are rather obscure and quite advanced. If you're unsure about it or unfamiliar with the matter, the guide is probably best left alone. BCMG should work on a standard installation of WinXP anyway, provided your systems specs are up to par.

Hope that was of some help again

Share this post


Link to post
Share on other sites

I have only one OS in my computer, and i tell the order in wich I install the software because i have no antivirus program or another things runing beside.

The computer was nearly nude, so the backgrownd programs was not the problem. Anyway thanks for your time.

I thing is something with the sound or the video, but not hardware, if someone reed my specs perhaps can tell me if the drivers are the last ones (I┬┤ve downloaded it as if they are)

Share this post


Link to post
Share on other sites

Ok, i┬┤ve found ewrw the game crashes, is just when i select any space object, f.e. when i select a space jump point. The game send me to the desktop, but still working. Is like if I press the alt+tab, but without doing. Wen i return to the game and i select another space jump point the game crash completley. I have notice that this doesn┬┤t happend when I select any craft or station. Even with the planets.

Strange, isn┬┤t it?

Share this post


Link to post
Share on other sites
Guest Arthur_Dent1976

You are running the latest version of the game right? E.g. BCMG version 1.01.07, patched from the installation directory like the faq says? And you've installed indeo codecs Gordon referred to earlier? Maybe these could be the culprits...

Share this post


Link to post
Share on other sites

I have uninstall and re-install the game, i have uploaded with the pach, first the 1.01..... and the the last one, the 1.01.07, the game beguns good, but when i select something, crashes. I can see the thing i select on the secreen, and after a second or something like that, is when the game hits me out. I have the Indeo codecs on my computer, the FAQ said that this problem only happend with the WinXP SP1, i have the SP2. But i have look anyway for and I have found it.

I don┬┤t know what┬┤s happening. Perhaps if I run it with the win98 emulator that give windows, I mean in the properties of the BCMG?

Share this post


Link to post
Share on other sites

Try to avoid using the keyboard when jumping or doing anything else that crashes the game ... use the mouse and on-screen menus instead. See if that helps.

Share this post


Link to post
Share on other sites
Guest Arthur_Dent1976

Hmmm... strange. So your pc is properly configured, has the right hardware and you've done a fresh install of BCMG with all the patches applied correctly. The game *should* work properly. The crashes related to the jump points are quite specific, however, and I have no doubt that some BCMG veterans could shed some light on this situation.

I still have a feeling the crashes are system/setup related. You see, most fans run the game without problems. BCMG has 'matured' quite well in this respect: From what I gather from the game's VCF, it's only very occasionally that a new bug is still found. The game is probably the most stable (supported) 3000ad title on the market right now.

As for your setup, what version of DirectX 9 are you using? (a, b or c?). And does the TNT2 graphics card use nvidia drivers? If that is the case, your version is a bit out of date. (Current is 66.93) You can click here to download the latest drivers for your videocard and here for the most recent soundcarddrivers. The last site has an autoupdate function that might come in handy if you're unsure about the specific type of SB Live! you've got in your PC.

Lastly.. I would strongly advise against running Win98 and BCMG via an emulator á la vmware on your machine. It would result in a tremendous strain on your system's resources. If you want to use Win98 for BCMG, I'd install the OS on a seperate partition and use a dual-boot sequence dialog to let you choose wich OS to run every time you start your pc.

Share this post


Link to post
Share on other sites

ok, I have update the video drivers, the sound drivers were update(d) yesterday. The problem still exactly the same, it beguns when i select the jump point. when i press it take near a second to appear in the CVD, anything else happends, i can play all the time like that, but when I select another jump point is when the game crash. I have observe that now I can┬┤t hardly see the mouse point appears and disappear when I make a clik at any screen it appears blinking (is the word?)

Ah, the directx is the 9c now i┬┤m runing the game with the graphic aceleretor with one step down, and in the dxdiag i have made the same, as the FAQ said.

Share this post


Link to post
Share on other sites

When i select a craft or a starbase the image in the same moment that i press the button, so the problem is only with the left side of the screen, the NID. ;-)

Share this post


Link to post
Share on other sites

Have you tried going into the games Graphic options and tweak everything down or turning things off as much as possible and running the game that way. If the game runs with no problem with the low graphics options, start turning things up again, one at a time of course, and see what happens.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×